LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   WineX newbie (https://www.linuxquestions.org/questions/linux-newbie-8/winex-newbie-92334/)

sammckee 09-13-2003 09:14 AM

WineX newbie
 
Okay, I downloaded the WineX stuff from CVS and did the build (I make it sound easy, don't I? :D It wasn't). Now I want to run it.

First I get a message that says:


Enter path for first drive (C:) (Default: /home/javaguy/c)
Newbie, press enter


(javaguy is my login name, as you've probably guessed.) I'm a newbie, so I pressed enter. Then I get:

[i]Making fake C drive...
sed: can't read /usr/lib/cvswinex/bin/config: No such file of directory
bash: line 106: /home/javaguy/.w.reg: No such file or directory

Registry Install failed...
Remove /home/javaguy/.cvswinex to try again.

Edit the /home/javaguy/.cvswinex/config file to fit your system[i]

Any idea what I'm doing wrong? I'm suffering from serious StarCraft withdrawal, but I'd rather see Alan Greenspan naked than go back to Windoze to play it.

ZenithRS 09-13-2003 05:03 PM

What distro you using? Not that it should matter.

Don't worry about the CVS. Just download the latest Wine tarball, which at the moment is

http://www.ibiblio.org/pub/Linux/ALP...0030911.tar.gz

Download it to your home directory

In a shell, CD to your home directory, and the the shell prompt

tar zxvf Wine-20030911.tar.gz

cd wine-20030911/tools

./wineinstall

The rest should pretty much take care of itself, or you may have to satisfy a few dependencies.

sammckee 09-13-2003 05:30 PM

I'm using Mandrake 9.1.

That link looks like a Wine installation, not Winex. Will it work for me?

ZenithRS 09-13-2003 07:34 PM

Oh, yeah, sorry... read your post to quick ;)

sammckee 09-14-2003 05:02 PM

Okay, so...Anyone have any advice?

TheOneAndOnlySM 09-14-2003 05:23 PM

not to burst your bubble or anything, but the cvs build of winex (from what i've heard) misses quite of bit of directx emulation stuff so u probably won't have a lot of luck with it

as for winex in general, make sure you have an nvidia card and installed drivers from nvidia.com otherwise don't bother

o, and i've never tried winex, i'm basing my words here from what i have heard from others and from things i've read myself


"play windows games on windows, play linux games on linux", as one user put it, even if u despise windows (i know i do, but i have no choice but to use it since i'm a gamer, but hopefully i can try winex sometime soon and post good results)

sammckee 09-14-2003 05:32 PM

I've heard a number of people say they've never been able to do a good cvs build, but I've also heard a number of people say that one just has to do it right. There are web sites showing screen shots of both StarCraft and Jedi Outcast under cvs winex, some I'm inclined to trust the later.

I have an nvidia card, and I have successfully installed the Linux drivers for it.

Now I have a new problem. I had to reboot my system. Now when I try to run winex, instead of saying it can't read the config file it just says
bash: winex: command not found

This reminds me of what happens to my network. Every time I reboot Linux, I have no internet access and have to reconfigure my connection from scratch. That's annoying, but at least I know how to do it. If winex somehow disappears from my system when I reboot, as it seems to have done, then I'm clueless. Help!

DrOzz 09-14-2003 08:54 PM

well i use the cvs build of winex and games like SOF2 and counter-strike run perfectly fine....i can tell you one thing though..when i installed the cvs version of winex, the command was "wine" and not winex, i have no idea why that is, but it dont' matter to me cause it works...so maybe try typing "wine" instead of "winex" and see if that is the case with you also..

sammckee 09-14-2003 09:05 PM

I tried "wine" as the command, and now I get:
wine: error while loading shared libraries: libntdll.so: cannot open shared object file: No such file or directory

It doesn't matter to me whether the command is wine or winex, but I'm curious to know why the winex command ran but gave me an error message about the config file before, whereas it's not even a recognized command since I rebooted. It's all the same to me, of course--I just like to know why things happen the way they do.

sammckee 09-16-2003 10:25 AM

Update: I tried a rebuild. Now when I run it I get an error that says no such file or directory /home/javaguy/.wine.

:(

aaa 09-16-2003 11:21 AM

In wine, when you get an error like that, it means you haven't configured properly. The .wine directory is where the config file should be. Wine and winex are very similar.

sammckee 09-16-2003 12:12 PM

So...What do I need to do then? :)

Sorry, but I really am a complete newbie to Linux. I did the build just like the documentation said, or so I thought anyway.

compjinx 09-16-2003 01:13 PM

I don't know it this helps at all or not, but a while back I was looking up Linux gaming info and came across "Complete Starcraft installation and running guide for Linux+Wine-systems"... I don't know if it helps, your problems are in the installation, but maybe you will find it usefull.

http://koti.mbnet.fi/~hoppq/sc-howto.html
I did notice that it only uses Wine, not WineX (I could have misread).

DrOzz 09-16-2003 01:48 PM

no no, when it says cannot find .wine then like said above, you don't have it configured properly...which means in turn that you have to setup your fake windows drive...you can get something like winetools to automate this for you..

sammckee 09-16-2003 05:30 PM

Okay, where do I get winetools?

Also, if winetools automates something not too terribly complicated, I'd like to learn at least a little about how to do it manually so I'm not helpless if I find myself in a situation the automated tool can't handle.


All times are GMT -5. The time now is 03:36 AM.