-   Linux - Newbie (
-   -   wine: installing win apps. using wine on mandrake10 (

dexmax 09-05-2005 07:53 AM

wine: installing win apps. using wine on mandrake10

Its my first time using Linux(started this morning), and I have managed to install and configure MandrakeLinux10 without any problems. Everything is working fine, network(already have 5 Linux machines on network now), internet-thru a router, and hardware(hopefully no problems here), etc.
**I was amazed. everything was done in less than 20mins!!!!**

My main problem is with wine. I have read the documentation on WineHQ's site but I cant seem to make it work.

I installed WINE from the installer CD(4cds) packaged with my mandrake installer.

Anyway, i get this error when trying to install programs using WINE.

when installing Sierra CS Retail
install path: c:\sierra\

when i run: wine path\to\windows\prog.exe
- installshield runs normally, as it does using MS OSes.
but when copying of files start I get this error:

"The file C:\SIERRA\COUNTER-STRIKE\UNWISE.EXE could not be opened. Please check that your disk is not full and that you have access to the destination directory. Path not found.'

so i tried manually copying the files to "/var/lib/wine" which was the path for DRIVE C:\ (Wine configurator), but it seems write protected.

********(excuse my ignorance, I am a MSDOS/MSWIN user since 1988)********

Thanks much!!


Diewi 09-05-2005 04:29 PM

You can stop trying to install CS retail. Even if you can manage the application to start it will crash
when you want to start a game. Use steam instead.

Mara 09-05-2005 04:40 PM

You should have a config file in .wine subdirectory of your home dir. It has quite clear syntax. There are sections describing emulated drives. In short, it says that c: is /opt/wine or something like that. Example:

[Drive C]
"Path" = "/opt/wine"
"Type" = "hd"
"Label" = "MS-DOS"
"Filesystem" = "win95"

In my case C: is /opt/wine. Look how it's in yours. Then see if you have write access to that dir. If it's not in /home/yourname you probably don't. Consider installing the program in your home (one of the drives probably points there). That's probably the easiest solution.

If you don't want that, you can change permissions on that dir (browse to it in konqueror, permission are in Properties menu after right-clicking on a dir). Make sure your user has write access. In most cases it means that you may:
a) change ownership to yourname user
b) set 'write' permission for 'others'

All times are GMT -5. The time now is 05:23 PM.