LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-10-2009, 08:52 AM   #1
daniell
Member
 
Registered: Jul 2008
Posts: 152

Rep: Reputation: 15
Windows Borders Disappeared in Gnome


My problem started when I uninstalled then reinstalled my video driver. Now programs such as Firefox and Thunderbird cannot be minimized. The square on the upper right is gone. I am at a loss what to do. Jaye if you are here, please help. I will humbly accept help from anyone.

Thanks

Last edited by daniell; 09-10-2009 at 10:37 AM. Reason: More Appropriate Title
 
Old 09-10-2009, 09:15 AM   #2
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,074

Rep: Reputation: 387Reputation: 387Reputation: 387Reputation: 387
I doubt that the video driver has anything to do with this, since it's a feature of the window manager.

Can you see the title bar of the window at all? Maybe you are using the fullscreen mode, it can be switched on/off using f11 in firefox, don't know about tbird. If that's not it, it's probable that your wm and firefox are screwing each other so I'd start by trying an alternate window manager, just to test.
 
Old 09-10-2009, 09:22 AM   #3
daniell
Member
 
Registered: Jul 2008
Posts: 152

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by i92guboj View Post
I doubt that the video driver has anything to do with this, since it's a feature of the window manager.

Can you see the title bar of the window at all? Maybe you are using the fullscreen mode, it can be switched on/off using f11 in firefox, don't know about tbird. If that's not it, it's probable that your wm and firefox are screwing each other so I'd start by trying an alternate window manager, just to test.
I cannot see the title bar of the window. All programs are affected. I cannot move them or minimize them.I tried F11 and it did no good.

Thanks
 
Old 09-10-2009, 09:25 AM   #4
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,074

Rep: Reputation: 387Reputation: 387Reputation: 387Reputation: 387
Quote:
Originally Posted by daniell View Post
I cannot see the title bar of the window. All programs are affected. I cannot move them or minimize them.I tried F11 and it did no good.

Thanks
In that case it's your window manager which is screwed. What desktop or window manager are you using?
 
Old 09-10-2009, 09:27 AM   #5
cola
Senior Member
 
Registered: Sep 2007
Location: Dhaka,Bangladesh
Distribution: Debian
Posts: 1,031

Rep: Reputation: 63
Quote:
Originally Posted by daniell View Post
My problem started when I uninstalled then reinstalled my video driver. Now programs such as Firefox and Thunderbird cannot be minimized. The square on the upper right is gone. I am at a loss what to do. Jaye if you are here, please help. I will humbly accept help from anyone.

Thanks
Can you post screenshots?
 
Old 09-10-2009, 09:27 AM   #6
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
I'm not sure either that the video driver itself has/had anything to do with the problem.

Daniell, did you do *anything* else, either in a configuration area, or a "System Settings" or "Desktop Settings" type of box, between reinstalling the video driver and now?

Also, for the benefit of other readers: Are you using an Ubuntu with a GNOME desktop environment? Please verify.

It sounds like you've selected an option something like "Hide Window Borders" or something to this effect. I don't use GNOME personally, so I can't point you towards the settings area where you might find such an option, but another member may be able to do so.

Sasha
 
Old 09-10-2009, 09:27 AM   #7
daniell
Member
 
Registered: Jul 2008
Posts: 152

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by i92guboj View Post
In that case it's your window manager which is screwed. What desktop or window manager are you using?
I must plead ignorance. All I know is that I am using Ubuntu 9.04.
 
Old 09-10-2009, 09:28 AM   #8
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Quote:
Originally Posted by daniell View Post
I must plead ignorance. All I know is that I am using Ubuntu 9.04.
OK, so sounds like GNOME..
 
Old 09-10-2009, 09:32 AM   #9
daniell
Member
 
Registered: Jul 2008
Posts: 152

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by GrapefruiTgirl View Post
OK, so sounds like GNOME..
Suggestions Please!
 
Old 09-10-2009, 09:55 AM   #10
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,074

Rep: Reputation: 387Reputation: 387Reputation: 387Reputation: 387
Well, if he's using Ubuntu with the default gnome, there's a chance that the video driver has something to do. If for some reason opengl stopped working and he is using compiz (3d desktop or whatever Ubuntu -again- fakes/call it) then the window decorations might not show. I think that Ubuntu puts an incon in the tray to disable/enable the 3d desktop, if so, try disabling it. You will lose the desktop effects but anyway right now you can't put them to an use, so...

If that doesn't work or you can't find an option then a gnome user will have to help you. The basics is that you will have to launch a terminal and kill emerald and compiz, and use metacity to replace them. However I am not sure of the syntax since I haven't used gnome for years, and I don't want to misguide you with my attempts.
 
Old 09-10-2009, 09:58 AM   #11
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Quote:
Originally Posted by i92guboj View Post
Well, if he's using Ubuntu with the default gnome, there's a chance that the video driver has something to do. If for some reason opengl stopped working and he is using compiz (3d desktop or whatever Ubuntu -again- fakes/call it) then the window decorations might not show. I think that Ubuntu puts an incon in the tray to disable/enable the 3d desktop, if so, try disabling it. You will lose the desktop effects but anyway right now you can't put them to an use, so...
OK, that sounds reasonable to me.
Quote:
... However I am not sure of the syntax since I haven't used gnome for years, and I don't want to misguide you with my attempts.
Same here; all I (could do/tried to do) did was help identify it was GNOME. I don't use it either, so a GNOME user will have to pop in and help further with that.

Sasha
 
Old 09-10-2009, 10:02 AM   #12
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,074

Rep: Reputation: 387Reputation: 387Reputation: 387Reputation: 387
In the while, I suggest changing the title of the thread to something more sensible, like "Window borders disappeared in Gnome", that will give any possible helper a clearer vision of your problem, which might otherwise pass unnoticed to them.

To do so, edit the first post of the thread and change the title field.
 
Old 09-10-2009, 10:03 AM   #13
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Try system->preferences->appearance, tab visual effects and change to none
 
Old 09-10-2009, 10:05 AM   #14
daniell
Member
 
Registered: Jul 2008
Posts: 152

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Wim Sturkenboom View Post
Try system->preferences->appearance, tab visual effects and change to none
Did that already.
 
Old 09-10-2009, 10:11 AM   #15
daniell
Member
 
Registered: Jul 2008
Posts: 152

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by i92guboj View Post
In the while, I suggest changing the title of the thread to something more sensible, like "Window borders disappeared in Gnome", that will give any possible helper a clearer vision of your problem, which might otherwise pass unnoticed to them.

To do so, edit the first post of the thread and change the title field.
How do I change the title?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to minimize all windows? mfeat Red Hat 16 10-31-2017 09:49 PM
How Can I Minimize Programs To Tray ? Felpipe SUSE / openSUSE 2 04-30-2007 06:27 AM
Minimize all windows tranh2 Linux - Newbie 2 08-28-2006 07:59 PM
minimize all puishor Linux - General 1 08-31-2005 07:10 AM
Minimize problem neozero62 Fedora 1 02-24-2004 01:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration