LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-07-2007, 10:16 PM   #1
tommytomthms5
Member
 
Registered: Sep 2007
Distribution: debian based
Posts: 305

Rep: Reputation: 30
windows ask for pass.... RESOLVED


i did a quick setup in samba on my server

Code:
[test1]
comment = blahh
volume name = test1
path = /mnt/disk1
writeable = yes
i slapped stuff like that into the /etc/samba/smb.conf


so i reboot and goto find this stuff on windows and get prompted with username + pass, what is that all about????

my question is how do i get to my folders????

Last edited by tommytomthms5; 09-08-2007 at 11:21 PM. Reason: saying its resolved
 
Old 09-07-2007, 11:17 PM   #2
andresj
LQ Newbie
 
Registered: Sep 2007
Posts: 1

Rep: Reputation: 0
I have the same

i have the same problem. I don't know how to setup samba to share my directories anonymously through the (local) network...

do someone know about this? I've tried looking tutorials about samba, etc. but they talk about users, or they are incomplete (asume that it just works)...
 
Old 09-07-2007, 11:28 PM   #3
tommytomthms5
Member
 
Registered: Sep 2007
Distribution: debian based
Posts: 305

Original Poster
Rep: Reputation: 30
yea it said some stuff in one i read about having to type some really long codes to create users and passwords and then some things for windows on logging into it and all...

im just confused cant i just bipass logging in all together

Last edited by tommytomthms5; 09-08-2007 at 11:24 PM. Reason: simplifing
 
Old 09-08-2007, 01:55 AM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677
It sounds like you want a configuration similar to one of the first ones in the Samba 3 by Example book. It is supplied either by the samba package or a samba-doc package. You will still need to set up the directory ownership & permissions, and add a user owning the share, but using "force owner" and "force group" it won't matter which user or password you entered.
 
Old 09-08-2007, 10:01 AM   #5
tommytomthms5
Member
 
Registered: Sep 2007
Distribution: debian based
Posts: 305

Original Poster
Rep: Reputation: 30
thats the only way???
 
Old 09-08-2007, 11:51 AM   #6
tommytomthms5
Member
 
Registered: Sep 2007
Distribution: debian based
Posts: 305

Original Poster
Rep: Reputation: 30
my new smb.conf looks like this

Code:
[global]
workgroup = Debian
netbios name = Debian
security = user

[test1]
comment = blah
volume name = disk1
path = /mnt/disk1
public = yes
writeable = yes

[test2]
comment = blah
volume name = disk2
path = /mnt/disk2
public = yes
writeable = yes

[test3]
comment = blah
volume name = disk3
path = /root/files
public = yes
writeable = yes

its still bad......

Last edited by tommytomthms5; 09-08-2007 at 11:25 PM.
 
Old 09-08-2007, 12:53 PM   #7
drakebasher
Member
 
Registered: Aug 2004
Location: Proprio Qui
Distribution: Debian
Posts: 85

Rep: Reputation: 16
I think the user name and password must be the same on both the Linux system and the windows system. It works for me with WinNT4.0 and a Debian server.
 
Old 09-08-2007, 12:56 PM   #8
tommytomthms5
Member
 
Registered: Sep 2007
Distribution: debian based
Posts: 305

Original Poster
Rep: Reputation: 30
ok ill try that but it sounds like a pain

Last edited by tommytomthms5; 09-08-2007 at 11:25 PM.
 
Old 09-08-2007, 02:25 PM   #9
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677
If you want a public share where you don't need permissions you could use the "guest ok = yes" option.

Here is an example:
For a world writable share, you need to allow "others" access to the directory, and make the share sticky:
drwxrwxrwt 2 root root 4096 2007-07-26 07:53 /home/samba

Code:
[samba]
        path = /home/samba
        read only = No
        guest ok = Yes
        available = Yes
 
Old 09-08-2007, 03:01 PM   #10
tommytomthms5
Member
 
Registered: Sep 2007
Distribution: debian based
Posts: 305

Original Poster
Rep: Reputation: 30
ok thats exactly what i needed to know thank you i think i overloaded mine with to much stuff so ill go minimal

another stupid question do i need to restart the service for the changes to "take"?


line removed but is quoted below....

Last edited by tommytomthms5; 09-08-2007 at 11:26 PM.
 
Old 09-08-2007, 04:53 PM   #11
jimmy512
Member
 
Registered: Oct 2006
Location: London
Distribution: Arch
Posts: 183

Rep: Reputation: 31
Quote:
edit gggrrrrrrr i hate samba who ever made it is a security paranoid dumb ass
Wrong... Whoever made windows was too lazy to bother with proper security. Passwords are something that should be expected, especially when sharing important files which might appear in the /root/ directory.

And yes, the service does need to be restarted (at least I think it does).
 
Old 09-08-2007, 05:48 PM   #12
tommytomthms5
Member
 
Registered: Sep 2007
Distribution: debian based
Posts: 305

Original Poster
Rep: Reputation: 30
can it be restarted without rebooting the computer? rebooting takes me like 10 minutes (literally)

Last edited by tommytomthms5; 09-08-2007 at 11:27 PM.
 
Old 09-08-2007, 06:59 PM   #13
cojo
Member
 
Registered: Feb 2003
Location: St. Louis
Distribution: RedHat 8
Posts: 262

Rep: Reputation: 31
Samba is easy to setup if you read the smb.conf file. It show you step by step what to do. Anyway, here is a quick steps to get it up and running.

1. create an account on your linux box ---> useradd userid
2. create password for samba share ---> smbpasswd -a userid
3. go to your windows box and browser to your linux server
4. select your samba share and type in your samba userid and password
5. Of course, if your samba userid & password match your windows userid and password. Samba will not challenge you for userid and password.

As for restarting the samba, you shouldn't need to reboot your server. All you have to do is service smb restart for Fedora and Red Hat.
 
Old 09-08-2007, 08:49 PM   #14
tommytomthms5
Member
 
Registered: Sep 2007
Distribution: debian based
Posts: 305

Original Poster
Rep: Reputation: 30
whats that command for debian? i tried it says "service: command not found"
 
Old 09-08-2007, 11:15 PM   #15
tommytomthms5
Member
 
Registered: Sep 2007
Distribution: debian based
Posts: 305

Original Poster
Rep: Reputation: 30
problem resolved... i thank all of you for your help

what worked...

keeping smb.conf simple and clean
setting users and passes
setting proper mount points
setting permissions
listening and not being so stubborn
keeping file backups

what needs to be worked on....

having to reboot after every change
some bios problem(s)
my laziness
my patients
other stuff

once again thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba password protected shared Folder Mrpeepers310 Linux - Networking 5 09-18-2010 11:04 AM
hide SAMBA shared folder in other user sasi.rrkay Linux - Software 0 06-26-2007 07:05 AM
I can see SAMBA shared folder in XP but can't access it vishivishi Linux - Networking 6 08-30-2006 02:13 AM
how do i connect to a windows shared folder using samba? winstone5000 Linux - Networking 1 12-19-2005 11:38 AM
Samba problems: can't write to shared folder Nylex Linux - Networking 4 07-19-2005 05:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration