LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   winbind and smb.conf?? (https://www.linuxquestions.org/questions/linux-newbie-8/winbind-and-smb-conf-268735/)

alirezan1 12-21-2004 05:52 AM

winbind and smb.conf??
 
Hello,

I have mandrake 10.1 installed. When I try to do : "winbind start" I get the error message:

"Starting Winbind services: Winbind is not configured in /etc/samba/smb.conf, not starting"

I have no idea what this is about. But, I have two problems:

When I check the status of Samba with SWAT, I get :

"smbd: not running
nmbd: running
winbindd: running"

but when I do samba status I get:
"# samba status
smbd (pid 7077 7076) is running...
nmbd (pid 7086) is running..."

Also, the problem is that when I try to browse the network with smb4k, it does not show the network computers automatically. However, when I search for any computer on the net, it starts to show the network computers.

I don't know what might be wrong, so here is my smb.conf and hoping someone could help me:

# Samba config file created using SWAT
# from 0.0.0.0 (0.0.0.0)
# Date: 2004/12/21 03:00:15

# Global parameters
[global]
workgroup = ARNIT
netbios name = LINUX
server string = Samba Server %v
security = SHARE
map to guest = Bad User
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = No
printer admin = @adm

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
guest ok = Yes
printable = Yes
print command = lpr-cups -P %p -o raw %s -r # using client side printer drivers.
use client driver = Yes
browseable = No

[print$]
path = /var/lib/samba/printers
write list = @adm, root
inherit permissions = Yes
guest ok = Yes

[pdf-gen]
comment = PDF Generator (only valid users)
path = /var/tmp
printable = Yes
printing = bsd
print command = /usr/share/samba/scripts/print-pdf "%s" "%H" "//%L/%u" "%m" "%I" "%J" &
lpq command = /bin/true
lprm command = lprm -P'%p' %j

Please tell me what is wrong with my samba. Thanks

Alireza

ctwos 01-11-2005 05:27 PM

Remove "netbios name = LINUX" from smb.conf will fix it.

I had same problem, seems like its a bug.

If I find out how to get around it will let you know, like you I want to use the name I pick.

Walt

alirezan1 01-11-2005 06:02 PM

Thank you for your reply. I will try this out.

Alireza

ctwos 01-15-2005 11:57 AM

found it
 
For a long time I have had two servers (RH7.3 and Mandrake 10.1), one which SWAT works, one which reports "smbd not running".
I finally decided to figure out what the difference was. Here is what it was.

Simply add to:
"/etc/samba/lmhosts"
"IP Address of the server" "the name of the server"

Example here is mine:

[root@chilly root]# cat /etc/samba/lmhosts
127.0.0.1 localhost
192.168.0.10 chilly

and put back
"netbios name = CHILLY" in smb.conf

Walt

ctwos 02-11-2005 08:20 PM

fyi
 
While set up my print server using samba I came across the following:

#man smb.conf

under:
bind interfaces only, (about line 784)

If bind interfaces only is set then unless the network address
127.0.0.1 is added to the interfaces parameter list smbpasswd(8)
and swat(8) may not work as expected due to the reasons covered
below.....

The swat status page tries to connect withsmbd and nmbd at the
address127.0.0.1 to determine if they are running. Not adding
127.0.0.1 will cause smbd and nmbd to always show "not running"
even if they really are. This can prevent swat from start-
ing/stopping/restarting smbd and nmbd.

PS
Did you get it working?

Walt


All times are GMT -5. The time now is 05:01 PM.