LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-26-2002, 05:00 PM   #1
albean
Member
 
Registered: Sep 2002
Distribution: fc2
Posts: 113

Rep: Reputation: 15
win2k Slow booting in presence of Linux partition


Hi,

I’ve installed rh7.3 on my computer and set it up as dual-boot between win2k-ntfs and linux. (Both are on separate drives.) After that windows began having a problem and I thought that it was related to GRUB or something. But now I know that it isn’t because after a “timeout” win2k works fine. Here is the symptom, I hope one of you guys can diagnose it:

------
I turn on my computer and choose win2k to boot from the menu.

Win2k begins to load, but stalls for about 30 seconds at the screen with the short blue squared “% done” bar. (Almost as if it finally gave up trying to do "whatever")

Then it moves on to the phase where it is “starting up windows” (it states this in a small window and the background is blue) when this is done the window is removed and the OS stalls for about 60 seconds (again like it "timedout" after this 60 secs) and then I get the prompt to press “ctrl-alt-del”. Normally after the “starting up windows” window is removed I immediately get the “ctrl-alt-del” prompt (i.e. no "timeout" period).

After I get the prompt and put in my password everything is fine.

Any ideas?

If I unplug the linux drive, the symptom goes away.

(My system is a Dell Dimension (8100 I think))

Thanks guys!
-AB
 
Old 09-26-2002, 05:39 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,575

Rep: Reputation: 181Reputation: 181
What was on your second (now Linux) disk? Maybe Windows swap or a similar thing? It may be searching for soemthing that's missing...
 
Old 09-26-2002, 08:43 PM   #3
albean
Member
 
Registered: Sep 2002
Distribution: fc2
Posts: 113

Original Poster
Rep: Reputation: 15
I've had windows on the 1st drive now for a year and I just added the 2nd drive this week so Windows probably isn't looking for any OS related stuff there. I'm wondering if its trying to mount it or something. (?)
 
Old 09-27-2002, 07:50 AM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,575

Rep: Reputation: 181Reputation: 181
It may be... Check also all the cables. Maybe the two disk work at different speeds and it creates the problem?
 
Old 09-27-2002, 04:45 PM   #5
albean
Member
 
Registered: Sep 2002
Distribution: fc2
Posts: 113

Original Poster
Rep: Reputation: 15
I blew linux away as a test and formatted the drive with DOS. Windows had no problem with the drive when it had DOS. It only slows down when its formatted with linux

I'm having the same problem this guy seems to have had but I can't get in touch w/ him. http://returntonature.com/pipermail/...ly/001017.html

Somebody suggested 'hiding' the linux partition to windows. As the guy says "I don't see how". If this is possible could someone point out a web page or something? Thanks!
-AB
 
Old 10-01-2002, 02:13 PM   #6
albean
Member
 
Registered: Sep 2002
Distribution: fc2
Posts: 113

Original Poster
Rep: Reputation: 15
I've fixed my problem and wanted to post the fix here in case someone ran into this issue.

Problem:
Simply put I wanted to have windows and linux on seprate hard drives and dual boot between them. The windows installation has existed for awhile and I did not want to re-install or other wise alter it. Upon adding a second hd and installing linux (redhat 7.3) when I booted windows it would stall in a couple places during boot-up and would slow down (or "pause") while running from time to time.

Solution (work-around):
I found that windows (2000) was looking for a windows (FAT,NTFS,whatever) partion on the other drive. So I fdisked the new drive using a win98 boot disk, created a small 26 Mb (Primary) FAT partion and then formatted it with the /s switch [later i put GRUB on this disk's MBR so you might not neet the /s switch]. (I did not test to see if win2k wanted to see this partion as the first partion or not, though.) By creating a FAT partion that took up the first couple sectors on the new hd, when windows started-up it saw the new hd and the FAT partion and was happy. [All in all the first 26 Mb went to the first FAT partition and the remain 10 Gb went to the linux partions] So I gave up a few megabytes to M$ and now I'm happy with linux!

As a side note:
I really wanted to see the GRUB boot loader upon computer start-up because I was tired of looking at NT's initial black screen OS boot loader/chooser. So I changed the cables and jumpers on the drives making the windows drive the slave and the linux drive the master. I then added the following lines to the grub.conf file:

title Windows 2000
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
makeactive
chainloader +1
boot

You could still leave windows as the Master hd but you will need to add linux to the NT OS boot loader/chooser. This worked nicely too with the above work-around.

-AB

Last edited by albean; 10-04-2002 at 04:42 PM.
 
Old 10-01-2002, 02:21 PM   #7
albean
Member
 
Registered: Sep 2002
Distribution: fc2
Posts: 113

Original Poster
Rep: Reputation: 15

Thanks for your help K. Behilo
-AB
 
Old 10-07-2002, 12:41 PM   #8
ryco
LQ Newbie
 
Registered: Oct 2002
Posts: 1

Rep: Reputation: 0
solution to slow win2k with dual linux without fdisk shennanigins

Hey,

Had the exact same problem, huge delays in win2k boot/startup.
Using win2k/linux (RH7.3) dual boot, with the two OS's on different HDDs. Noticed that the linux drive was listed in the device manager of win2k (control panel->system->hardware tab->device manager) under "disk drives". Right-click the linux drive, select disable, and BAAM! - the system boots like it ain't five years ago.

Hope this helps,
Ryan
 
Old 10-07-2002, 01:03 PM   #9
albean
Member
 
Registered: Sep 2002
Distribution: fc2
Posts: 113

Original Poster
Rep: Reputation: 15
For some reason that trick didn't work for me. I had to partion the 2nd hard dive as explained above. But I'm glad to hear that you didn't have to go through the trouble I did! It took me almost a week of evenings getting my system to dual boot correctly.
 
Old 01-06-2003, 01:53 AM   #10
sunsesh
LQ Newbie
 
Registered: Jan 2003
Posts: 1

Rep: Reputation: 0
W2K slow after Linux load

I had the small problem with Mandrake 9 and W2K. I did the following and the problem has disappeared. Please try that yourself too.

The basic trick is to make W2K think that it need not review the Linux partition. Proceed as below:

Caution: You would lose the Linux installed and have to reinstall it; You would have to go into W2K with the delay as you encounter now.

(a) Identify the partitions used by Linux (there will be one for mount point: / and more for the others as you might have defined such as Swap, /HOME etc.)

(b) Using Disk management (Start - Settings - Control Panel - Administrative Tools - Computer Management - Storage), right click on these partitions and 'delete the logical drive'. ****CAUTION***** PLEASE REMEMBER YOU WOULD LOSE THE DATA AND HENCE CHOOSE THE CORRECT PARTITION. THE AUTHOR IS NOT RESPONSIBLE FOR ANY LOSS******

(c) Now the contigous areas of the partitions released will become FREE and right click on that area and define logical drives on them. Indicate the correct size and bypass the logical drive name and the formatting options.

(d) Now, you should see the partitions (as required by Linux) visible in Windows 2000 and you are ready to install Linux.

(e) While installing Linux, do not let it 'make' any partitions - but use the existing partitions.

You are set, then.

I have not given detailed instructions - but, I am sure that you would be able to use them.

Best wishes.
 
Old 01-06-2003, 02:17 AM   #11
Ed-Slack
Member
 
Registered: Dec 2002
Location: the Netherlands
Distribution: Slackware/Gentoo with Fluxbox
Posts: 46

Rep: Reputation: 15
Just a tip :-)

The major thing to rember here actually is that windows 2000 doesn't read the partion table correctly if it is written with linux (e.g. fdisk from the slackware install). If want dual boot win2k an linux I suggest PQmagic to create the partions, this program can format ex2, and linux swap as well as fat, fat32, ntfs and some others. It can be booted from two disks. You can convert and resize all you want in it. And windows will have no troubles after wards. I had this problem too. I didn't want to loose any thing if possible so in pqmagic I deleted a partion which wasn't used yet (of the four disks) and recreated it formating it as well. And ho and behold it was cured. So rember don't use linux partioning when running w2k as well.

Just a tip :-)
 
Old 01-06-2003, 11:15 AM   #12
membrax
Member
 
Registered: Nov 2002
Location: 50'48''N - 4'21''E
Distribution: SuSE7.1 - SuSE8.1 - SuSE8.2 - RH6.2 - RH7.1 - RH7.3 - RH8.0 - RH9.0 - Fedora Core 1
Posts: 281

Rep: Reputation: 30
"Solution (work-around):
I found that windows (2000) was looking for a windows (FAT,NTFS,whatever) partion on the other drive. "

You're perfectly right, I used to have the same issue lately.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
booting win2k and two Linux distros on two hard drives mjp Linux - General 3 01-01-2004 02:26 PM
booting win2k AFTER linux felipe_ced Linux - Newbie 1 08-24-2003 07:28 AM
linux booting through win2k kid12 Linux - Newbie 2 07-14-2003 08:33 PM
booting linux from win2k stand General 6 09-24-2002 05:15 AM
uploading to linux-Apache1.3.20 from win2k is working too ...... slow lamihai Linux - Networking 1 04-23-2002 06:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration