LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-13-2012, 03:13 AM   #1
takakia
LQ Newbie
 
Registered: Nov 2012
Posts: 7

Rep: Reputation: Disabled
Widescreen resolution 1366x768 not working - onboard Intel graphics system


Hi Gurus,

I have installed Slackware 14 and I am enjoying it. The problem is that my widescreen monitor is not recognized to the right resolution that is 1366x768. The problem is persistent in all distros like Ubuntu and OpenSuSE. I tried all methods on the web, including changing the xorg.conf file, installing bleeding edge drivers and also compling the latest kernel. But nothing worked. Its frustrating how Intel video hardware cannot detect the right resolution.

My system:

Code:
bash-4.2# lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

Code:
bash-4.2# dmesg | grep -i vga
[    0.000000] Console: colour VGA+ 80x25
[    0.599517] vgaarb: device added: PCI:0000:00:02.0,decodes=io+mem,owns=io+mem,locks=none
[    0.599627] vgaarb: loaded
[    0.599684] vgaarb: bridge control possible 0000:00:02.0
[    7.503841] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
I am attaching my Xorg.0.log here.

Last edited by takakia; 11-13-2012 at 03:54 AM. Reason: dead link
 
Old 11-13-2012, 07:23 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,661

Rep: Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540
Welcome to LQ!

Actually it appears that your monitor is the problem. The Xorg.0.log shows that the monitor EDID http://en.wikipedia.org/wiki/Extende...ification_data is only advertising that it is capable of resolutions up to 1024x768.

Your best bet with your hardware is to find out what refresh rate that your monitor uses at 1366x768 and then use 'cvt 1366 768 <refresh rate>' to get a mode line that suits your monitor. You can then test this using 'xrandr'.
From the EXAMPLES section in 'man xrandr'
Quote:
Forces to use a 1024x768 mode on an output called VGA:
xrandr --newmode "1024x768" 63.50 1024 1072 1176 1328 768 771 775 798 -hsync +vsync
xrandr --addmode VGA 1024x768
xrandr --output VGA --mode 1024x768
If this works, you can then introduce this into your xorg.conf to make it permanent.
 
Old 11-21-2012, 06:50 AM   #3
takakia
LQ Newbie
 
Registered: Nov 2012
Posts: 7

Original Poster
Rep: Reputation: Disabled
Thanks

my cvt command gave an output like this

Code:
cvt 1366 768
# 1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz
Modeline "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
when I tried to add it at a new mode with xrandr

Code:
xrandr -newmode "1366x768" 85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync^C
I get this error

Code:
usage: xrandr [options]
  where options are:
  -display <display> or -d <display>
  -help
It seems it does not set the resolution as I instruct

BTW, changed to another monitor which is also the same brand and same resolution but a newer one.
 
Old 11-21-2012, 08:50 AM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,661

Rep: Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540Reputation: 1540
Try this line - Note the double hyphen before newmode.
Code:
xrandr --newmode "1366x768" 85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync^C
 
Old 11-21-2012, 09:07 AM   #5
takakia
LQ Newbie
 
Registered: Nov 2012
Posts: 7

Original Poster
Rep: Reputation: Disabled
Thanks a lot,

It worked with the command:
Code:
xrandr --newmode "1366x768_widescreen" 85.25  1368 1440 1576 1784  768 771 781 798
followed by :

Code:
xrandr --addmode VGA1 1366x768_widescreen
xrandr --output VGA1 --mode 1366x768_widescreen
I found a way to keep running this as a script everytime I boot.

Problem solved. Thanks a lot.

Last edited by takakia; 12-04-2012 at 03:21 AM. Reason: Spelling error
 
Old 12-04-2012, 03:20 AM   #6
takakia
LQ Newbie
 
Registered: Nov 2012
Posts: 7

Original Poster
Rep: Reputation: Disabled
A follow up,

I updated the bios and the problem was fixed automatically. Seemed like a problem with the old mobo bios.

Sid
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to blacklist my intel onboard graphics drivers deepclutch Debian 1 06-08-2007 12:46 AM
Samsung 226BW widescreen and Intel 915 graphics card: cannot reach max resolution k4zau Linux - Hardware 1 05-21-2007 08:08 AM
1366x768 resolution with intel 865G on LCD HDTV powe11 Linux - Hardware 3 12-27-2006 04:11 PM
Onboard Graphics Driver Intel 810E MikeEnIke Slackware 8 10-19-2006 07:31 PM
Need to Know Whether my Onboard Graphics Chip is an Intel i810 Huddlebum Linux - General 4 04-04-2004 11:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration