-   Linux - Newbie (
-   -   Why won't my PC boot into either the installation or a live CD? (

BoydRice 09-22-2009 02:16 PM

Why won't my PC boot into either the installation or a live CD?

I am new Vector Linux but not Linux. Last night I installed Vector Linux Light on my laptop. The install seemed to go fine and when I went to reboot post installation (without the CD in my CDROM) it doesn't boot to anything. I rebooted it a couple of times and after the BIOS/logo nothing seems to happen. I can't even boot to a live CD like Puppy Linux or even the Vector install CD, I keep ending up looking at a cursor on a blank screen. I have installed many distros, and even had installations fail and never had this happen. I took the defaults for installing LILO, does anyone have any idea how I can fix this? The Laptop is a fairly new Lenovo Ideapad y430 laptop. Any help is appreciated.


j_jerry 09-22-2009 03:47 PM

If the bios is set to boot from cd and then no bootable cd is loading, it could be some bios level problem.

you sure you have set up bios correctly ?

BoydRice 09-22-2009 03:59 PM

I don't think its a BIOS issue, my boot priority on my BIOS is set to boot the DVDROM first then the hard drive. I have tried booting to the CD and even going to the boot options and selecting the DVDROM and no luck then I did the opposite, manually selecting the Hard Drive on boot and no luck.

JamesChamberlain 09-22-2009 04:39 PM

So your machine wont boot via cd or via hdd now after your newly installed distro? Strange.

Firstly I'd do what you've done, remove install media from cdrom and reboot. See what you get, got any grub / bootloader errors? Anything?

If not you can be sure that your hdd install is screwed. Maybe the bootloader didn't install properly, obviously this wont boot your OS. Try booting another distro, like perhaps an ubuntu live cd, see if that will boot.

If it doesn't, pop a distro live cd image on a usb drive, and if your bios supports it try and boot from this usb drive, possibilities with your cd drive not read/writing cd's correctly hence not writing files properly to your hdd.

If your on a network try a network installation by NFS. There's plenty of tutorials online how to do this and it's fairly straight forward, providing you can get a live cd to boot :).

btncix 09-22-2009 05:11 PM

If you have another computer, see if your boot cd/dvd is able to boot other computer.

I would unplug your machine. If you are using a laptop, I would unplug the laptop and then remove the battery. Wait 7 whole seconds. Then plug the power cord back. Don't worry about batteries for now. Now turn now your system and go straight to the bios menu. Make sure your boot order is setup to boot the cd/dvd followed by the hard drive. See if your cd/dvd is now able to boot your system. If your cd/dvd is able to boot, I would now check if the hard drive is able to boot. If the hard drive isn't able to boot, I would use a rescue cd/dvd to see if reinstalling the bootloader might solve your problem.

I've had weird booting issues with my toshiba laptop, and unplugging the power and batteries seem to resolve them.

BoydRice 09-22-2009 06:28 PM

Thanks btncix, I will try removing the battery when I get home from work. I have literally tried dozens of installs on this machine and never had anything like this happen before.

BoydRice 09-22-2009 11:45 PM

Well removing the battery didn't help. The DVD drive sounds like it is spinning but no luck still. Strangest thing can't boot a live CD, maybe I bricked it. I'm not sure what else to do, maybe try a PC repair place.

j_jerry 09-22-2009 11:50 PM

please try your cd in another computer and see if its booting

BoydRice 09-23-2009 01:20 AM

I did, I have tried four different CDs, Puppy Linux 4.3, openSUSE 11.1, Vector Linux Light, and Slackware 13.

JamesChamberlain 09-23-2009 03:48 AM

Hm, maybe an obvious one but have you tried loading optimal defaults in the bios?

BoydRice 09-23-2009 01:20 PM

Well I went into my BIOS setup and loaded the defaults, still ended up with the same results.

JamesChamberlain 09-23-2009 01:31 PM

Oh man, hmpf im really having trouble with this one!.

Your machine is literally not booting at all? No messages, just a black screen? I really would advise against passing it to a pc repair place. They're overpriced and im sure you can fix it yourself.

I know we cant seem to fix the issue but i refuse to admit it's screwed!.

Do you get the same output on your screen regardless of attempting to boot from cd or hdd?

j_jerry 09-23-2009 01:59 PM

If you've tried setting bios to boot from cd and hdd and still fails it'd be a hardware(most probably bios) fault.
Try reflashing your bios

btncix 09-23-2009 02:27 PM

Man, I empathize.

I agree with Jerry, but one more thing you might want to try is, poweroff, disconnect your hard drive, and try to boot with CD.

I had a really weird experience once where a flawed monitor wouldn't let me boot. Really really weird. I thought for sure, something was wrong with my motherboard or hard drive. Long story short, when I switch to a different monitor, everything booted up fine.

BoydRice, I doubt you're in similar situation.

yancek 09-23-2009 05:34 PM

Have you checked to cables to the CD drive/motherboard?

All times are GMT -5. The time now is 05:00 PM.