LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-21-2005, 03:08 AM   #1
Jose Santos
LQ Newbie
 
Registered: May 2005
Location: Portugal
Distribution: Fedora Core 3
Posts: 19

Rep: Reputation: 0
Why when i write in Portuguese the Oppen Office editor changes the characters?


Good morning.

I am in Portugal, so when i write a letter in Portuguese i try that every word is Ok.

So, what is happening to me :

I write the word "Conceição" that is a proper name and the screen shows me something like that "ConceiA$Éo" .

Never theless , on the other day i noticed that when i send a mail to a friend the same thing happened. After that i changed the language to Portuguese and i supposed that everything will be Ok after that.


Do you have any idea what is going on and how can i fix it?

This happend on the OppenOffice writer. I suppose this will happen on other applications. Maybe i am wrong.. I really dont know.. i am a beginner....

Thanks in advance for yout help

Samora
 
Old 05-21-2005, 06:05 PM   #2
zeca_pedra
Member
 
Registered: Nov 2003
Location: Funchal, Madeira, Portugal
Distribution: Linux Mint 13
Posts: 37

Rep: Reputation: 15
Try changing locales

The same happened to me (I'm writing in english because this is a global forum and everybody should benefit from these posts, but I'm portuguese as you are).

It occured in several distros and sometimes with all applications some other times only with OpenOffice! Never understood the difference.
Anyway, I've learned from these and other foruns and the solution couldn't be easier - in console/terminal type, as root:
Code:
dpkg-reconfigure locales
My advice is that you choose only the locales you want, for example, pt, pt@Euro, pt_ISO-8859-1, etc

Once you have done that, the system will reconfigure the locales, then you'll have to choose one to be your default. You try one and if you're not succeed do the entire process again until you find the right one.

Regards
zeca
 
Old 05-22-2005, 08:22 AM   #3
Jose Santos
LQ Newbie
 
Registered: May 2005
Location: Portugal
Distribution: Fedora Core 3
Posts: 19

Original Poster
Rep: Reputation: 0
Portuguese Characters

Thanks for your help.

as a i am a real beginner, can you explain to me how i can do it.?

1 - i enter as root user

2 - i go to Console/terminal application

3 - i write the code you told me and after that i put PT in front of the code ??? Does the same thing applies to the other parameters???, PT@EURO , pt_ISO-8859-1, etc


After i gave the "Enter" does everything goes Ok???

I am sorry for making such a "dummy" question, but i am really trying to let WIndows out of me.

So, i need very badly to work those things ( Word, Spreadsheet , Presentations ) .

However i miss something . A database application like Access.. Does Fedora Core 3 comes with anyone?? If so, what is the name. If not , can you tell me wich one do you
advice it to me. I would appreciate very much

Best regards

José Santos
 
Old 05-23-2005, 10:21 AM   #4
zeca_pedra
Member
 
Registered: Nov 2003
Location: Funchal, Madeira, Portugal
Distribution: Linux Mint 13
Posts: 37

Rep: Reputation: 15
Reconfiguring locales

I didn't made myself clear. Here are the steps you need to go through:
1) login as you normally do (never login to X as root, it may give you problems);
2) open the console and change to root with the su command, like this
Code:
zeca_pedra@ubuntu >$ su
and type your root password when asked;
3) now that you're logged in console as root type
Code:
# dpkg-reconfigure locales
4) in the choices that apear in front of you select only the ones you want (to select you'll have to press spacebar with the desired locale selected)[*] en_US[*] pt@Euro
etc, etc, etc... there are a lot of locales, you'll have to go through the entire list to see those in which you're interested
5) since I am advising you to select more than one locale the system will ask you tho choose one to be your default
6) make that choice
7) finally test your keyboard and your language in OpenOffice and other applications to see if it worked. If not you'll have to go through this process again - believe me I had to make this one or two times and I've droped some distributions because the problem appear again days later (I believe due to some updates I've made)

hope now this helps
zeca
 
Old 05-23-2005, 10:26 AM   #5
zeca_pedra
Member
 
Registered: Nov 2003
Location: Funchal, Madeira, Portugal
Distribution: Linux Mint 13
Posts: 37

Rep: Reputation: 15
Database

Sorry I forgot to mention: I don't use any database package but I've heard ofMySQL ! I believe you can search for this and many other applications in
http://www.linuxsoft.cz/en/
or in
http://sourceforge.net/

if if you want to learn about linux the easy way, I found many useful tutorials and ebooks here (in portuguese)
http://www.guiadohardware.net/ebooks/linux/index.html

zeca
 
Old 05-26-2005, 03:38 AM   #6
Jose Santos
LQ Newbie
 
Registered: May 2005
Location: Portugal
Distribution: Fedora Core 3
Posts: 19

Original Poster
Rep: Reputation: 0
portuguese characters -

Hello again Zeca

Before anything i wanna thank your help

however i received the following message:

[jsantos@localhost jsantos]$ su
Password:
[root@localhost jsantos]# dpkg-reconfigure locales
bash: dpkg-reconfigure: command not found
[root@localhost jsantos]# reconfigure locales
bash: reconfigure: command not found
[root@localhost jsantos]#


did i made anything wrong?

i am a little confused.

i am going to see the URL you told me about and post 2 more things.
1 - how to change the name of my localhost ?
2 - how can i put my computer on a network ?

Best regards
Ze
 
Old 05-26-2005, 04:08 AM   #7
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
Isn't dpkg for debian distributions?

There is an RPM package for an Open Office Language Pack for Brazilian Portugese:
openoffice.org-langpack-pt

Do you have this package installed? It should be located with the other Open Office packages.
Also make sure that you have the kde-i18n-Portuguese package installed. I'll bet that the KDE package is already installed.

Last edited by jschiwal; 05-26-2005 at 04:09 AM.
 
Old 05-26-2005, 04:15 AM   #8
Jose Santos
LQ Newbie
 
Registered: May 2005
Location: Portugal
Distribution: Fedora Core 3
Posts: 19

Original Poster
Rep: Reputation: 0
Portuguese characters

Portuguese charactershi..
thanks for your help

as i am a real beginner, i really don't know what you are talking about.

i really don't know if i have all that stuff on my distro or in my computer.

Can you help me?

Thanks in advance.

Ze
 
Old 05-31-2005, 12:05 PM   #9
zeca_pedra
Member
 
Registered: Nov 2003
Location: Funchal, Madeira, Portugal
Distribution: Linux Mint 13
Posts: 37

Rep: Reputation: 15
A few questions

Ok, let's start all over!
What is the distribution that you're using?
One way or the other you should have access to package managing!
Check if you have one of these programs on your distribution:

- synaptic (if Debian or a Debian based distro)
- rpmdrake (for Mandrake, now Mandriva distro)
- yum (if you're using Fedora)

I'm assuming you're not using Debian and I believe jschiwal is wright: you should try to find those packages - my suggestion is that you open the package manager you have on your system and make a search to them.

If you find that you don't have them installed just mark them for installation and apply the changes. After a few minutes you should have those installed and working!

I know this is not of much help but I'm in the dark right now ;-D I don't know what distro you're using and the solution would be different in each case

zeca

Funchal
 
Old 05-31-2005, 12:11 PM   #10
zeca_pedra
Member
 
Registered: Nov 2003
Location: Funchal, Madeira, Portugal
Distribution: Linux Mint 13
Posts: 37

Rep: Reputation: 15
ignore my previous post

Sorry, I was sleepping ;-D
I know you're using Fedora - forget what I've told you, my mistake!
Now, for the real thing, open your pakcage manager (it should be in the menu under the System categorie).

Make a search to openoffice-pt or something similar. Forget that search about kde, Fedora uses gnome so you problably don't need anything from kde desktop environment!!!

And keep searching about locales - you should find a lot of locales listed in the package manager! Mark for installation the ones you need and apply the changes!

Now I hope this works,
zeca
 
Old 05-31-2005, 12:58 PM   #11
Jose Santos
LQ Newbie
 
Registered: May 2005
Location: Portugal
Distribution: Fedora Core 3
Posts: 19

Original Poster
Rep: Reputation: 0
the package manager

Hello Zeca

Thanks for your help

However i have a small problem...

when you mentioned "Package Manager" what do you mean by that in Portuguese ?

My Fedora is in Portuguese, so in the Menu under the System category , i don't see anything like that or that the tradution means something like that..

what did i do:

1- Clicked on the Red hat icon

2 - it appeared 2 categories:
System configuration (Configuração do Sistema)
System Tools (Ferramentas do Sistema)

However , on both categories i didn't noticed nothing like you said that i think as "Gestor de Pacotes ou Gestor de Aplicações"

So, i couldn't make the search you told me.
and yeah , it uses Gnome . That i know now.....

Could you please give me an extra help on that search ? I would appreciate very much. While i haven't my openoffice working i can't switch from Windows.

By the way, i saw an aplication called KOffice.
I think this one solves my database's problem. However, i don't know how to make the download and setup the application

Is the download method equal to the Windows? what is the ZIP or RAR aplication here??? Maybe it is here and i don't know it. i think that is the Problem.
When the downloaded software is in my machine what should i do to install and setup the application???

Too damn beginner , but i wanna know how i can switch off permanently my Windows....

Thanks again for your help and support

Best regards
Ze
 
Old 06-02-2005, 05:38 AM   #12
zeca_pedra
Member
 
Registered: Nov 2003
Location: Funchal, Madeira, Portugal
Distribution: Linux Mint 13
Posts: 37

Rep: Reputation: 15
package manager

I believe it's under System Tools (ferramentas do sistema) but I can't tell for sure - never had any system installed in portuguese nor even Windows :-(
Should be something like Instalar Aplicativos or Instalar Novos Programas - remember, it's NOT the red hat update tool!
When that package manager opens you have the chance to search for installed apps, not installed, upgradable or obsolete apps! It's really easy, more than in Windows, because you have a lot of software at your fingertips and you only have to put a check mark on those you want.

Now in portuguese:
«Tens a hipótese de pesquisar por todo o tipo de software que desejas dentro de diversas categorias (instalado na máquina, não instalado, que pode ser actualizado ou que se encontra obsoleto). Basta com procurares pelo aplicativo que desejas. colocar a check mark na caixinha respectiva e fazer o aplicar para que ele comece a proceder ao download e instalação da aplicação (não precisas de zip nem rar nem nada disso, ele faz tudo automaticamente e no fim diz-te se a instalação foi bem sucedida ou se houve alguma falha). De qualquer modo, caso faças um download por outra via o Gnome traz um equivalente ao zip ou rar que é o File-Roller!»

Sorry but it's hard for me to guess teh right names for the menus and apps in portuguese because, as I've told you, I've never had any OS installed in my native language!

zeca
 
Old 06-02-2005, 11:57 AM   #13
Jose Santos
LQ Newbie
 
Registered: May 2005
Location: Portugal
Distribution: Fedora Core 3
Posts: 19

Original Poster
Rep: Reputation: 0
OppenOffice Portuguese

Hi Zeca...

I saw the Package Manager...
it's under Configuração do Sistema and then Adicionar ou Remover Aplicações.....

all of them are cheked... as OppenOffice is too (i checked this)

so, the problem might be somewhere else.... but i don't think is here...

Can you give me an extra help???

should this problem be on the Keyboard??? I have an ASUS laptop.....

or in the language when i am login in to the Linux???

the language is in Portuguese.

hope to hear from you soon

best regards

Ze
 
Old 06-03-2005, 05:09 AM   #14
zeca_pedra
Member
 
Registered: Nov 2003
Location: Funchal, Madeira, Portugal
Distribution: Linux Mint 13
Posts: 37

Rep: Reputation: 15
Hmmmm

Does this problem only occur in OpenOffice??? Try other text editor (like Gedit, the gnome default text editor) and see if it occurs tehre to!

If everything is ok with your keyboard (I guess it is because if you choose portuguese keyboard layout under Configuração do Sistema > Teclado it's my beliefe that it should work)... I've never had problems with keyboard when I used Fedora.

I'm thinking that if your problem is only related to Open Office you may try to change options on this office suite.
1) open OpenOffice Writer
2) go to Options under Tools menu (Opções no menu Ferramentas)
3) choose language settings (Lingua ou Linguagem???)
4) choose Portuguese as default language for documents

But this is a solution for the characters displaying only in Open Office. If you have the same problem with other editors then there's something wrong with the locales, that's for sure

If you can the next time tell me in more detail what happens and the solutions you've tried

zeca
 
Old 06-03-2005, 06:31 PM   #15
Jose Santos
LQ Newbie
 
Registered: May 2005
Location: Portugal
Distribution: Fedora Core 3
Posts: 19

Original Poster
Rep: Reputation: 0
Arrow 2 hmmmmm

hi Zeca

thanks again for your help

i tried like you said and everything went Ok

GEDIT verificação

but please repair very careful what i received by your post reply:


YOUR POST REPLY

If everything is ok with your keyboard (I guess it is because if you choose portuguese keyboard layout under Configuração do Sistema > Teclado it's my beliefe that it should work)... I've never had problems with keyboard when I used Fedora.

I'm thinking that if your problem is only related to Open Office you may try to change options on this office suite.
1) open OpenOffice Writer
2) go to Options under Tools menu (Opções no menu Ferramentas)

.......

As you can seen when i opened your post i received the "problem" , i.e. when you typed in Portuguese the letter "ç" becomes the confusion you see...

it seems somehow the language in my system is not correct. or the keyboard...

maybe the problem is not on the Openoffice and i just found out when i tried to write something on it.

OPPENOFFICE verificação

Maybe is on another configuration i have to make and i didn't see it or i don't know how to do it.

I bought a book from FCA - LINUX that have 4 Cd's in Portuguese with the full instalation of Rad Hat FEDORA 3. I have the Fedora 2 ( i saw it now)

Do you think if i make the update to the FEDORA 3 will be a better solution. Maybe it is, but an update on a distro is so simple like install WIndows Xp?
As i told i am a beginner.

If is just to put the Cd and make an Update option i "think" i can handle it....
If it is necessary much more knowledge, maybe it is not the right moment... or maybe ask someone who knows this a lot better that can help me making the update...


As allways, i will wait for your precious comments....

Thanks a lot

best regards
Ze
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Portuguese characters on Redhat 9 in english fbenites Linux - Newbie 3 10-29-2003 11:35 AM
How can I write with romanian characters in Linux? Please Help! petru_b16 Linux - General 2 10-22-2003 07:53 AM
Open office read only, K-write read/write mode lwtvh Linux - Newbie 1 07-19-2003 11:33 AM
random characters in editor forand *BSD 0 12-12-2002 12:17 PM
Star Office 5.2 characters... Frank Linux - General 2 06-22-2002 06:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration