-   Linux - Newbie (
-   -   why sendmail takes so long to start? (

fromzj 08-13-2002 01:10 AM

why sendmail takes so long to start?
Hi, I have RedHat and Win2000 daul Os.Everything seems to be OK but when I load Linux, it took very long time to start sendmail.(more than the time to start all the other services)

Please tell me why or what is sendmail just.


A-dummy 08-13-2002 01:19 AM

sendmail is a mail server & I am sure you dont want to run it .
cos u dont know what it stop it from starting just
go to /etc/rc.d/rc5.d/ & there must be a file Sxxsendmail
xx is some number......just rename it to Kxxsendmail or may be
something else not starting with S (S means you want to start
it, K means you want to kill it)......

JamesF1 08-13-2002 03:16 AM

I had a similiar problem with this. Mind you I'm not sure how I solved it but it might have something to do with the hosts file. Check that the machine name (fully qualified one) and ip address is correct. I think sendmail checks this file on startup.

A-dummy is right about not having it running if you don't need it. It'll just provide a possible security risk if not maintained properly.

fromzj 08-13-2002 11:45 AM

Thank you A-dummy, I have tried rename the file S80sendmail in dir /etc/rc.d/rc5.d/, but this failed to skip starting sendmail after my reboot.

Then I think than /etc/rc.d/rc5.d/ is used at the running level of 5, but I load at 3.

So I renamed the file S80sendmail in dir /etc/rc.d/rc3.d/, it successfully skip starting that sendmail.

Further question:

What is xx.d file?

A-dummy 08-13-2002 11:54 AM

you mean rc.d ,rc3.d & such things.....they are initialisation
files & all files inside rc5.d (starting with S)are run,for example ,
when you enter 5th level.....all such scripts are kept inside rc.d
directory structure with (probably) symbolic links to /etc/init.d...
this is true for most of the distros following system V like RH,

fromzj 08-13-2002 03:00 PM

init.d, what an important file. My impression to it is very confuse, could you tell me about it more detailer?

acid_kewpie 08-13-2002 04:11 PM

right, the problenm is probably that it is not resolving your domain name properly, that's what it always is. if you tail /var/log/messages youshould see 3 or 4 error messages saying i can't resolve the hostname. make suer that the hostname is set in /etc/mail/local-host-names and any other relevant files in that directory

All times are GMT -5. The time now is 12:59 AM.