Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 08-20-2009, 09:15 PM   #1
LQ Newbie
Registered: Aug 2009
Location: Singapore
Distribution: RedHat 8; kernel 2.4.18
Posts: 15

Rep: Reputation: 0
Smile why samba restart is needed at the first time when boot up

I encountered a problem with samba. I configured samba, and it really worked. however, when I shut the linux down and boot up again, samba would not work until I restart it twice. Print info is as following:

/etc/init.d/smb restart

Shutting down SMB services: Failed
Shutting down NMB services: Failed
Starting SMB services: Ok
Starting NMB services: Ok

And then I restart it again, it seems all ok.
Old 08-20-2009, 09:25 PM   #2
LQ Guru
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677
The failure is in shutting down samba. It wasn't running in the first place. Also, the smb and nmb services are separate daemons. smbd is the samba server. nmbd is used to resolve microsoft hostnames and might not be used if you aren't using a client presently.

Go to your services configuration and enable smb for the console/multiuser/networked mode and for the X11 mode. For most distro's that would be run levels 3 & 5, but it depends on which distribution you are running.
On SuSE, Fedora, etal:
/sbin/chkconfig --list smb
smb                       0:off  1:off  2:off  3:on   4:off  5:on   6:off
Please list your distribution in your LQ user profile. That would help in getting the best answer right away instead of having to request more info.

Last edited by jschiwal; 08-21-2009 at 12:01 AM.
Old 08-20-2009, 11:56 PM   #3
LQ Newbie
Registered: Nov 2005
Location: Canada
Distribution: CentOS 5.0 & Suse 10.3
Posts: 26

Rep: Reputation: 15
Looking at the messages you got, it looks like your samba was not started at boot time to begin with (probably was not set to do so). You had to start it first.
Old 08-21-2009, 12:44 AM   #4
LQ Newbie
Registered: Aug 2009
Location: Singapore
Distribution: RedHat 8; kernel 2.4.18
Posts: 15

Original Poster
Rep: Reputation: 0

Thanks for your advice, I change the configuration as you said and it works.
Therefore I changed the file to enable samba in multi-user with network (3) and multi-user with network and display manager (5), it finally works.

By the way thank you for remind me of updating my profile.

To: Vitalka

I believe you are right, I was just not sure how to change it.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
My computer restart automatically from time to time ?? pleasehelpme Linux - Newbie 2 07-04-2005 04:29 PM
dhclient needed every time i boot to get internet michiaki Linux - Newbie 5 06-26-2005 08:37 PM
Samba server ok at boot, later fails to bind to IP. smbd restart doesn't help. tisource Linux - Networking 1 04-09-2005 08:16 AM
samba availiable at boot time Gkarfield Linux - Networking 3 10-21-2004 10:16 PM
Starting Samba at boot time. Unknown_User Linux - Software 3 04-26-2003 03:30 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:40 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration