LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-06-2006, 01:45 PM   #1
mallettaa
LQ Newbie
 
Registered: Jun 2006
Posts: 9

Rep: Reputation: 0
Question why my network printer does not work


I have a Brother 3820CN printer connect to my home network. I was running FC 3 and it was working fine. I changed OS to FC 4 and the printer has not worked since. The problem is I am not getting any error msg. Does anyone have any suggestion?

Tony
 
Old 07-06-2006, 06:50 PM   #2
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
Quote:
Originally Posted by mallettaa
I have a Brother 3820CN printer connect to my home network. I was running FC 3 and it was working fine. I changed OS to FC 4 and the printer has not worked since. The problem is I am not getting any error msg. Does anyone have any suggestion?

Tony
Yup! I have often had to re-install my network printer when I've changed OS - I'm thinking that the config for it is sitting in the / (root) partition so your upgrade wiped out the settings - It may still appear in apps when you're doing stuff in the user account of your install, but if it's not set up (through CUPS or something) then it ain't gonna work. Or maybe the new FC4 install has selected the wrong driver for it, so I'd think that you'd need to reconfigure it anyway.

If it is the driver, you might need to look up to see what the printer supports e.g. my HP 4050 has a driver available from CUPS, but as it supports PostScript 3 I just tell CUPS during the setup that it's a postscript printer and it just goes straight for "generic postscript printer".

Erm I don't recall whether it's http or https that you use to access cups - try both (http(s)://127.0.0.1:631 that is or it might be either the http/https and ://localhost:631 either way have a google for cups or just search here at LQ for it I've seen lots of posts for it).

regards

John
 
Old 07-09-2006, 01:28 PM   #3
mallettaa
LQ Newbie
 
Registered: Jun 2006
Posts: 9

Original Poster
Rep: Reputation: 0
John,

When I changed OS, I reformat the HD in order to use the new ext3 file system. I also download the Linux print driver and the cups driver from Brothers. I installed both files and configure. The main problem I see right now is when print anything even a test page, there is no errors, the file leaves the queue but nothing happens on the printer. So I am looking for some troubleshooting tips so I can find out whats happening once the file leave s the computer.

BTY, I also have a Windows machine that is able to print to this printer, so I know the network connective to this printer is good.

Thanks Tony
 
Old 07-10-2006, 07:57 PM   #4
mallettaa
LQ Newbie
 
Registered: Jun 2006
Posts: 9

Original Poster
Rep: Reputation: 0
i added an entry into my DNS and it seems to be working

Thanks for your help

Tony
 
Old 08-15-2006, 07:34 PM   #5
mallettaa
LQ Newbie
 
Registered: Jun 2006
Posts: 9

Original Poster
Rep: Reputation: 0
After some more research I was able find the fix for my problem. The problem was SELinux was not letting me print. After adding the correct statement to the SELinux file and/or disable SELinux I was able to print to the printer via IP

Thanks to everyone for their help

Tony
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CUPS Network Printer/ server indicator blinks no printer output wine Linux - Networking 8 03-18-2006 11:20 PM
printer modules not loaded; parallel printer doesn't work blinux1 Linux - Newbie 7 06-24-2004 10:59 PM
Network Printer via SMB - doesn't work thw Linux - Networking 0 03-17-2004 03:01 PM
setup printer on client machine(slackware 8) to server (slackware7) network printer changwoo Slackware 9 05-02-2003 06:37 PM
Need help getting network printer to work hextex Linux - Newbie 0 04-19-2001 12:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration