LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-01-2017, 02:37 AM   #1
ajayss
LQ Newbie
 
Registered: Feb 2017
Posts: 11

Rep: Reputation: Disabled
Why My Linux Booting In to Emergency Mode ?


Hi,

I have an appliance which is running FreeBSD. I wanted to boot WindRiver Linux when I reboot the appliance.
There are more than one partition in the disk based on GPT. In partition 3, FreeBSD is kept (UFS). Windriver Linux is kept on partition 7 (EXT2).
I installed GRUB 2.0 and made the entries in grub.cfg as below.

menuentry "FreeBSD" {
insmod ufs2
set root=(hd0,3)
kfreebsd /boot/loader
}

menuentry "Linux " {
set root=(hd0,7)
echo "loading kernel"
echo "###############################################################"
linux /boot/bzImage-4.1.21-WR8.0.0.10_standard root=/dev/sda7
echo "#####################LOADED KERNEL#############################"

GRUB menu shows up the options FreeBSD & Linux on reboot.
When I select "Linux", it is booted in Emergency Mode by
giving message "Welcome To Emergency Mode". How can I boot
in normal mode?

Output of df - T in FreeBSD is given below

Filesystem Type 1K-blocks Used Avail Capacity Mounted on
/dev/mfid0p3 ufs 2030712 1225360 642896 66% /
devfs devfs 1 1 0 100% /dev
/dev/mfid0p5 ufs 2030712 16520 1851736 1% /nextroot
/dev/mfid0p2 msdosfs 1046516 64 1046452 0% /efi
/dev/mfid0p6 ufs 395896 104008 260224 29% /var
/dev/mfid0p8 ufs 2031132 124 1868520 0% /var/db/godspeed
/dev/mfid0p9 ufs 1874393936 32284512 1692157920 2% /data
procfs procfs 4 4 0 100% /proc
linprocfs linprocfs 4 4 0 100% /compat/linux/proc
linsysfs linsysfs 4 4 0 100% /compat/linux/sys
/dev/mfid0p7 ext2fs 412777400 7468416 384337464 2% /data/ajay


fstab entries in WR Linux are given below

proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
devpts /dev/pts devpts defaults 0 0
tmpfs /run tmpfs mode=0755,nodev,nosuid,strictatime 0 0
tmpfs /dev/shm tmpfs defaults 0 0
tmpfs /var/volatile tmpfs defaults 0 0
/dev/sda7 / ext3 auto,users,suid,dev,exec 0 0

Could you please help me in figuring out the issue.

Thanks,
Ajay
 
Old 03-01-2017, 04:18 PM   #2
goumba
Senior Member
 
Registered: Dec 2009
Location: New Jersey, USA
Distribution: Current: Debian and OpenSUSE. Past: Arch, RedHat (pre-RHEL). FreeBSD & OpenBSD novice, Hackintosh
Posts: 1,193
Blog Entries: 7

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
You have no initial ramdisk (initrd) entry in your grub configuration that you posted (although from the missing closing curly brace, it looks like what you posted is incomplete). Likely there's a driver needed that isn't being loaded, and the root filesystem can't be found.
 
2 members found this post helpful.
Old 03-04-2017, 06:43 AM   #3
hoes
Member
 
Registered: Sep 2005
Distribution: debian, linux from scratch
Posts: 186

Rep: Reputation: 50
Also, consider your root=(hd0,3) and root=(hd0,7) statements.
You should look this up in grub to be sure, but I think that partitions also start couting at zero.
That would mean that your third partition on the first hd is found by (hd0,2).
 
1 members found this post helpful.
Old 03-04-2017, 01:08 PM   #4
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 9,420

Rep: Reputation: 2088Reputation: 2088Reputation: 2088Reputation: 2088Reputation: 2088Reputation: 2088Reputation: 2088Reputation: 2088Reputation: 2088Reputation: 2088Reputation: 2088
Quote:
You should look this up in grub to be sure, but I think that partitions also start couting at zero.
That's true for Grub Legacy but with Grub2, drives begin counting from zero, partitions from 1.
 
Old 03-06-2017, 11:35 PM   #5
ajayss
LQ Newbie
 
Registered: Feb 2017
Posts: 11

Original Poster
Rep: Reputation: Disabled
Hi,

The issue is solved
I did "chown root" to the linux .tar file and then am able to boot in normal mode.

@goumba : My rootfs was built as part of the kernel. So no separate initrd needed.
@hoes : In grub2 partitions start numbering from 1 as mentioned by @yancek.

Anyway, thanks guys for the suggestions.

Ajay
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Fedora 23 booting to emergency mode runningconfig Linux - Newbie 1 01-09-2016 03:17 PM
Cryptic booting error on Fedora 22 with emergency mode geminiman112 Linux - Software 3 09-20-2015 03:14 AM
[SOLVED] Oracle Linux 7 How to recover from emergency mode rajthampi Linux - Newbie 2 07-04-2015 02:45 AM
Booting into Emergency mode manyrootsofallevil Red Hat 12 07-10-2013 06:46 PM
Emergency mode can mount the HDD with FS error but not in rescue or single user-mode kayod_jj Linux - Newbie 3 12-01-2010 07:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration