LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-21-2008, 09:48 PM   #1
Ceran
Member
 
Registered: Sep 2006
Posts: 32

Rep: Reputation: 15
Why is there no Wifi Support in Linux?


I'm using Fedora 8. It's repo has few wireless tools. It autodetected and installed the kernel modules for using my wifi card, but no matter what mode I try and start the card's network interface with, all I ever get is "Determining IP information for wlan0...Failed". I've tried using wlassistant to browse nearby networks, but it says none are detected. I try the same thing with a Windows laptop, and I get 8 networks, all it can connect to with the push of a SINGLE button. It doesn't ask for wireless modes, or channels, or transmit rates. I hate Microsoft as much as the next guy, but their Wifi manager just *works*. I really wish Linux had this basic functionality.
 
Old 01-21-2008, 09:59 PM   #2
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 2,024

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Quote:
Originally Posted by Ceran View Post
I really wish Linux had this basic functionality.
It does.

Try NetworkManager.
 
Old 01-21-2008, 10:03 PM   #3
Ceran
Member
 
Registered: Sep 2006
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by rkelsen View Post
It does.

Try NetworkManager.
What do you think's installed by default in Fedora? It's not been getting good reviews, especially concerning wireless support.
 
Old 01-21-2008, 10:22 PM   #4
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
I have been testing several distros lately--specifically for Wireless. Fedora is among the best. Also very good is Ubuntu. I particularly like the feature ( a Gnome feature, I think) where you hover or click on the network icon in the task bar and see a list of the detected hot spots.

I'm far more concerned about getting power management working. Fedora 8 is the ONLY distro that could be configured to do what I wanted when the lid was closed.

I do NOT want things in Linux to be designed so the user doesn't have to think. That paradigm is what has helped facilitate the Windows monopoly.
 
Old 01-21-2008, 10:31 PM   #5
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 2,024

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Quote:
Originally Posted by Ceran View Post
It's not been getting good reviews, especially concerning wireless support.
Who cares about the reviews? It works for me, and has done so under several different distributions that I've installed, used and experimented with since I first set up my wireless network in 2004. People often deride that which they don't understand.

Open a terminal, switch to root and run "ifconfig" (without quotes of course) and post the output here.
Quote:
Originally Posted by Ceran View Post
It doesn't ask for wireless modes, or channels, or transmit rates.
Nor does NetworkManager. In fact, I can honestly say that even before NetworkManager was released (and - shock, horror! - wireless was configured from the command line), I've never had to input any of those details to get wireless working.
 
Old 01-21-2008, 10:54 PM   #6
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677
Additionally to the iwconfig command, look at the output of "iwlist scan". It should list networks detected. If not, then you may not have your device working which is needed before you can try authenticating with an AP. This step is needed whether you are running Linux or Windows. In Windows, you probably installed a third party driver before you could connect to a wireless network.
 
Old 01-21-2008, 11:11 PM   #7
elliott678
Member
 
Registered: Mar 2005
Location: North Carolina
Distribution: Arch
Posts: 977

Rep: Reputation: 73
Quote:
Originally Posted by Ceran View Post
I hate Microsoft as much as the next guy, but their Wifi manager just *works*.
HAHA! That is a good one. Maybe for you, but in my experience it is the most unreliable thing ever in XP, Vista's is on an even higher level of suck. Sure is pretty though.
 
Old 01-22-2008, 07:38 AM   #8
Ceran
Member
 
Registered: Sep 2006
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by rkelsen View Post
Who cares about the reviews? It works for me, and has done so under several different distributions that I've installed, used and experimented with since I first set up my wireless network in 2004. People often deride that which they don't understand.

Open a terminal, switch to root and run "ifconfig" (without quotes of course) and post the output here.

Nor does NetworkManager. In fact, I can honestly say that even before NetworkManager was released (and - shock, horror! - wireless was configured from the command line), I've never had to input any of those details to get wireless working.
# /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:11:09:C6:9E:CC
inet addr:76.99.156.188 Bcast:255.255.255.255 Mask:255.255.248.0
inet6 addr: fe80::211:9ff:fec6:9ecc/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:178680 errors:0 dropped:0 overruns:0 frame:0
TX packets:31822 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:132139612 (126.0 MiB) TX bytes:1820396 (1.7 MiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4534 errors:0 dropped:0 overruns:0 frame:0
TX packets:4534 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2628156 (2.5 MiB) TX bytes:2628156 (2.5 MiB)

wlan0 Link encap:Ethernet HWaddr 00:11:09:9C:0C:F9
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wmaster0 Link encap:UNSPEC HWaddr 00-11-09-9C-0C-F9-68-AF-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Btw, how is the user supposed to interact with NetworkManager? I have both the NetworkManager and NetworkManager-gnome packages installed, but the only effect this seems to have is that system-config-network has a "Controlled by NetworkManager" check box. I even have the wlan0 checked, but I still can't enable the interface.

I remember seeing an applet in Fedora 7 that would list the details of a wireless connection, but the only applet I can find now is "Network Monitor", and I can't set that to monitor wlan0, presumably because I can't enable the interface.

Btw, my wifi hardware is a Ralink RT2500 802.11g Carbus/Mini-PCI.
 
Old 01-22-2008, 07:42 AM   #9
Ceran
Member
 
Registered: Sep 2006
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jschiwal View Post
Additionally to the iwconfig command, look at the output of "iwlist scan". It should list networks detected. If not, then you may not have your device working which is needed before you can try authenticating with an AP. This step is needed whether you are running Linux or Windows. In Windows, you probably installed a third party driver before you could connect to a wireless network.
# /sbin/iwconfig
lo no wireless extensions.

eth1 no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thrff Fragment thr=2352 B
Encryption keyff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

# /sbin/iwlist scan
lo Interface doesn't support scanning.

eth1 Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan0 No scan results

However, I'm sure the kernel modules for my ralink device are running:
# /sbin/lsmod | grep rt2
rt2500pci 20417 0
rt2x00pci 11201 1 rt2500pci
rt2x00lib 20929 2 rt2500pci,rt2x00pci
rfkill 9297 1 rt2x00lib
input_polldev 7369 1 rt2x00lib
mac80211 115789 2 rt2x00pci,rt2x00lib
crc_itu_t 6081 2 rt2x00lib,firewire_core
eeprom_93cx6 6081 1 rt2500pci

Is it possible the native Linux driver simply doesn't support my device? Last year, I tried the proprietary driver using ndiswrapper, but had the same results.
 
Old 01-22-2008, 09:35 AM   #10
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,241
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
Might help to post exactly what device you have ( lspci )

ralink devices are among the easiest to get working in Linux imho.
Took me all of about 2 minutes to get my rt2500 device functional on Debian Etch.
 
Old 01-22-2008, 07:26 PM   #11
Ceran
Member
 
Registered: Sep 2006
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by farslayer View Post
Might help to post exactly what device you have ( lspci )

ralink devices are among the easiest to get working in Linux imho.
Took me all of about 2 minutes to get my rt2500 device functional on Debian Etch.
I mentioned this above, but here is the lspci formatted output

# lspci | grep RaLink
03:02.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
 
Old 01-22-2008, 07:29 PM   #12
AceofSpades19
Senior Member
 
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 58
Quote:
Originally Posted by elliott678 View Post
HAHA! That is a good one. Maybe for you, but in my experience it is the most unreliable thing ever in XP, Vista's is on an even higher level of suck. Sure is pretty though.
I would be lucky if I got to use the internet for more then a hour before the wireless connection crapped out in windows xp, windows xp really sucked with wpa too
 
Old 01-22-2008, 08:05 PM   #13
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 2,024

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Try these steps (as root):

ifconfig ra0 up
iwconfig ra0 essid your_router's_essid
dhcpcd ra0

Notes: Those are zeros, not "oh"s. You may not have "dhcpcd", in which case you can subsitute "dhclient".

If your router is WPA-enabled, then there is a bit more involved. I can step you through that if need be.
 
Old 01-22-2008, 08:41 PM   #14
Ceran
Member
 
Registered: Sep 2006
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by rkelsen View Post
Try these steps (as root):

ifconfig ra0 up
iwconfig ra0 essid your_router's_essid
dhcpcd ra0

Notes: Those are zeros, not "oh"s. You may not have "dhcpcd", in which case you can subsitute "dhclient".

If your router is WPA-enabled, then there is a bit more involved. I can step you through that if need be.
Thanks, I appreciate your help, but as you can see from the ifconfig output in my previous post, I have no ra0 interface, only wlan0.

I'm guessing I'd get a ra0 interface if I installed the ndiswrapper driver, but I'd like to try getting the native Linux driver working, since it apparently takes just a couple minutes to setup (even though I've been trying for the last year with no luck).

However "ifconfig wlan0 up" has no effect for me. Either something's broken, or my distro's equivalent is something like "ifup wlan0". For that I at least get some output, but it's discouraging:

# ifup wlan0
Determining IP information for wlan0...Firewall started
failed.

Right now, I'm focusing on just simply getting the interface up, since that's a prerequisite for everything else.
 
Old 01-22-2008, 08:55 PM   #15
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 2,024

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Quote:
Originally Posted by Ceran View Post
Thanks, I appreciate your help, but as you can see from the ifconfig output in my previous post, I have no ra0 interface, only wlan0.
Yes, I had noticed that. The first command in my prior post would "create" ra0.
Quote:
Originally Posted by Ceran View Post
I'm guessing I'd get a ra0 interface if I installed the ndiswrapper driver
You'd get an ra0 interface if you followed the steps in my prior post.

While the wlan0 interface may exist (for reasons which are beyond my understanding), I can tell you that it isn't the one that you are meant use. On my system, I have an ath0 (Atheros wireless) and wlan0. ath0 is the one which gets an IP address.
Quote:
Originally Posted by Ceran View Post
but I'd like to try getting the native Linux driver working, since it apparently takes just a couple minutes to setup
It might help if you would at least try following instructions.
Quote:
Originally Posted by Ceran View Post
However "ifconfig wlan0 up" has no effect for me.
No. And I wouldn't expect it to, either.
Quote:
Originally Posted by Ceran View Post
Right now, I'm focusing on just simply getting the interface up, since that's a prerequisite for everything else.
Please follow the instructions in my prior post, then report results here.

Last edited by rkelsen; 01-22-2008 at 08:57 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Rugged, powerful WiFi cards support Linux LXer Syndicated Linux News 0 02-10-2007 02:33 PM
LXer: Why Linux donít support mp3 and selected wifi cards out of the box? LXer Syndicated Linux News 0 11-12-2006 02:24 AM
best wifi support distro... eoth Linux - Distributions 1 06-04-2006 11:18 AM
WiFI card support on FC 3 kojak012 Linux - Wireless Networking 1 12-15-2005 10:07 AM
WiFi support? Konig Fedora 2 01-08-2004 12:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration