Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 11-12-2005, 10:31 AM   #1
LQ Newbie
Registered: Nov 2005
Posts: 12

Rep: Reputation: 0
Unhappy Why I can't start Apache

Please help.

I have installed RedHat 9 and its Apache as root user. There is no problem for me to start the Apache.

However, when I want to run the Apache as a normal user (./httpd start), I have the following error messages: not shared...file not found

I only have in my system.

So I link the to
But, this time it give me another error message: .....not found

The expat in my system is 1.95.5.

Can someone help me, please.


Old 11-12-2005, 11:39 AM   #2
LQ Veteran
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
How are you trying to start apache as a normal user? The way it is supposed to be done is by specifying the user and group in httpd.conf (at least with Apache 1.3, Apache 2 may be slightly different). You then start apache as root and apache switches the listening processes to the normal user.

By the way, if you are going to expose this box to the Internet, you are SERIOUSLY going to want to look at a more modern distro. RH9 hasn't been supported for quite some time and there are going to be some nasty security issues that a more modern distro will have already solved.
Old 11-13-2005, 01:32 AM   #3
LQ Newbie
Registered: Nov 2005
Posts: 12

Original Poster
Rep: Reputation: 0

The reason that I want to start the Apache as a normal user is because I want to test my home page.

Are there some ways to test me home page as a normal user?

Will it cause any problem if I test my home page as a root user?

Please advise.


Old 11-13-2005, 02:15 AM   #4
LQ Guru
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 75
You need to edit your httpd.conf and make sure that the Userdir section is enabled and the user directory is set to public_html. Once thats done, create a directory called public_html in your home directory and give it permissions of 755. To access your webpages you would then do something like http://localhost/~userid/page.html. Apache still has to be started by root.

Redhat 9 reached its end of life last year, so Redhat no longer provides updates and support for it. You ought to think of using Fedora Core, RHEL or CentOS because they are still being activley developed and recieving security upgrades.
Old 11-14-2005, 11:00 PM   #5
LQ Newbie
Registered: Nov 2005
Posts: 12

Original Poster
Rep: Reputation: 0
I will try that.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
I can start apache ridge321 Linux - Software 3 02-20-2005 01:23 PM
Failed to start apache : Apache does not appear to be running : number11 Slackware 9 02-11-2005 09:51 AM
Apache will not start. MercuryRaz0r Linux - Networking 7 11-04-2004 08:10 AM
can't get SSLl working on Apache. Apache won't start bentman78 Linux - Software 1 08-10-2003 06:17 PM
apache not able to start up raymondm Linux - Newbie 1 04-22-2003 04:07 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:06 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration