-   Linux - Newbie (
-   -   Why does SLES allow no access to its X Server? (

cephus5 03-19-2008 03:33 AM

Why does SLES allow no access to its X Server?
I wouldn't call myself a newbie but I don't think this question fits in the Distributions section because I have a hunch that it's more of a general linux thing.

So I'm working on a SLES 10 and running applications on a remote server (AIX 6.1). I cannot (neither with ssh -X nor with telnet, xhost, DISPLAY) get the remote GUIs to appear on my SLES screen. I tried the same thing with an SLES 9 and it also didn't work. It works problem free with Cygwin or Hummingbird.

Is there a security configuration in SLES I'm missing?

To prove that I'm not just asking random questions without trying to find the answer, here are things that aren't the problem:

1. on the remote machine (AIX), ForwardX11 is set to yes in /etc/ssh/ssh_config

2. I tried logging onto the remote machine with ssh -X root@remoteHost, then running xclock:
Error: Can't open display:
It's a bit strange that nothing is in the DISPLAY variable at this time, so I try step 3:

3. I also tried setting xhost + <remoteHost>, then doing telnet <remoteHost>, then setenv DISPLAY <SLES10-IP>:0.0

xclock on the remote host returns (after over 20 seconds' wait):
Error: Can't open display: <SLES10-IP>:0.0

So which of you Gurus has some experience with this and can give me a hand? Thanks a lot in advance,


bigrigdriver 03-19-2008 07:49 AM

Try these instructions:

cephus5 03-19-2008 08:36 AM

Already tried it
First of all thanks for the response.
The linked page describes exactly the procedure that I tried in 'attempt 3' but this gave the above mentioned error. Any more ideas?


cephus5 06-03-2008 06:18 AM

I found the answer myself and proved to be a SuSe newbie. In the Control Panel, under 'firewall' you can choose to allow access to the X Server, this was it. As soon as I set this option to 'allow', I could use ssh -X and telnet with DISPLAY, etc.

Thanks to everyone for your help anyway, and to anyone with my problem, hope this helps you.


All times are GMT -5. The time now is 06:02 AM.