LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-24-2011, 06:18 AM   #1
Chia L'Etranger
LQ Newbie
 
Registered: Apr 2011
Location: Australia
Distribution: Ubuntu Studio (10.10 Maverick)
Posts: 8

Rep: Reputation: 0
Why do I keep losing full permissions?


I am currently running Ubuntu Studio (a variant of Ubuntu 10.10), dual-booted with Windows 7. For convenience's sake, I have three partitions - one for 7, one for Ubuntu, and a third shared partition, for all of my non-OS-specific media, documents and programs.
I am using RhythmBox Media Player, and have it pointed at a folder on the shared partition as a music library.
However, every time I boot, I have to re-mount the shared partition, which requires re-entering my login password.
In a similar vein, when I'm installing programs in terminal (doing 'sudo apt-get install [x]'), I have to re-enter my password each time I do a sudo command.
Is there any way to keep super-user permissions until I choose to drop them myself? Better yet, can I make it so that logging in as the admin account automatically instates super-user privileges?
Thanks in advance.
 
Old 04-24-2011, 06:22 AM   #2
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hello and Welcome to LinuxQuestions,

That's the whole nature and advantage of sudo, limiting the powers a regular user has on a system and requiring a password to execute 'high level' commands. You can set up sudo no to use a password with the NOPASSWD option if that's really what's bothering you. Automatically obtaining root powers or logging in as root is really a bad idea since one simple mistake could render your system unusable.

Kind regards,

Eric
 
Old 04-24-2011, 06:24 AM   #3
Chia L'Etranger
LQ Newbie
 
Registered: Apr 2011
Location: Australia
Distribution: Ubuntu Studio (10.10 Maverick)
Posts: 8

Original Poster
Rep: Reputation: 0
Hrrmmmm. Yes, good point. Okay, so in that case, is there another way around the problem with mounting the partition? How do I make mounting a partition a task that doesn't require root powers?
 
Old 04-24-2011, 06:35 AM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852
Add your shared partition to your /etc/fstab, so that it gets automatically mounted at boot time.
 
Old 04-24-2011, 06:35 AM   #5
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

What have you got in your /etc/fstab for that partition?

Kind regards,

Eric
 
Old 04-24-2011, 06:38 AM   #6
Chia L'Etranger
LQ Newbie
 
Registered: Apr 2011
Location: Australia
Distribution: Ubuntu Studio (10.10 Maverick)
Posts: 8

Original Poster
Rep: Reputation: 0
Hello,

My /etc/fstab reads:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda6 during installation
UUID=be975088-b323-4534-8b0f-3b8233386401 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda7 during installation
#UUID=09859a1b-af56-48e9-a061-5e550389d24e none swap sw 0 0
/dev/mapper/cryptswap1 none swap sw 0 0
 
Old 04-24-2011, 06:43 AM   #7
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

As indicated by TobiSGD, add your shared partition to your /etc/fstab. Then execute:
Code:
sudo mount -a
to see if it gets mounted correctly (umount before to test). That way you'll make sure there are no errors in your fstab line so that it mounts automatically when booting.

Kind regards,

Eric
 
Old 04-24-2011, 07:02 AM   #8
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 291Reputation: 291Reputation: 291
Quote:
Originally Posted by Chia L'Etranger View Post
In a similar vein, when I'm installing programs in terminal (doing 'sudo apt-get install [x]'), I have to re-enter my password each time I do a sudo command.
After you run a command with sudo in the terminal, Ubuntu should allow you to run additional commands using sudo for about 15 minutes without having to re-enter your password. Does it not give you this 15 minute period of using sudo without re-entering your password?
As long as you keep the terminal open, you should get this 15 minute grace period on Ubuntu.

Last edited by tommcd; 04-24-2011 at 07:03 AM.
 
Old 04-24-2011, 07:02 AM   #9
Chia L'Etranger
LQ Newbie
 
Registered: Apr 2011
Location: Australia
Distribution: Ubuntu Studio (10.10 Maverick)
Posts: 8

Original Poster
Rep: Reputation: 0
Hello,

I'm not sure that I added it to /etc/fstab properly - the drive has disappeared from my Places menu.

I changed my fstab to read:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda6 during installation
UUID=be975088-b323-4534-8b0f-3b8233386401 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda7 during installation
#UUID=09859a1b-af56-48e9-a061-5e550389d24e none swap sw 0 0
/dev/mapper/cryptswap1 none swap sw 0 0
/dev/sda5 /mnt/shared ntfs ro,user,auto,umask=0 0 0

Last edited by Chia L'Etranger; 04-24-2011 at 07:04 AM.
 
Old 04-24-2011, 07:04 AM   #10
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852
Please show us your /etc/fstab, so that we can tell you.
 
Old 04-24-2011, 07:06 AM   #11
Chia L'Etranger
LQ Newbie
 
Registered: Apr 2011
Location: Australia
Distribution: Ubuntu Studio (10.10 Maverick)
Posts: 8

Original Poster
Rep: Reputation: 0
I have edited my post to include my new /etc/fstab

Edit:
Quote:
Originally Posted by tommcd View Post
After you run a command with sudo in the terminal, Ubuntu should allow you to run additional commands using sudo for about 15 minutes without having to re-enter your password. Does it not give you this 15 minute period of using sudo without re-entering your password?
As long as you keep the terminal open, you should get this 15 minute grace period on Ubuntu.
Didn't notice your post, sorry. Yes, I get the grace period, I was just wondering if there was a way to make it last longer.

Last edited by Chia L'Etranger; 04-24-2011 at 07:08 AM.
 
Old 04-24-2011, 07:12 AM   #12
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

I'm not sure but why are you including umask=0? And if you include it, shouldn't it be umask=0000? On an additional note, I think it should be users and not user for NFS.

Kind regards,

Eric

Last edited by EricTRA; 04-24-2011 at 07:14 AM.
 
Old 04-24-2011, 07:16 AM   #13
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852
After fixing the umask entry (or just remove it, umask is for writing files, but you are using ro for mounting read-only) and making sure that /mnt/share exists itshould mount properly.
If it doesn't show up in your places (which I think is normal with drives that are mentioned in fstab), just bookmark it in your file-manager and it should show up.
 
1 members found this post helpful.
Old 04-24-2011, 07:18 AM   #14
Chia L'Etranger
LQ Newbie
 
Registered: Apr 2011
Location: Australia
Distribution: Ubuntu Studio (10.10 Maverick)
Posts: 8

Original Poster
Rep: Reputation: 0
Hello,

I was including umask=0 because that's what it said to do when I Googled it. >.>
Is this bad? The instructions I found here say that it allows "everybody to do everything with the files on disk", which I took as meaning that it gives read and write permissions.
(I couldn't find any rule against users with low post counts posting links, hope this is okay.)
 
Old 04-24-2011, 07:20 AM   #15
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

Already indicated by TobiSGD, umask is used for writing and you are defining your mount as read only (ro). Either change to rw or delete the umask entry.

Kind regards,

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Full Screen Permissions dmlx48 Linux - Software 0 03-15-2009 08:18 AM
httpd.conf losing permissions when changed by WHM derricke Linux - Server 3 10-20-2008 11:14 AM
Samba Profiles Losing Permissions Settings (Java App) djturner Linux - Networking 0 10-07-2005 01:06 PM
losing permissions on /home folder johnnymo Linux - Software 1 01-25-2005 10:59 PM
How do I change permissions for a full Stevetgn Linux - Newbie 3 05-15-2004 03:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration