-   Linux - Newbie (
-   -   Why aren't common commands working? (

NewTuxGirl 06-05-2004 09:42 AM

Why aren't common commands working?

I just installed Fedora 2 last night, and I seem to be having a PCMCIA problem where it is not recognizin my network cards. It seems to be able to identify the model, but I get a message on boot that the 'device is not present,' as well as when I try to enable the card through the gui. furthermore, there is no acknowledgement beeps when I plug a card in after boot. My ethernet worked when I installed core 1.

I'm having a huge problem with terminal, though. I see commands suggested all over the place--lspci, cardctl, modprobe, ifconfig--but when I try to use any of these I get a bash message telling me the command is not found.

What am I doing wrong? Do I need to be in a certain directory? I have the same failure in root, /dev/, /sbin/, and /etc/.

Please help! I am getting very frustrated. I expected some hardware issues (it's a laptop), but if I can't even use basic commands, how am I supposed to fix anything??? I have two books in front of me, but neither is specifying directories for any of these commands, nor have any message boards.

Philippe 06-05-2004 09:56 AM


If the command returns "not found", this could be :
- the command does not exist
- the path is not good.

Your path depends on your user. these commands need the root Path, so please begin by typing : su - and the root password. Don't forget the -, or you will not execute the profile and still have the PATH of your user.

"su - root" is the same thing that "su -"

Maybe this helps,


oldyas 06-05-2004 11:24 AM

The command "whereis" checks the most likley places for the command you give it.

If for some reason your $PATH is messed up, use


export PATH="$PATH:<directory-you-want-to-add-goes-here>"

NewTuxGirl 06-05-2004 12:19 PM

Thanks....a friend pointed out to me though 'su' is enough to log in as root, i need su - root to set up the shell properly.

My card still doesn't work, but at least now I can use tools to find the problem!


michaelk 06-05-2004 12:58 PM

Futhermore, linux only searchs directories in the path enviornment but not the current working directory for a command.

./ is a shortcut for current working directory.

Philippe 06-05-2004 11:22 PM


Futhermore, linux only searchs directories in the path enviornment but not the current working directory for a command.
Right ... except if you put " . " in your $PATH ;-)


320mb 06-06-2004 06:01 AM

from a term window or command line type:

which $SHELL
this will tell you what your default shell is.........IE
/bin/bash, /bin/csh, /bin/tsh----------etc.

NewTuxGirl 06-06-2004 10:46 AM

Oooo....good to know
That sounds *very* useful....thanks!!!

So much to learn! :scratch:


Santas 06-07-2004 10:42 AM

Put " . " in the PATH is not a good idea.

All times are GMT -5. The time now is 12:59 AM.