LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-29-2004, 09:18 AM   #1
laszlo
LQ Newbie
 
Registered: Nov 2003
Location: Adelaide, Australia
Distribution: RedHat 7.2, 9
Posts: 7

Rep: Reputation: 0
Angry Who is editing my fstab???!!!


Hi,

I started to use a USB thumbdrive on a box with RH9. I can mount it with
Code:
mount -t vfat /dev/sda1 /mnt/flash
and it works. I added the line:
Code:
/dev/sda1   /mnt/flash    auto    noauto,users,kudzu 0 0
to my /etc/fstab. Everything is OK until I disconnect and reconnect the drive. At the moment when the drive is connected, the mount point (/mnt/flash) disappear together with the line I added to fstab.

What the hell is going on here??? this is not windoze!!!

If anyone could give me a clue ... so I can stay more or less sane ...

Thanks

laszlo
 
Old 06-29-2004, 09:37 AM   #2
fluppi
Member
 
Registered: Oct 2003
Location: Switzerland (Europe)
Distribution: OpenSuSE, RedHat, Knoppix, IRIX + MacOSX
Posts: 198

Rep: Reputation: 31
Is there a automounter / autofs or simmilar at work ? Or something that detects new hardware ?
 
Old 06-29-2004, 12:10 PM   #3
laszlo
LQ Newbie
 
Registered: Nov 2003
Location: Adelaide, Australia
Distribution: RedHat 7.2, 9
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for the idea, but no autofs, no automount. It is really weird.
 
Old 06-29-2004, 01:29 PM   #4
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,153

Rep: Reputation: 60
I suppose you already have created a directory /mnt/flash manually right??? try using fs type as vfat instead of auto.

code:/dev/sda1 /mnt/flash vfat noauto,users,kudzu 0 0
 
Old 06-29-2004, 04:52 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 16,422

Rep: Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938
Delete the kudzu option from fstab.
 
Old 06-30-2004, 06:37 AM   #6
laszlo
LQ Newbie
 
Registered: Nov 2003
Location: Adelaide, Australia
Distribution: RedHat 7.2, 9
Posts: 7

Original Poster
Rep: Reputation: 0
Cool

I think I've got the culprit: hotplug. It is a bunch of scripts in /etc/hotplug, activated by the chain: /proc/sys/kernel/hotplug -> /sbin/hotplug -> /etc/hotplug/*

Thanks for the ideas.

Cheers

laszlo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
editing /etc/fstab Mad Malc Linux - Newbie 6 09-19-2005 02:25 AM
Editing fstab GingerMegs Linux - Software 1 06-04-2005 05:24 PM
Editing etc/fstab- yet again:-) hitest Slackware 7 04-21-2005 01:50 PM
Editing fstab jodef Yoper 4 11-27-2004 10:06 AM
Fstab editing Ando Linux - General 4 06-29-2003 06:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration