Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-19-2007, 03:07 AM   #1
LQ Newbie
Registered: Mar 2007
Posts: 5

Rep: Reputation: 0
White screen - 3D desktop

So, i got my nVidia driver installed 100% and i went to turn on the 3D desktop to see how cool it was ect. ect. But it asked me to reboot for some purpose, so i reboot and it loads again. When it comes to loading gnome the screen goes all white and i cant do anything. I press ctrl+alt+f1 for command and tried a couple things after researching a bit.

Things I've tried:

1. login as root, typed /etc/sysconfig/xgl but nothing came up

2. " , typed eselect opengl set nvidia and also nothing happened.

3. " , typed gnome-xgl-switch --diable-xgl once again nothing happened...

Please help me. Really want to try this 3D desktop. Thank you for taking the time to read this thread and hopefully it helps me out.

linux dist: Mandriva free 2007



Last edited by jarred; 03-19-2007 at 03:10 AM.
Old 03-19-2007, 09:46 AM   #2
Senior Member
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,142

Rep: Reputation: 49
I guess you put compiz or beryl in the gnome-session-manager without testing it.
I had the whitescreen thing too once, I think because I was still using the open source nvidia driver. So I guess it's a driver issue. To log back into gnome see "man gnome-session" It will tell you where the configuration file is, so you can take the 3d manager out, and be able to start gnome again.

Once it works again, see if you really got the nvidia driver installed "100%" :P
run "glxinfo | grep direct"
and see if direct-rendering is enabled.

Last edited by oskar; 03-19-2007 at 09:58 AM.
Old 03-19-2007, 09:54 AM   #3
Senior Member
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
The "white screen" issue was identified by the Beryl developers as a build issue. You can confirm this is your problem by holding down ctrl and alt, then dragging the white screen. If the "cube" appears and rotates (but all white), this is your problem. The Fedora developers released a new Beryl build shortly after the problem was identified, and that corrected it for me. Check to make sure you have the latest version of the software installed on your system (Beryl 0.2.1 at this moment).


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
White Screen ?! Swoop Linux - Newbie 5 04-01-2007 03:24 AM
White screen then hashed screen on fresh install slan124 Fedora 4 04-14-2006 04:54 AM
white screen sachingarg1604 Fedora 7 10-20-2005 04:33 AM
White screen hlinux Fedora 9 06-30-2005 04:58 PM
White Screen of Death! malinruin Linux - Laptop and Netbook 1 08-21-2003 03:11 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:02 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration