LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   which script does ash shell execute first (https://www.linuxquestions.org/questions/linux-newbie-8/which-script-does-ash-shell-execute-first-698804/)

Jurrian 01-21-2009 04:06 AM

which script does ash shell execute first
 
Hi all,

I installed a embedded demo version of linux on an embedded system. It runs fine, starts an Xserver and everything seems to work fine. However, I tried to change the Xserver, but that gives some errors. So I found the script that started the Xserver, changed it to another dir so it wouldn't be executed, and tried to start the Xserver manually. This wouldn't work with the error can't open display.

So I expected the display value not beeing set correctly. export DISPLAY=:0 wouldn't help me out, though. Perhaps there is some script setting other environments right, that are not available to me because I use ssh to connect to my embedded system.

executing sh command told me I am using an ash shell, and reading the man page of ash tells me ash searches for /etc/profile or /$home/.profile scripts that will be executed. Neither of them exists.

The rcS script is running all scripts in init.d, but none of them changes things to the environment, they only start ssh, xserver, create devices.

Does anyone knows which script starts the rcS, or did I miss a script that the ash shell looks for?
EDIT: the inittab script starts the rcS, but no change in environment in there..

Thanks in advance,

Jurrian


All times are GMT -5. The time now is 10:18 PM.