LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Which programs running in background?? (https://www.linuxquestions.org/questions/linux-newbie-8/which-programs-running-in-background-445323/)

bcsman 05-16-2006 09:29 AM

Which programs running in background??
 
I posted in the Network section but have no responses yet. I'm trying to connect to the internet with my 3Com serial internal modem (not a winmodem). It works great with Xandros but every other distro pretty much tells me when I try to connect the modem is busy. Never does begin to dial. Seems as if something else may be running in the background when booting up and using the modem. How can I check to see what's running in the background in my KDE GUI?? In WinXP the old Ctl-Alt-Del will pop up a task manager and you can check and close running applications. Is there something similar with Linux KDE to do the same?? Maybe I can close whatever seems to be using my modem. I can't remember which distro it was but a weather forecast window kept popping up and I'm sure was trying to access the internet?? Thanks!

Fadoksi 05-16-2006 11:10 AM

Not sure... But I think the process command was:
Code:

ps -aux

mark_alfred 05-16-2006 11:11 AM

For finding out what processes are running, and killing unwanted processes, try htop. Your distro probably has a package for this, if it's not currently installed on your computer. If not, you can download it and install it from http://htop.sourceforge.net/. Or try running top, which is the forerunner of htop.

I doubt that your modem problem is due to a weather applet trying to run, however. I'm assuming that the modem you speak of is a dial-up modem, and not a modem for adsl connections. And so, I'm assuming that you're using KPPP to try to set it up. Often when KPPP doesn't find a modem, it reports that it's "busy". My suggestion, then, is to explicitly state the modem device, and not leave it as the default "/dev/modem". Here are the Windows equivalents:
COM1 = ttyS0
COM2 = ttyS1
COM3 = ttyS2
COM4 = ttyS3
COM5 = ttyS4

So, do not leave the setting as "/dev/modem", but set it to "ttyS?" (replacing the "?" with the appropriate number.) If you don't know the correct number, try them all.

Good luck.

PS, if you are talking about an ADSL modem/router, well, that's a different kettle of fish.

bcsman 05-16-2006 05:55 PM

mark-alfred,
Thanks for the reply and advice! Will give the htop or top command a try after I get home from work.

You're probably right about some program running in the background not causing my modem to say "busy"!! By the way it is a dial-up. What's strange is I've got it working on three or four different distro installs and every one of them has it running on different ttyS?? settings. I would think if the internal modem is installed on a specific PCI slot it would read the same on every system. On the distros I do NOT have my modem working, Linspire, aLinux, Suse10, and Mandriva I have tried every ttyS? setting there was. Seems the ones I can get it working on, Xandros, Fedora 4 & 5 have an automatic modem detector and finds it everytime. Not sure what that auto-detector does that I don't do manually. And the Fedora 5 modem detector found the modem on ttyS14. There is no such option on any of the manual installs, only goes as high as ttyS13!!

Oh well, nobody said Linux was going to be easy. Learning as I go, and trust me there's a lot to learn!!

mark_alfred 05-16-2006 07:12 PM

I had a very similar problem years ago when I was using a dial-up modem. My modem was on /dev/ttyS4, but the detection only went up to /dev/ttyS3. I was told to open a terminal and su to root. Now, using your favorite editor (ie, gedit, or kwrite), open the following file:
/etc/modutils/modem

Now add the following to this file:

pre-install serial rm /dev/modem
post-install serial ln -s /dev/ttyS14 /dev/modem

In your case I'm assuming /dev/ttyS14. If not, try other ones, like /dev/ttyS0.
Save the file and close your editor. Next, still as root, type in:

update-modules

After that is run, reboot.

According to the people giving me this advice, it "tells modutils to run the specified commands during boot but this will happen after the autoconfig and therefore will override autoconfig." What exactly that means, I'm not sure, but it did work for me. In short, it was problems with the symlink. I first got this advice in a Mepis thread, at http://www.mepis.org/node/935. Granted, this advice is years old, and for Mepis; so, it may not work. The other suggestion I have is to check out forums specific to your distro. What is your distro?

bcsman 05-16-2006 07:51 PM

mark-alfred,
Thanks again for the reply! I am new to Linux and just playing with many different distros. Am at work right now but here is a list of what I've experimented with to this point I think!!

Xandros 3.02--modem works great, autodetected
Mandriva 2006--modem worked once, now busy all the time!
Slackware 10.2--modem works
Fedora 4 & 5--modem works, autodetected by system-config-network
Mepis 4.3--modem busy or not recognized
Ubuntu 5.10--modem not recognized
Debian 3.1--modem not recognized
Lindrake ??--modem busy or not recognized
aLinux ??--modem busy or not recognized
PCLinux .92--modem busy or not recognized
Gentoo ??--modem busy or not detected
Suse 10--modem busy or not detected

This pretty well says what I've played with. Mostly using KDE GUI.

I did find a driver at USR for my modem in an .rpm format. I know this only works on certain distros, but might help detection process!!

dtcs 05-16-2006 08:12 PM

Have you tried wvdial it can detect your modem automatically and connect to internet.

bcsman 05-16-2006 08:27 PM

No I haven't. Have read a little about it but not familiar. Do I have to install on most of these distros I've listed or is it normally pre-installed?? If I have to install, I'll have to do alot of reading to find which type file to use .rpm, etc and how to install. I believe this is a command run program, would prefer GUI such as KPPP, but if this works, might be the ticket. Is this going to tell me what Comm port and ttySx the modem is installed to? If so maybe I can use that info to program KPPP and get it to work.

mark_alfred 05-16-2006 10:16 PM

My other suggestion is to just use Xandros, since it worked and found it hassle free - especially if you have either the deluxe or business edition. It's also pretty compatible with the Debian repositories, I think, and has good support.

[dreamy reminisce]
When I first started, I used an open circulation release of the Corel Linux operating system, and it was fantastic. Corel was developed from Debian, and used KDE (which was rare for a Debian based distro at the time). The Corel OS had the best hardware detection of its time, and a very easy install. A lot of people knocked Corel, but I think it did a lot to change how people viewed the potential of Linux. When Corel withdrew from Linux, the OS was taken over by Xandros.
[/dreamy reminisce]

bcsman 05-17-2006 09:21 AM

mark-alfred,
Probably will use the most user-friendly system, but having fun learning about Linux with the other distros I've tried. Will never learn unless you "break a few eggs"!!

dtcs,
Tried wvdial last night after work with my Fedora 5 setup. Scanned the ports and came back with a message saying it could not detect a modem. Really strange because when I got done scanning with wvdial I opened the Network Config program and dialed out on the internet with it! Guess there's no such thing as a sure bet!! The sytem-config-network program found my modem immediately!! Go figure!!

Brian S.

mark_alfred 05-17-2006 11:32 PM

Hi bcsman. Yes, you can't make an omelette without breaking a few eggs. Have you tried my suggestions from post #5 yet?

bcsman 05-18-2006 12:40 PM

mark_alfred,
No I'm sorry I haven't! Been busy in my spare time reformatting my Linux hard drive to try and set up a multi-boot system. Have set up 7 5MB partitions and trying to get grub to recognize and boot any of them.

Will try your #5 suggestion tonight after I get home from work and see if it helps! Have lots to learn about Linux, but this is both challenging and fun! Thanks for all your help and suggestions!! Really appreciation the patience!

Brian S.


All times are GMT -5. The time now is 08:41 AM.