LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-21-2009, 06:01 AM   #1
rijas
LQ Newbie
 
Registered: Mar 2009
Posts: 7

Rep: Reputation: 0
Wink Where to give noapic option to start linux


I have installed "Redhat Enterprise linux ws version 4 32 bit x86"
Linux in my system.

When booting it is showing an error "kernel panic not syncing io apic timer doesn't work boot with apic = debug option"

How can I get a command prompt to give this option.
What is the actual command to start with noapic option.
Anyone please help me.
Thanks
 
Old 03-21-2009, 06:23 AM   #2
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: pclinuxos slackware64 tails kali
Posts: 3,372
Blog Entries: 33

Rep: Reputation: 217Reputation: 217Reputation: 217
Hi, usually, when the boot prompt menu comes up, press F3 or what-ever (maybe F2 or F1 or esc.),

and type in the command-line...

noapic

I also have to type in nomsi (or pci=nomsi)

It may be a colour menu with a cli from grub.

Either way, you need to catch the boot process before the kernel begins to load.

Later you can check out how to add the command to the boot menu so it starts (that way normally).

Cheers, Glenn

ps. Welcome to LQ!

Check out the search function here at LQ, over 3 million posts,

It may save you time waiting for an answer to an existing question.

;-)

Last edited by GlennsPref; 03-21-2009 at 06:36 AM. Reason: Welcome to LQ!
 
Old 03-21-2009, 06:33 AM   #3
rijas
LQ Newbie
 
Registered: Mar 2009
Posts: 7

Original Poster
Rep: Reputation: 0
I am using amd Sempron new processor and Asus mother bord
thanks It is booting now.
Why this error is coming
Is this due to the installation of 32 bit linux in 64 bit machine.
 
Old 03-21-2009, 06:41 AM   #4
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: pclinuxos slackware64 tails kali
Posts: 3,372
Blog Entries: 33

Rep: Reputation: 217Reputation: 217Reputation: 217
I'm not too sure why the chipset behaves that way.

It's too complicated for me.

I just know when ever I have to boot from cd, or a new kernel I have to insert them

into the boot command line.

I'm sure there is more about it, I've read abit on MSI and the kernel,

but it is not within my scope of using/maintaining GNU/linux systems.

Google pci=nomsi noapic

Cheers, Glenn
 
Old 03-29-2009, 12:20 AM   #5
rijas
LQ Newbie
 
Registered: Mar 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Thankyou

Fine . Thankyou . Linux is booting now with noapic option
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I specify the noapic option? lumix Linux - Newbie 2 02-28-2008 09:45 PM
noapic option help allen28 Linux - Newbie 4 07-20-2006 07:04 PM
noapic boot option jalldridge Linux - Newbie 2 04-01-2005 05:05 AM
noapic option, configuration? shanenin Linux - General 2 02-23-2005 04:32 PM
how can pass noapic noacpi in boot option rddreamz Linux - Newbie 1 05-11-2004 01:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration