LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-23-2017, 01:49 PM   #1
Gruber
LQ Newbie
 
Registered: Mar 2017
Distribution: Knoppix
Posts: 5

Rep: Reputation: Disabled
Smile Where did Libre Office go to when I changed window manager from default to Awesome under Knoppix?


Hi there,

I love knoppix and I run it live from a usb with a perpetual storage layer so I can save things for after reboot. I have no HDD and I'm using a Lenovo T61 laptop. (It's really fast for old hardware!)

My issue is that having just moved over to Awesome window manager I see the Debian menu with most of the items I am used to on the normal LXDE desktop menu, but Libre Office is not present anywhere.

Please can you lovely people illuminate me as to where I am going wrong, correct my expectations etc.

Thank you in advance.
 
Old 03-23-2017, 04:56 PM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Hi: & Welcome to LQ-

If all you did was change Window Managers Libre Office should still be there under 'Office' or 'Other' in your Applications Menu.

Open the terminal and type:

Code:
libreoffice
The program should launch for you. IF it doesn't........use the locate cmd to find out where Libre Office is installed.

Code:
locate libreoffice <OR>
find libreoffice
https://awesomewm.org/

Maybe Awesome needs configured? Guessing here as I've never used it.
https://wiki.archlinux.org/index.php/awesome

Last edited by Ztcoracat; 03-23-2017 at 04:58 PM.
 
1 members found this post helpful.
Old 03-23-2017, 05:11 PM   #3
Gruber
LQ Newbie
 
Registered: Mar 2017
Distribution: Knoppix
Posts: 5

Original Poster
Rep: Reputation: Disabled
Thanks that's really helpful.

I've found loffice in ~/bin/share and it loads from a terminal by just typing loffice which is great. I noticed that when I do this the terminal remains busy and does not return to the prompt leaving the app running independently. Is there a way to do this?

Locate works amazingly!! How do I know which one is the equivalent of an exe the one I should run?

Last edited by Gruber; 03-23-2017 at 05:14 PM.
 
1 members found this post helpful.
Old 03-23-2017, 07:57 PM   #4
Soitgoes
Member
 
Registered: Oct 2016
Location: Beyond Thunderdome
Distribution: Gentoo
Posts: 67

Rep: Reputation: Disabled
You can background the process by placing an ampersand behind the command.
Code:
$ libreoffice &
 
1 members found this post helpful.
Old 03-23-2017, 08:15 PM   #5
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Quote:
Originally Posted by Gruber View Post
Thanks that's really helpful.

I've found loffice in ~/bin/share and it loads from a terminal by just typing loffice which is great. I noticed that when I do this the terminal remains busy and does not return to the prompt leaving the app running independently. Is there a way to do this?

Locate works amazingly!! How do I know which one is the equivalent of an exe the one I should run?
When the terminal is used to launch a program it will continue to need the terminal to stay open.
Closing the terminal will terminate the application.

Background the process like Soitgoes suggests. It should help.
 
Old 03-23-2017, 08:17 PM   #6
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Quote:
How do I know which one is the equivalent of an exe the one I should run?
Sorry I haven't had a Windows machine in about 6 years; not sure on that.
 
Old 03-23-2017, 08:20 PM   #7
Gruber
LQ Newbie
 
Registered: Mar 2017
Distribution: Knoppix
Posts: 5

Original Poster
Rep: Reputation: Disabled
Cool OMG This Is Great !!

Blimey! The more I use Linux the more I absolutely love it. Who on earth would have thought that an ampersand would be so powerful? Thanks for your help, it is really appreciated. :-)

Quote:
Originally Posted by Soitgoes View Post
You can background the process by placing an ampersand behind the command.
Code:
$ libreoffice &
 
Old 03-23-2017, 08:25 PM   #8
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Quote:
Blimey! The more I use Linux the more I absolutely love it.
Yeah, us too!-

You're Welcome Gruber.

Don't forget to mark your thread solved.

Cheers
 
Old 03-24-2017, 01:06 PM   #9
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,264
Blog Entries: 10

Rep: Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172
Quote:
Originally Posted by Gruber View Post
My issue is that having just moved over to Awesome window manager I see the Debian menu with most of the items I am used to on the normal LXDE desktop menu, but Libre Office is not present anywhere.
the problem is that the debian menu is not the same as an (xdg) app menu.
in awesome, you probably have to do some configurating to get an xdg app menu.
alternatively you might want to try something ultra-minimal like dmenu.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to make Garuda as default font in Libre Office? 1sweetwater! Linux - Software 3 07-23-2014 07:27 PM
LXer: Awesome Window Manager Default Themes LXer Syndicated Linux News 0 02-05-2013 10:20 PM
[SOLVED] fluxbox can't see my libre office window benslice Linux - Desktop 2 07-02-2012 05:58 PM
libre office take up whole window. casperdaghost Linux - Newbie 4 02-04-2012 08:44 AM
Awesome Window manager ~ resize window key bindings do not work. bubnoff Linux - Desktop 0 12-23-2010 01:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration