LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   When using the command dmesg I only rceivice infomation about wlan0 (https://www.linuxquestions.org/questions/linux-newbie-8/when-using-the-command-dmesg-i-only-rceivice-infomation-about-wlan0-208400/)

jginger 07-22-2004 02:38 PM

When using the command dmesg I only rceivice infomation about wlan0
 
Hi

When I type the command dmesg into the console I get the following message:

work@linux:~> dmesg
564)
wlan0 (WE) : Buffer for request 8B1B too small (0<10)
wlan0 (WE) : Buffer for request 8B0B too small (0<564)
wlan0 (WE) : Buffer for request 8B1B too small (0<10)
wlan0 (WE) : Buffer for request 8B0B too small (0<564)

This pattern carries on for ages and I get no other information. My Internet connection seems to be working okay and is connected over wlan0. When I tried to use this command before I received information on everything else. Please can you help me to get it back to how it used to work. There is probably something obvious that I am missing to get it to work properly.

This is my first post and I hope it contained enough information. If not please ask me what you want to know.

Thanks
John

Tinkster 07-22-2004 02:53 PM

Hi, and welcome to LQ.


Your problem is not that dmesg isn't working (it is doing its
job) ... the problem is that your wlan card must be set-up
incorrectly, and keeps filling the kernels ring-buffer with
warnings ... dmesg reads that buffer (which has a limited
size) and prints the contents.

Have a look at the wlan cards set-up. Once the errors are
gone your dmesg will display what you expect.


Cheers,
Tink

jginger 07-23-2004 05:12 AM

Thanks a lot for the help Tink. I looked around to see the programs using wlan0 and disabled a Kwifi manager applet that was running. This solved the problem and now dmesg works fine. Thanks again

John

Tinkster 07-23-2004 03:44 PM

Pleasure,

glad I could nudge you in the right direction! :)


Cheers,
Tink


All times are GMT -5. The time now is 01:08 PM.