-   Linux - Newbie (
-   -   When I type "sudo grub" it says "command not found" in Ubuntu 9.10 Live CD. (

msbstar 01-30-2010 02:11 AM

When I type "sudo grub" it says "command not found" in Ubuntu 9.10 Live CD.

I am going to reinstall my GRUB bootloader and some one
said do the followings:
sudo grub

> root (hd0,0)

> setup (hd0)

> exit

But when I type "sudo grub" in terminal it gives this error:

"sudo: grub: command not found"

Would you please help me in this problem?

With best regards,

r3sistance 01-30-2010 02:15 AM

You probably don't have path set-up for sbin, try the following line

sudo /sbin/grub

msbstar 01-30-2010 02:20 AM

Hello r3sistance,

Thanks for your reply.

I did what you said and still I got the same result.

What should I do??

Best regards,

r3sistance 01-30-2010 02:24 AM


You could try doing a 'sudo find / -name "*grub"', or if you have locate and updatedb use those instead as they are more effeicent at searches. That should give you the path for the grub command, just ignore configuration files and directories like /boot/grub

msbstar 01-30-2010 02:36 AM


I typed "locate grub" and it returned dozens of lines.
In none of them I could find "menu.lst" and "grub.conf".

I have no idea what has happened to my Ubuntu!!

r3sistance 01-30-2010 03:46 AM

I believe this has been answered in a different thread for you, however you likely should have used locate *grub as this will stop wildcard finds after the word grub.

Bratmon 01-30-2010 10:19 AM

Ubuntu 9.10 uses grub2.

worm5252 01-30-2010 11:05 AM

grub.conf and menu.lst should be located in /boot/grub/

I am on Debian so this might help you since Ubuntu is Debian based.

jared@Sarah:~/Movies$ locate *grub

For me my grub command is located in /usr/sbin/grub

aayadi 07-17-2017 12:24 PM

grub is not installed period


sudo apt-get install grub

notKlaatu 07-17-2017 12:27 PM

aayadi, you are responding to a thread that is over 7 years old. They've probably fixed it by now. :-)

Dates for posts are in the upper-left corner of each post.

All times are GMT -5. The time now is 07:53 PM.