LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-27-2009, 08:48 PM   #1
camshron
LQ Newbie
 
Registered: Mar 2009
Posts: 2

Rep: Reputation: 0
Angry When I try to install a program I get an error message telling me that I need to run


When I try to install a program I get an error message telling me that I need to run dpkg --configure -a so I run that script in terminal and it does nothing. here is the output from the terminal

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
camshron@camshron-desktop:~$ sudo dpkg --configure -a
Setting up dvd-slideshow (0.8.0-0.0ubuntu1.1) ...
dpkg: dependency problems prevent configuration of kdebase-runtime:
kdebase-runtime depends on kde-icons-oxygen (>= 4:4.2.0-0ubuntu1~intrepid2); however:
Version of kde-icons-oxygen on system is 4:4.1.3-0ubuntu1~intrepid1.
dpkg: error processing kdebase-runtime (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kjots:
kjots depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kjots (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kuser:
kuser depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kuser (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kwrite:
kwrite depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kwrite (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libokularcore1:
libokularcore1 depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing libokularcore1 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libkholidays4:
libkholidays4 depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing libkholidays4 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libkcddb4:
libkcddb4 depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing libkcddb4 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kdepim-kresources:
kdepim-kresources depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kdepim-kresources (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kamera:
kamera depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kamera (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kcalc:
kcalc depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kcalc (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kdebase-runtime-bin-kde4:
kdebase-runtime-bin-kde4 depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kdebase-runtime-bin-kde4 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of okular:
okular depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
okular depends on libokularcore1 (>= 4:4.2.0); however:
Package libokularcore1 is not configured yet.
dpkg: error processing okular (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kaddressbook:
kaddressbook depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
kaddressbook depends on kdepim-kresources; however:
Package kdepim-kresources is not configured yet.
dpkg: error processing kaddressbook (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of akonadi-kde:
akonadi-kde depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing akonadi-kde (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libkleo4:
libkleo4 depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing libkleo4 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kappfinder:
kappfinder depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kappfinder (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ksystemlog:
ksystemlog depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing ksystemlog (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of juk:
juk depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing juk (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of sweeper:
sweeper depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing sweeper (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of krfb:
krfb depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing krfb (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ktimer:
ktimer depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing ktimer (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kscd:
kscd depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
kscd depends on libkcddb4; however:
Package libkcddb4 is not configured yet.
dpkg: error processing kscd (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kdepim-wizards:
kdepim-wizards depends on kaddressbook; however:
Package kaddressbook is not configured yet.
kdepim-wizards depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kdepim-wizards (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kolourpaint4:
kolourpaint4 depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kolourpaint4 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of okteta:
okteta depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing okteta (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kalarm:
kalarm depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
kalarm depends on libkholidays4 (= 4:4.2.0-0ubuntu1~intrepid3); however:
Package libkholidays4 is not configured yet.
dpkg: error processing kalarm (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kdegraphics-strigi-plugins:
kdegraphics-strigi-plugins depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kdegraphics-strigi-plugins (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libkpgp4:
libkpgp4 depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing libkpgp4 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kdepim-strigi-plugins:
kdepim-strigi-plugins depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kdepim-strigi-plugins (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kcolorchooser:
kcolorchooser depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kcolorchooser (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libksane0:
libksane0 depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing libksane0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ark:
ark depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing ark (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kmail:
kmail depends on akonadi-kde; however:
Package akonadi-kde is not configured yet.
kmail depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
kmail depends on libkleo4 (= 4:4.2.0-0ubuntu1~intrepid3); however:
Package libkleo4 is not configured yet.
kmail depends on libkpgp4 (= 4:4.2.0-0ubuntu1~intrepid3); however:
Package libkpgp4 is not configured yet.
dpkg: error processing kmail (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of knode:
knode depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
knode depends on libkpgp4 (= 4:4.2.0-0ubuntu1~intrepid3); however:
Package libkpgp4 is not configured yet.
dpkg: error processing knode (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmaildir4:
libmaildir4 depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing libmaildir4 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kopete:
kopete depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kopete (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kdenetwork-filesharing:
kdenetwork-filesharing depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kdenetwork-filesharing (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of korganizer:
korganizer depends on kaddressbook; however:
Package kaddressbook is not configured yet.
korganizer depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
korganizer depends on kdepim-kresources; however:
Package kdepim-kresources is not configured yet.
korganizer depends on libkholidays4 (= 4:4.2.0-0ubuntu1~intrepid3); however:
Package libkholidays4 is not configured yet.
dpkg: error processing korganizer (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kfind:
kfind depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kfind (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kruler:
kruler depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kruler (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kdepim:
kdepim depends on akonadi-kde (>= 4:4.2.0-0ubuntu1~intrepid3); however:
Package akonadi-kde is not configured yet.
kdepim depends on kaddressbook (>= 4:4.2.0-0ubuntu1~intrepid3); however:
Package kaddressbook is not configured yet.
kdepim depends on kalarm (>= 4:4.2.0-0ubuntu1~intrepid3); however:
Package kalarm is not configured yet.
kdepim depends on kdepim-kresources (>= 4:4.2.0-0ubuntu1~intrepid3); however:
Package kdepim-kresources is not configured yet.
kdepim depends on kdepim-wizards (>= 4:4.2.0-0ubuntu1~intrepid3); however:
Package kdepim-wizards is not configured yet.
kdepim depends on kmail (>= 4:4.2.0-0ubuntu1~intrepid3); however:
Package kmail is not configured yet.
kdepim depends on knode (>= 4:4.2.0-0ubuntu1~intrepid3); however:
Package knode is not configured yet.
kdepim depends on korganizer (>= 4:4.2.0-0ubuntu1~intrepid3); however:
Package korganizer is not configured yet.
kdepim depends on kdepim-strigi-plugins (>= 4:4.2.0-0ubuntu1~intrepid3); however:
Package kdepim-strigi-plugins is not configured yet.
kdepim depends on kjots (>= 4:4.2.0-0ubuntu1~intrepid3); however:
Package kjots is not configured yet.
dpkg: error processing kdepim (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of knewsticker:
knewsticker depends on kdebase-runtime (>= 4:4.1.3); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing knewsticker (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kmix:
kmix depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kmix (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kgamma:
kgamma depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kgamma (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libkdecorations4:
libkdecorations4 depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing libkdecorations4 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libkdepim4:
libkdepim4 depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing libkdepim4 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ktnef:
ktnef depends on kdebase-runtime (>= 4:4.1.3); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing ktnef (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kdf:
kdf depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing kdf (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of konqueror-nsplugins:
konqueror-nsplugins depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing konqueror-nsplugins (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of akregator:
akregator depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
akregator depends on libkdepim4 (= 4:4.2.0-0ubuntu1~intrepid3); however:
Package libkdepim4 is not configured yet.
dpkg: error processing akregator (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of khelpcenter4:
khelpcenter4 depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
dpkg: error processing khelpcenter4 (--configure):
dependency problems - leaving unconfigured
dpkg: too many errors, stopping
dpkg: ../../src/packages.c:265: process_queue: Assertion `!queue.length' failed.
Aborted

if someone can actually answer for once that be great(like a REAL community)
 
Old 03-28-2009, 02:42 PM   #2
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,318

Rep: Reputation: 126Reputation: 126
Quote:
Originally Posted by camshron View Post
if someone can actually answer for once that be great(like a REAL community)
I'm at a loss as to why your FIRST post to this forum is an insult. Is this the way you normally act in public when seeking help?

I can't tell for sure, because I've never had this problem, but are you using ubuntu? (you don't say anywhere, that's just a guess) And, if so, is your sources.list pointing to multiple incompatible repos?
 
Old 03-28-2009, 04:13 PM   #3
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,574
Blog Entries: 56

Rep: Reputation: Disabled
Try googling for this:
Quote:
dpkg: dependency problems prevent configuration of kdebase-runtime:
kdebase-runtime depends on kde-icons-oxygen (>= 4:4.2.0-0ubuntu1~intrepid2); however:
Version of kde-icons-oxygen on system is 4:4.1.3-0ubuntu1~intrepid1.
dpkg: error processing kdebase-runtime (--configure):
dependency problems - leaving unconfigured
and this:
Quote:
depends on kdebase-runtime (>= 4:4.1.96); however:
Package kdebase-runtime is not configured yet.
Alternatively, try running sudo apt-get update before installing anything.

Is that "great" enough for you?

Last edited by brianL; 03-28-2009 at 04:18 PM.
 
Old 03-28-2009, 05:01 PM   #4
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,318

Rep: Reputation: 126Reputation: 126
Quote:
Originally Posted by brianL View Post
Alternatively, try running sudo apt-get update before installing anything.

Is that "great" enough for you?
D'oh, don't know why I didn't think to add that. Guess synaptic's held my hand for far too long.
 
Old 03-29-2009, 12:16 AM   #5
saagar
Member
 
Registered: Jul 2008
Location: Chennai, India
Distribution: RHEL5, Ubuntu
Posts: 191

Rep: Reputation: 37
"When I try to install a program I get an error message telling me that I need to run "

...haha...so why don't you obey and try running for some time.?
 
Old 03-29-2009, 06:52 AM   #6
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,574
Blog Entries: 56

Rep: Reputation: Disabled
Quote:
Originally Posted by Quakeboy02 View Post
D'oh, don't know why I didn't think to add that. Guess synaptic's held my hand for far too long.
Well, when I was running Ubuntu or Debian, I used Synaptic most of the time too.
 
Old 03-29-2009, 08:11 PM   #7
camshron
LQ Newbie
 
Registered: Mar 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Smile thanks

thanks for the help dudes
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
run smbpasswd return an error message jodie Linux - Newbie 1 10-02-2008 04:45 PM
Cannot run ./configure (Qt error message) dantux Linux - Software 2 09-04-2007 09:35 PM
run mozilla-firefox and an error message jpan Linux - Software 1 10-16-2004 08:23 AM
error message when run MRTG: SNMP error zhgalaxy Linux - Newbie 0 02-18-2004 01:08 PM
Search Program error message ZhiYi Linux - General 1 03-09-2003 09:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration