-   Linux - Newbie (
-   -   When attempting to install a Linux Distribution it hangs after selecting a language (

Gabbers 11-04-2011 12:26 PM

When attempting to install a Linux Distribution it hangs after selecting a language
Hello All - This problem has been resolved but posting because I am not having any luck locating documentation to help me understand why, what I did, worked/did not work.

Goal: Format a virus/malware infected hard-drive and install an end user friendly version of Linux

Hardware: AMD single-core Athlon 64, 1mb DDR RAM, 160gb IDE drive (containing a single NTFS partition running Windows XP SP3)

Problem: When trying to install a Linux OS I am able to boot to the live desktop but when attempting to install to the local hard drive, it hangs at the screen to select the language. Although the install would not proceed, it was not locking the computer. During that time I was still able to go back to the “live desktop” open a terminal or web browser. I ran into this problems with 3 separate builds on 3 separate types of media (Ubuntu 11.04/USB flash drive, Mint 11/DVD and Fedora13/CD)

My first thought was that the drive is bad, so I replaced it with a 40gb drive (also single NTFS partition with Windows XP). This drive hung the same as the 160gb drive, so I put it back in.

In the next attempt I booted to a live version of Mint 11 > opened a Terminal > and ran fdisk /dev/sda1 and received an error stating it could not access the drive. I ran the df command to make sure I could see the drive and it was not listed. I mounted it and was then able to view and navigate through the Windows files. I attempted to run fdisk again but this time received a message instructing me to unmount the drive. Unmounted the drive, ran sudo fdisk /dev/sda (and /dev/sda1) both ways returned the error stating it could not access the drive

Fix: ran the command mkfs.ext2 /dev/sda1 This ran for maybe 2 minutes and finished without any errors. After which I tired browsing the drive and was able to access it but it gave the appearance that the NTFS file structure and all files were gone. I closed the the Terminal program, clicked the icon to install MINT to my hard-drive which installed as expected. At this time I have been using the workstation for 2 days and have had no further problems.

themanwhowas 11-04-2011 01:09 PM

Somewhere here there's a question. I just can't seem to find it.

Do you have the problem sorted?

Gabbers 11-04-2011 03:01 PM

Somewhere here there's a question
The primary reason for posting was I found another Thread, on the exact same issue, but it did not have any replies that fixed the problem.
I had trouble joining that site, to post a reply, so I thought I would share it here.

The issue is resolved but I do have a couple questions:

Why did fdisk not work?
I checked my syntax, read the man pages and cannot figure out what I must be missing.

Why would the 3 separate distributions, I tried, unable to write/overwrite what was on the drive?
I've only been working with Linux for a few months but have installed both Fedora and Ubuntu on drives formerly running Windows without having to format or change the file structure. The only difference with this one is the machine was so riddled with malware and viruses I couldn't get it to shutdown. I just pulled the plug and restarted, booting to one of the Linux Desktop. Would a corrupt MBR or something along those lines keep Linux from being able to read or write to the disk?

themanwhowas 11-04-2011 04:32 PM

you could have run 'fdisk -l' to show which disks fdisk can access. but yes, 'fdisk /dev/sda' should have run fine AS ROOT. As a normal user can't use fdisk (returns error 'Unable to open /dev/sda') I would assume that you were running as a non root user. You mentioned sudo, perhaps you do not have sudo set up correctly.

Gabbers 11-04-2011 06:19 PM

I was installing Mint which I thought had root disabled. Preceding fdisk with the sudo command, generated the warning "respect others privacy....etc" so I expect it was running the command as privileged user.

All times are GMT -5. The time now is 11:04 AM.