LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   what's this 'clock skew' problem in RH7.3 (https://www.linuxquestions.org/questions/linux-newbie-8/whats-this-clock-skew-problem-in-rh7-3-a-29402/)

aditya 09-02-2002 07:51 AM

what's this 'clock skew' problem in RH7.3
 
Hi guys,
I decided to build a 'boot floppy' on my own. So, I proceeded by making the root file system.
Then I decided to configure the kernel. But when I ran 'make mrproper', I got the following errors:
make[1]:warning:clock skew detected. Your build may be incomplete.
make[1]:Leaving directory /usr/src/linux2.2.18-3/Documentation/DocBook
make:warning:clock skew detected. Your build may be incomplete.


In spite of this, I continued with 'make config', then on executing 'make dep', it gave me the same 'clock skew' error. And when I still tried 'make bzImage', it didn't create the linux file, it exited with the same errors.

I also get these errors whenever I boot my system. I installed RH 7.3 without the X windows, web stuff, and all that. Just simple kernel development, and the sort was included.

Whatizzit???

rshaw 09-02-2002 09:43 AM

its usually a file(s) that has a date/time greater than the system date/time. is your bios clock set to the proper time/date?

aditya 09-03-2002 01:17 AM

problem partially corrected
 
Yep,
I checked my CMOS clock, and it was one year lagging. I corrected it, it the problem of clock skew vanished.
But, I'm still not getting the result.
I did 'make config', then 'make dep'. Then when I ran 'make bzImage', it processed all that blah blah blah, and at the end it exited with errors.
It didn't make the binary image file of the kernel. The last 5 lines of the output of 'make bzImage are:

make[2]: ***[socket.o] Error 1
make[2]: Leaving directory '/root/linux-2.4.18-3/net'
make[1]: ***[first_rule] Error 3
make[1]: Leaving directory '/root/linux-2.4.18-3/net'
make: ***[_dir_net] Error 2

What do I do now?


All times are GMT -5. The time now is 06:28 AM.