LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-21-2016, 08:51 PM   #1
road hazard
Member
 
Registered: Nov 2015
Posts: 156

Rep: Reputation: Disabled
Question What causes this weird tearing issue? Pic inside [SOLVED]


http://imgur.com/a/iKeaz

I've seen this weird tearing issue ALL THE TIME with Linux. Whether I'm in FireFox scrolling a page, in gedit scrolling through a long txt file or watching a movie and the camera pans up/down or the person in the frame moves up/down..... this weird, freaking tearing issue appears. I'm running Mint (but have seen it with ALL the distros I've tried) and using the latest, proprietary NVidia drivers for my gfx card.

What is it? What causes it? How do I get rid of it?

I play a few games via Steam on my Mint install and oddly enough, I don't see this issue when gaming. What gives?

UPDATE: Problem solved. Answer was: http://www.thelinuxrain.com/articles...vidia-try-this Adding: { ForceCompositionPipeline = On } to xorg.conf did the trick.

Last edited by road hazard; 09-22-2016 at 06:23 PM. Reason: Solved
 
Old 09-21-2016, 09:06 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 15,790
Blog Entries: 27

Rep: Reputation: 4633Reputation: 4633Reputation: 4633Reputation: 4633Reputation: 4633Reputation: 4633Reputation: 4633Reputation: 4633Reputation: 4633Reputation: 4633Reputation: 4633
More information would help, such as:

What make model/computer? What version of Mint? What desktop environment? What is specific graphics chipset?

The more detail you provide, the easier it will be for others to help you.

My best guess is that it has something to do with the NVidia graphics, but I don't know enough to hazard anything beyond that.

Last edited by frankbell; 09-21-2016 at 09:08 PM.
 
Old 09-21-2016, 09:13 PM   #3
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,316

Rep: Reputation: Disabled
There are options to pass to nvidia blob to get rid of tearing, requires reading nVidia documentation in /usr/share/.
 
Old 09-21-2016, 11:56 PM   #4
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,994
Blog Entries: 1

Rep: Reputation: 846Reputation: 846Reputation: 846Reputation: 846Reputation: 846Reputation: 846Reputation: 846
You probably have some sync issues. Freesync versus Gsync, amd versus nvidia, change monitors and the issue might go away. Disable some proprietary feature and it should go away. Or use a browser that actually uses GPU acceleration.
 
Old 09-22-2016, 07:10 AM   #5
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: Mojave
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Mint terminal >
Code:
inxi -c0 -Fsz | pastebin
paste the url please.

I have "mint" is = "I haz toaster"
Versions!?

How was the vid driver installed in Mint, exactly?

Last edited by Habitual; 09-22-2016 at 07:11 AM.
 
Old 09-22-2016, 08:08 AM   #6
road hazard
Member
 
Registered: Nov 2015
Posts: 156

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by frankbell View Post
More information would help, such as:

What make model/computer? What version of Mint? What desktop environment? What is specific graphics chipset?

The more detail you provide, the easier it will be for others to help you.

My best guess is that it has something to do with the NVidia graphics, but I don't know enough to hazard anything beyond that.
Generic PC. i5 3570K. 12 gigs of RAM.

Linux Mint 18 (64bit) Mate desktop

NVidia GTX 670

NVidia driver v367.44

Monitor is an LG L227WTG hooked up via DVI
 
Old 09-22-2016, 08:12 AM   #7
road hazard
Member
 
Registered: Nov 2015
Posts: 156

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Habitual View Post
Mint terminal >
Code:
inxi -c0 -Fsz | pastebin
paste the url please.

I have "mint" is = "I haz toaster"
Versions!?

How was the vid driver installed in Mint, exactly?
https://gist.github.com/00a2d8cc18bc...45bb6c3c6cae82

I installed the drivers like this:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-367 nvidia-settings

Rebooted my machine and done.

Thanks
 
Old 09-22-2016, 08:21 AM   #8
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: Mojave
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by road hazard View Post
[url]
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-367 nvidia-settings
Are those from here?
Have you tried the XOrg driver (default) or the recommended in Driver Manager prior to 367?

Please let us know,

Thank you.
 
Old 09-22-2016, 09:27 AM   #9
road hazard
Member
 
Registered: Nov 2015
Posts: 156

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Habitual View Post
Are those from here?
Have you tried the XOrg driver (default) or the recommended in Driver Manager prior to 367?

Please let us know,

Thank you.
Yes, I believe that's the web site I pulled my steps from.

I tried the open sources drivers and the recommended ones from the Mint Driver manager and no matter what, same end result.
 
Old 09-22-2016, 09:33 AM   #10
road hazard
Member
 
Registered: Nov 2015
Posts: 156

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Shadow_7 View Post
You probably have some sync issues. Freesync versus Gsync, amd versus nvidia, change monitors and the issue might go away. Disable some proprietary feature and it should go away. Or use a browser that actually uses GPU acceleration.
Since I see the problem with text editors and watching videos, I think it's bigger than a browser issue. I'd rather not spend $500 for a G-Sync monitor. I'm confident it's a software issue since I don't see this problem when I'm booted into Windows doing the same things.
 
Old 09-22-2016, 09:34 AM   #11
road hazard
Member
 
Registered: Nov 2015
Posts: 156

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Emerson View Post
There are options to pass to nvidia blob to get rid of tearing, requires reading nVidia documentation in /usr/share/.
I'll dig through the documentation, thanks for the tip!
 
Old 09-22-2016, 09:44 AM   #12
road hazard
Member
 
Registered: Nov 2015
Posts: 156

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Habitual View Post
Are those from here?
Have you tried the XOrg driver (default) or the recommended in Driver Manager prior to 367?

Please let us know,

Thank you.
I found this link on the Googles and will try some of these tips when I get home: http://unix.stackexchange.com/questi...oblem-in-linux

EDIT: Found some more links that discuss this problem:

http://www.thelinuxrain.com/articles...vidia-try-this

https://forums.linuxmint.com/viewtopic.php?t=224942
https://forums.linuxmint.com/viewtop...174237#p906436
https://forums.linuxmint.com/viewtopic.php?t=217836

Really looks like this: ForceCompositionPipeline = On ....... will fix my problem.

Last edited by road hazard; 09-22-2016 at 10:21 AM.
 
Old 09-22-2016, 10:29 AM   #13
mybrothersentme
LQ Newbie
 
Registered: Aug 2016
Distribution: Ubuntu 16.04 with Cinnamon 3.0 desktop (as of Sept 2016)
Posts: 19

Rep: Reputation: Disabled
Getting the right Nvidia Driver

Okay, I don't run Mint, BUT Mint 18 is built on Ubuntu 16.04 (Xenial). But I had a similar problem. So, I'm not entirely sure this will work, but, maybe you could give it a try. It really will depend on whether Mint retains the ability to use some Ubuntu commands.

Open terminal command line - no sudo needed and can run from your home directory:

ubuntu-drivers devices | grep recommended

Also, if you aren't familiar with grep, it may look like it isn't doing anything for a few seconds. Wait for it... It should return something like this:

driver : nvidia-3xx.yy - distro non-free recommended

What it returns should be the optimal driver for your card with Ubuntu. Since nVidia drivers do not auto un-install a previous version, so you can get major conflicts unless you purge old one before installing correct one. So run the following to purge the old driver and autoinstall the one you came up with when you ran the previous commands:


sudo apt-get remove --purge nvidia-*
sudo ubuntu-drivers devices
sudo ubuntu-drivers autoinstall


Might solve your problem. Have used it on an OLD nVidia card with success and a recent one with success. Success of ALL of the above will depend on updating Mint regularly. (I check for System updates daily) You must also do a reload of your repositories using Synaptic or whatever S/W manager you use before you run the previous commands or you probably won't get the latest recommended. Hope any of this works for you. I'm not sure if the Nouveau X.org driver is available to you on your desktop, but if you don't specifically need the nVidia driver, that also is an option. I had to go with the nVidia drivers because I have STEAM installed.


yes, I play Hacknet... And I know it's not real like Mr. Robot. :-)
 
Old 09-22-2016, 11:41 AM   #14
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: Mojave
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by mybrothersentme View Post
Okay, I don't run Mint, BUT Mint 18 is built on Ubuntu 16.04 (Xenial). But I had a similar problem. So, I'm not entirely sure this will work, but, maybe you could give it a try. It really will depend on whether Mint retains the ability to use some Ubuntu commands.

Open terminal command line - no sudo needed and can run from your home directory:

ubuntu-drivers devices | grep recommended

Also, if you aren't familiar with grep, it may look like it isn't doing anything for a few seconds. Wait for it... It should return something like this:

driver : nvidia-3xx.yy - distro non-free recommended

What it returns should be the optimal driver for your card with Ubuntu. Since nVidia drivers do not auto un-install a previous version, so you can get major conflicts unless you purge old one before installing correct one. So run the following to purge the old driver and autoinstall the one you came up with when you ran the previous commands:


sudo apt-get remove --purge nvidia-*
sudo ubuntu-drivers devices
sudo ubuntu-drivers autoinstall


Might solve your problem. Have used it on an OLD nVidia card with success and a recent one with success. Success of ALL of the above will depend on updating Mint regularly. (I check for System updates daily) You must also do a reload of your repositories using Synaptic or whatever S/W manager you use before you run the previous commands or you probably won't get the latest recommended. Hope any of this works for you. I'm not sure if the Nouveau X.org driver is available to you on your desktop, but if you don't specifically need the nVidia driver, that also is an option. I had to go with the nVidia drivers because I have STEAM installed.

yes, I play Hacknet... And I know it's not real like Mr. Robot. :-)
Ack, My eyes!
Interesting and awesome tips.
I am out of here. Sorry.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pecualir tearing issue, nvidia gtx960 neo_cool_XIIK Ubuntu 8 05-30-2015 04:35 PM
[SOLVED] KUbuntu 11.04 x64 - Radeon 6950 & Catalyst - Screen tearing issue. edooze Linux - Newbie 5 02-01-2012 07:03 PM
I cannot boot up ubuntu..i get a weird msg(pic of the msg included) please help :( debz480 Linux - Newbie 3 09-12-2010 01:45 AM
PIC issue on RHEL4 platform gcc 3.3.6 compiler dayalan_cse Programming 0 11-05-2008 08:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration