LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   What am I missing? [Gnome desktop] (https://www.linuxquestions.org/questions/linux-newbie-8/what-am-i-missing-%5Bgnome-desktop%5D-583068/)

jchambers 09-07-2007 10:21 PM

What am I missing? [Gnome desktop]
 
Hello everyone.

I don't know what I did or did not do here?
Trying to use Gnome desktop.


Code:

# yum grouplist
Loading "installonlyn" plugin
Setting up Group Process
Setting up repositories
core                      100% |=========================| 1.1 kB    00:00
updates                  100% |=========================| 1.2 kB    00:00
extras                    100% |=========================| 1.1 kB    00:00
Installed Groups:
  Office/Productivity
  Editors
  System Tools
  GNOME Desktop Environment
  Network Servers
  X Window System
  Graphics
  Web Server
  Printing Support
  Mail Server
  Server Configuration Tools
  Sound and Video
  Administration Tools
  Graphical Internet

Available Groups:
  Engineering and Scientific
  MySQL Database
  Development Libraries
  Window Managers
  GNOME Software Development
  XFCE Software Development
  Text-based Internet
  X Software Development
  Virtualization
  Legacy Network Server
  DNS Name Server
  Authoring and Publishing
  FTP Server
  Hardware Support
  Games and Entertainment
  XFCE
  Legacy Software Development
  Java Development
  Web Development
  Windows File Server
  Eclipse
  KDE Software Development
  KDE (K Desktop Environment)
  Educational Software
  PostgreSQL Database
  News Server
  Development Tools


inttab
Code:

...
...
...

# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

# Run xdm in runlevel 5
x:5:once:/etc/X11/prefdm -nodaemon


When I boot up, I get the terminal login prompt.

Any ideas what I am missing?
Brand new install, I had the bright idea of using yum intead of the the CD's. :rolleyes:

Any help is greatly appreciated.

Jon

tommytomthms5 09-07-2007 10:38 PM

im a debian apt-get person myself but i still get the concept of yum... from what i interpret you just need to install a package called gdm or gnome-display-manager so i think its something along the lines of:

#yum install gdm

then reboot

jchambers 09-07-2007 10:44 PM

I will try that, thanks!

Jon

tommytomthms5 09-07-2007 10:57 PM

oh and it never hurts to have bum (boot up manager) it helps with the whole booting up and down process

snares 09-08-2007 12:24 AM

after you login in and type statx does it start the X server or just bring you back to the terminal? If it doesn't then it is just a matter of changing the defualt runlevel in /etc/inittab file. Yours doesn't look proper to me. I'm not sure what distro your using. Yum is usually Gentoo which I try to avoid.(Just not my cup of coffee.) So I wouldn't know if it really is wrong.

jchambers 09-08-2007 02:28 AM

Well now I am really scratching my head?!

I gave up and reinstalled FC6 (to clarify) and let it install all the defaults. On every other box I have had that brings up the x11 environment.

Kernel 2.6.18.2798.fc6 ( have not done a yum update )


So I am back to a terminal login after all that.


snares: "-bash: statx: command not found"


This can't be that difficult, right? :confused:

Thanks for the replies.

snares 09-08-2007 08:06 AM

sorry should have check that my command was typed write.

startx not statx

that my fault sorry

tommytomthms5 09-08-2007 09:13 AM

yea i always triple check when i type commands to make sure there correct it avoids confusion and it only takes a minute.....


the command you want is startx and it can also be done with just X (capital X lowercase dont work)

jchambers 09-08-2007 11:20 AM

A-w-s-o-m-e-!

That worked: # startx

Thanks for your help. :)


Now I can add a command to the grub.conf to get it to load on boot correct?

tommytomthms5 09-08-2007 11:33 AM

usually just setting up the gdm package does that but i think you could add a command or 2 to

/etc/init.d/rc.local but be very VERY careful!!!! use backups for every change

it runs the scripts as root too so you need to be careful of that too

jchambers 09-08-2007 12:36 PM

Ok, i'll take it slow with that.
I do not want to start over again


Thanks again.

Vijair 09-12-2007 05:13 PM

Quote:

Originally Posted by jchambers (Post 2885608)
A-w-s-o-m-e-!

That worked: # startx

Thanks for your help. :)


Now I can add a command to the grub.conf to get it to load on boot correct?


startx doesn't help me, when I type that......it looks as though its starting the server, the screen flashes and nothing happens after...it just goes blank and doesnt give me any errors or bring me back to the terminal!

help me pls...lol

tommytomthms5 09-12-2007 08:56 PM

Quote:

Originally Posted by Vijair (Post 2890090)
startx doesn't help me, when I type that......it looks as though its starting the server, the screen flashes and nothing happens after...it just goes blank and doesnt give me any errors or bring me back to the terminal!

help me pls...lol

yea uhh that could be a problem... try hitting ctrl+alt+backspace or ctrl+alt+[f1 or f2 or f3... up to f6] that should kick it back to terminal where you can read us the error

Vijair 09-12-2007 11:14 PM

hmm
 
ok...i'll try that and get back to you....lol i had uninstall everything...cus i just got fustrated..but I will reinstall....partition over...format...lol and stuff...and let u know what happens...i have never used linux before...and i dont quite understand all that happens when its booting etc. But i guess that is why this formn is in existance...lol, take care bye :)

jchambers 09-12-2007 11:27 PM

Here is what I did...
 
Make sure you have these groups.

# yum grouplist

# yum groupinstall "X Window System"

# yum groupinstall "GNOME Desktop Environment"

# reboot

[ login ]

# startx


Hope this helps.

Good luck!


All times are GMT -5. The time now is 03:08 AM.