LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-20-2016, 01:37 AM   #1
imjustkillingtime
LQ Newbie
 
Registered: May 2016
Distribution: Slackware
Posts: 27

Rep: Reputation: 4
b-l-u-e-t-o-o-t-h


Hello forums. I'm new to Linux and I love to learn.

I have a 7-year-old laptop/notebook and am a bit annoyed by the LED of the bluetooth (see attached image)constantly switched ON whenever i boot or login. I was able to tame it from autostarting in W7 before. Now that i completely switched to Linux i want to do the same. Maybe you can point me to the right directions and/or resources. Any suggestions and tips will be greatly appreciated. Thanks in advance.

GOAL1: Prevent Bluetooth from autostarting.
GOAL2: Manually activate Bluetooth.

DEVICE: Acer Aspire 4740
OS: Slackware32 14.2 stable; vmlinuz-generic-smp-4.4.14-smp; KDE
Attached Thumbnails
Click image for larger version

Name:	bluetooth-tray-icon1.jpg
Views:	14
Size:	31.8 KB
ID:	23392  

Last edited by imjustkillingtime; 10-30-2016 at 07:44 AM.
 
Old 10-21-2016, 10:10 AM   #2
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (15 current), Slack15, Ubuntu studio, MX Linux, FreeBSD 13.1, WIn10
Posts: 10,342

Rep: Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242
hahaha I just went through this myself but just not as much as you did to try and resolve it.

add your user to these groups to get bluetooth.
Code:
lp audio plugdev
as far as all of that other stuff you did, you didn't need to do that, so I do not know if that will conflict with what you actually needed to do. provided your bluetooth is always plugged in like mine in my laptop.. anyways you can log in as root, startx and see if your bluetooth icon is showing up, that way you'll know it is working then add yourself to them groups, or not, just add yourself to them groups log out, log in, if that doesn't work reboot, if that doesn't work then fix what you did to your system prior to posting this help me request.

then you should be able to just turn it off with the gui interphase, or set it to not show present to anyone, as it is not hurting anything being on.

Code:
#/etc/rc.d/rc.bluetooth stop
should shut it down completely. typing that in your terminal of course.

Last edited by BW-userx; 10-21-2016 at 10:22 AM.
 
Old 10-21-2016, 08:21 PM   #3
imjustkillingtime
LQ Newbie
 
Registered: May 2016
Distribution: Slackware
Posts: 27

Original Poster
Rep: Reputation: 4
thanks for the reply BW-userx, but i think im not very clear with my initial post. What im trying to achieve is to prevent/stop my bluetooth from automatically loading. I will update my help me request asap. And by the way, i have:

Code:
$ groups
users lp floppy audio video cdrom plugdev power netdev scanner

Last edited by imjustkillingtime; 10-30-2016 at 07:44 AM.
 
Old 10-21-2016, 08:35 PM   #4
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (15 current), Slack15, Ubuntu studio, MX Linux, FreeBSD 13.1, WIn10
Posts: 10,342

Rep: Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242
Quote:
Originally Posted by imjustkillingtime View Post
thanks for the reply BW-userx, but i think im not very clear with my initial post. What im trying to achieve is to prevent/stop my bluetooth from automatically loading. I will update my help me request asap. And by the way, i have:

Code:
$ groups
users lp floppy audio video cdrom plugdev power netdev scanner
Now that I am in Slack. I personally don't see why just doing what you did didn't work.

Code:
  chmod -x /etc/rc.d/rc.bluetooth
Just removing it from being an executable is suppose to stop it from auto starting at boot.

Quote:
and the result is: problem persists (The LED is always ON across reboots and logins)
what exaclty do you mean by that? LED where on your hw or in you DE?

if it is on your hardware then that is a BIOS / BT power button on your laptop thing

Last edited by BW-userx; 10-21-2016 at 08:44 PM.
 
Old 10-21-2016, 09:38 PM   #5
imjustkillingtime
LQ Newbie
 
Registered: May 2016
Distribution: Slackware
Posts: 27

Original Poster
Rep: Reputation: 4
Quote:
what exaclty do you mean by that? LED where on your hw or in you DE?

if it is on your hardware then that is a BIOS / BT power button on your laptop thing
Sir i am referring to this: http://i.imgur.com/tCCjPR1.jpg

Last edited by imjustkillingtime; 10-30-2016 at 07:45 AM.
 
Old 10-22-2016, 06:39 AM   #6
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (15 current), Slack15, Ubuntu studio, MX Linux, FreeBSD 13.1, WIn10
Posts: 10,342

Rep: Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242
Quote:
Originally Posted by imjustkillingtime View Post
Sir i am referring to this: http://i.imgur.com/tCCjPR1.jpg
Yep, that is your HW (Hardware) the OS (Operating System) has nothing to do with that.

You're BIOS (Basic Input/Output System), kind of does along with your MB (Mother Board, or MoBo).
Most laptops (Smaller desktops that can be carried along with you, and placed on your lap to use.) have a button on it to turn it on or off, some use the fn+ (some key) to turn it on or off, this has nothing to do with your OS per sa.
If you find that button, it might even be what that light is sitting in, that is a button yes, no?

have you tried pushing it to see if that light changes color?

Some laptops may not even provide you with a means to turn it on or off, the light is just their to let you know it is working in the since that the power to it is on.

I suggest you put your OS back the way it was, then all you have to do is Push that button, or key combination to turn your BT (BlueTooth) on or off. Cheers!

I like you're choice of title to indicate an annoying Bluetooth (situation) as opposed to wisdom tooth. Whatever word man came up with to indicate that whole thought process. Comparison, perhaps?

Last edited by BW-userx; 10-22-2016 at 07:11 AM.
 
Old 10-22-2016, 07:06 AM   #7
imjustkillingtime
LQ Newbie
 
Registered: May 2016
Distribution: Slackware
Posts: 27

Original Poster
Rep: Reputation: 4
thanks again for bearing with me BW-userx, but Sir are you saying that it is impossible to prevent my HW from automatically switching ON? That there is no way to configure my OS to solve my problem?

Last edited by imjustkillingtime; 10-30-2016 at 07:45 AM.
 
Old 10-22-2016, 07:25 AM   #8
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (15 current), Slack15, Ubuntu studio, MX Linux, FreeBSD 13.1, WIn10
Posts: 10,342

Rep: Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242
Quote:
Originally Posted by imjustkillingtime View Post
thanks again for bearing with me BW-userx, but Sir are you saying that it is impossible to prevent my HW from automatically switching ON? That there is no way to configure my OS to solve my problem?
If your laptop does not provide a means to cut power to it, short of you actually going in and cutting the wire, then it will always be on. The OS only sees it as a result of the power to it being on, then provides a means for you to use it. The only other way for you to not have it running so others will not see it. Is to keep it in hidden mode, or, I'd have to look this up, keeping your execute permissions on your rc.bluetooth so all you have to do is run the command to start / stop the daemon that controls the software that runs it. as oppose to having it start up on boot.

rc.bluetooth start / rc.bluetooth stop - to turn it on or off which is actually only switching the software that it uses "on" or "off".
 
Old 10-22-2016, 11:50 AM   #9
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Debian
Posts: 6,135

Rep: Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314
Have you entered the BIOS editor at boot up and searched for something to disable Bluetooth?

As for disabling it from Linux, you can set the configuration to kill it the moment it starts: see section 3 of
http://www.pc-freak.net/blog/disable...tooth-devices/
also explained here
https://pseudomorph.wordpress.com/20...based-distros/
 
1 members found this post helpful.
Old 10-22-2016, 07:51 PM   #10
imjustkillingtime
LQ Newbie
 
Registered: May 2016
Distribution: Slackware
Posts: 27

Original Poster
Rep: Reputation: 4
Thank you for the links DavidMcCann i will try and digest it, and for the BIOS thing, i haven't hit my F2 button for a while now.

update
I cant find anything obvious in my BIOS setup utility with regards to disabling bluetooth.
I tried this (3. Disable Bluetooth on Gentoo / Slackware and other Linuces) from one of the links you provided earlier wherein i have to modify my /etc/rc.d/rc.local by adding

Code:
#!/bin/sh
rfkill block bluetooth
exit 0
and
first Reboot = the LED still autoloads, so i reboot again
2nd Reboot = the LED still autoloads then switched OFF by itself (im using runlevel 3 by the way) so i thought it's VOILA but as soon as i logged in (not as root) and issued startx, there it goes again together with the system tray icon. So that's it, i believe it don't fully worked because i already mess it up. Do you think it's time to reinstall? TIA

Last edited by imjustkillingtime; 10-30-2016 at 07:45 AM.
 
Old 10-23-2016, 10:35 AM   #11
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Debian
Posts: 6,135

Rep: Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314
Quote:
Originally Posted by imjustkillingtime View Post
Do you think it's time to reinstall?
No, but it might be time to admit that the manufacturer of the laptop has won.
 
Old 10-23-2016, 12:51 PM   #12
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (15 current), Slack15, Ubuntu studio, MX Linux, FreeBSD 13.1, WIn10
Posts: 10,342

Rep: Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242
I don't know why you just don't put a piece of electrical tape over the LED so it quits bothering you.
 
Old 10-24-2016, 03:16 AM   #13
imjustkillingtime
LQ Newbie
 
Registered: May 2016
Distribution: Slackware
Posts: 27

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by DavidMcCann View Post
No, but it might be time to admit that the manufacturer of the laptop has won.
You might be right Sir but i can feel there's a solution to this. Thanks again.

Quote:
Originally Posted by BW-userx View Post
I don't know why you just don't put a piece of electrical tape over the LED so it quits bothering you.
That would double if not triple the annoyance Sir. You are funny and we both know the saying "Laughter is ...medicine". Thanks again.
 
Old 10-27-2016, 09:50 PM   #14
imjustkillingtime
LQ Newbie
 
Registered: May 2016
Distribution: Slackware
Posts: 27

Original Poster
Rep: Reputation: 4
i thought i disabled the tray icon. wow!
Attached Thumbnails
Click image for larger version

Name:	bluetooth-tray-icon.png
Views:	14
Size:	70.4 KB
ID:	23389  

Last edited by imjustkillingtime; 10-30-2016 at 07:46 AM.
 
Old 10-28-2016, 08:57 AM   #15
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (15 current), Slack15, Ubuntu studio, MX Linux, FreeBSD 13.1, WIn10
Posts: 10,342

Rep: Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242Reputation: 2242
Quote:
Originally Posted by imjustkillingtime View Post
i thought i disabled the tray icon. wow!
lmao ~ find out how your distro adds your user to that bluetooth then remove that user and that will go away. because he/she will no longer have privs to use it.

Code:
 cat /etc/group
then look, hopefully their is a group called bluetooth, just remove your user from that group, when you boot up agian, and log in, it will not be there.

here is how ya do that click me I dare ya.

or you could just take another piece of electrical tape and place it across your screen where that icon is at.

Last edited by BW-userx; 10-28-2016 at 09:02 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
rfkill (software but not hardware) block bluetooth saves battery? stozi Linux - Newbie 1 10-12-2016 02:41 PM
[SOLVED] How to stop remote access, sharing and bluetooth? jdr97 Fedora 4 03-04-2012 04:19 PM
How to get bluetooth audio to stop interferring with wifi? redss Ubuntu 1 12-26-2011 01:31 PM
Latitude D820 + Firewire drive/bluetooth/WiFi/Core Duo issues, please stop by NeXuS_2006 Linux - Laptop and Netbook 2 12-17-2006 02:53 PM
How do I stop Xwindows from autostarting ehsan Linux - General 2 03-14-2001 09:26 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration