LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-10-2007, 12:41 AM   #1
g0dd011
LQ Newbie
 
Registered: May 2007
Location: BONANZA
Distribution: KDE Debian
Posts: 11

Rep: Reputation: 0
Thumbs down Water water everywhere...


Alright, on my very happy 13th install of this OS this week. It seems to come up with a new way to need to eat a hole in my harddrive everytime I install it. This time it's almost like last time...

I try to access my windows files on the other partition, and come to find that the partition has no mount point! I already did this one today so I went and set up

Code:
/mnt/hda1 /winxp ntfs defaults 0 0
The last time I messed everything up, I figure it's because I set the mount point for the home directory, and effectively kicked my user out.

So I make a empty directory for windows to let me call wallpapers, and .inf and .sys files so I can get the the ndiswrapper project I started on this morning, and am 2 steps back from where I started!

Code:
mkdir /winxp
This is all done in root. So all is good in the world, I reboot.
I log back in and find I can't access the windows file, because it's locked out by root! OH BOY! No problem, I'll just go and change my file permissions.

So, now I find myself here, I've got
Code:
chmod
and it's -R rwx coming out of my ears. I'm tired, and I feel like I've wasted my day, mainly because I have. I still can't access my new directory even though I did:
Code:
chown -hR [username] /windows
Then rebooted, it still refuses to let me in the folder... IDK, I really tried to get into this, I have school, and it's almost done. I can go waste my time on the cold war rewriting history and writing up my own profile. I'm really not a happy camper, and anyone who installs an OS twice a day for a week straight because they can't get it to do one simple thing would be in the same boat. Sure there's tons of information out there, but none of it can help me. Water water everywhere, but not a damn drop to drink...
 
Old 05-10-2007, 01:08 AM   #2
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Quote:
chown -hR [username] /windows
You didn't take that literally, did you? [username] needs to be replaced with your username. Also your mount point seems to be /winxp, not /windows.

Last edited by jay73; 05-10-2007 at 01:19 AM.
 
Old 05-10-2007, 01:17 AM   #3
General Failure
Member
 
Registered: Jan 2007
Location: Germany
Distribution: Slackware 13.37
Posts: 387

Rep: Reputation: 35
/mnt/hda1 /winxp ntfs defaults 0 0

needs to be

/dev/hda1 /winxp ntfs defaults 0 0

or even better

/dev/hda1 /winxp ntfs user 0 0

No idea what and why you chowned around there but after mkdir the /winxp directory doesn't need any changes or chowning. File system permissions are set at mount time and thus defined in fstab.

You might want to try out ntfs-3g to gain write access on you windows partition.
 
Old 05-10-2007, 04:57 AM   #4
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Lower Rhine region, Germany
Distribution: Slackware64 14.2 and current, SlackwareARM current
Posts: 1,597

Rep: Reputation: 125Reputation: 125
Chmod does not work with Windows permissions: http://slackwiki.org/Windows_Partitions
 
Old 05-10-2007, 05:05 AM   #5
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677
You need to use the umask option. Using dmask and fmask would be better. You can also use the uid and gid options to change the owner and group of the partition. The dmask and fmask determine the permissions for all directories and files respectively.

See "man 8 mount" for more options.
 
Old 05-10-2007, 09:07 AM   #6
g0dd011
LQ Newbie
 
Registered: May 2007
Location: BONANZA
Distribution: KDE Debian
Posts: 11

Original Poster
Rep: Reputation: 0
It looks like no matter what directory I have it mount in, I'm getting goated by this stinking file permission. I can mkdir anything I want in root, it's just when I mount the info I want in the directory if locks out everyone but root! I'm really hating this...

I just don't know. I'm not stupid, and I REALLY don't like not knowing. Thanks for your replies... I just don't have the time for this. Thank you though, it's much appreciated.
 
Old 05-10-2007, 01:00 PM   #7
Ryptyde
Member
 
Registered: Jun 2004
Location: Tragic City,Michigan,USA
Distribution: Fedora 23 Fedora 22
Posts: 244

Rep: Reputation: 37
If you need to access your NTFS partition to retrieve your files use a Knoppix-5.1.1 liveCD or whatever recent version that you can get. You may be able to change the permissions also using Knoppix. If getting your files is your first priority use the Knoppix disc to mount your NTFS partition.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Testing the water.... Troutwizzard LinuxQuestions.org Member Intro 6 05-25-2006 09:11 AM
dead in the water slzckboy Slackware 7 09-19-2005 05:35 PM
Water cooling? Mack_T Linux - Hardware 3 08-30-2004 06:59 PM
Deep Water portfox Linux - Networking 4 10-30-2003 08:53 PM
Is it in the water? A new Guru :) MasterC General 3 06-01-2003 01:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration