LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Watching TV on Linux (https://www.linuxquestions.org/questions/linux-newbie-8/watching-tv-on-linux-671694/)

seheap 09-22-2008 09:25 PM

Watching TV on Linux
 
My sister's boyfriend just installed linux on my computer (i love it!) but I feel badly that I've asked him so many questions in the past two days so I decided to post here.

I have a Any TV-ATSC stick for watching HDTV. It is a "Blaze" brand. I want to use this on linux (so I don't have to boot into windows whenever I want to watch TV). I've tried a couple of downloads (KDETV, DVB something or another, TVTime, and a few others I would know if I saw the name.)

Does anyone know of a good program to use a TV dongle? Most of the programs I tried just didn't support my TV stick.

thanks.
sheap

sasho 09-22-2008 09:40 PM

Is it a USB stick, really? A quick google search only reveals cards from the PCI variety...

In any case, you need a driver first, before any tv-playing program can use your hardware.

Open a console and type
PHP Code:

lspci 

or if USB:
PHP Code:

lsusb 

and post the result here

pinniped 09-22-2008 10:13 PM

Just adding to what sasho posted - it isn't the viewer which supports the hardware, it is the v4l driver collection. If you post the information that sasho asked for we should be able to check if your hardware is supported. Once you've identified a driver (to set up and control the hardware) then you can go looking for software to tune and display things.

Woodypecker 09-23-2008 01:32 AM

To add here ... HDTV is very demanding of hardware - due to the high graphics resolution, it needs a "thick iron" processor (best dualcore) to decode the stream without losses. I do use a linux vdr but with standard PAL resolution and a "full-feature" dvb pci card plus a budget (without its own decoder chip) and a dvb-t card as the 3rd one.
Unfortunately there are no linux-compatible "fullfeature" dvb-s2 (hdtv) cards available yet, so everything in that regard has to be done by the cpu.
If your dvb stick _really_ does support HDTV, I think you have to stick with windows first.
In particular thanks the "protected media path".

seheap 09-23-2008 09:16 AM

When I type

lsusb

into Konsole i get the message

bash: lsusb: command not found

Am I typing correctly? Do I have to qualify that command with something first?

I have a "thick iron" processor it's a x86_64 dual core. Everything is amazingly fast; windows was definitely not.

swalker23 09-23-2008 01:23 PM

If you get your drivers and card(usb your case)working I suggest to use the program TVtime it worked great for me. I've tried 9 different apps to get to work for me and the only that gave me perfect results with lil to no trouble was TV time. Only problems I'm having is my composite(cable wire) is black and white and no sound from my composite and svideo inputs through my card. I get around with this by using s video for video input(displays perfect) and a adapter to hook my audio to my on board mobo sound.

piotrk 09-23-2008 02:32 PM

Quote:

Originally Posted by seheap (Post 3289234)
When I type

lsusb

into Konsole i get the message

bash: lsusb: command not found

Am I typing correctly? Do I have to qualify that command with something f

try like this:
Quote:

$whereis lsusb
lsusb: /usr/sbin/lsusb
$/usr/sbin/lsusb

pinniped 09-23-2008 06:15 PM

Perhaps the usb utilities aren't installed, so no lsusb - or else it is only accessible to 'root' (which makes sense because it can't get a lot of the information you want unless it's root). What distribution are you using?

seheap 09-24-2008 03:40 PM

ok I got:

Bus 001 Device 001: ID 0000:0000
Bus 002 Device 002: ID 046d:c51b Logitech, Inc.
Bus 002 Device 001: ID 0000:0000

I'm not sure what distribution.....I know it's Mandriva Linux 2008.1 but that is probably not what you are asking.....

Woodypecker 09-25-2008 01:33 AM

Does not look like your device is recognized - Logitech may be your mouse or whatever,
from the descriptions I see online, the forementioned usb-tv stick should have a set of
chips like Tuner: Microtune MT2131; Demodulator: Auvitek AU8502; USB Interface: Auvitek AU0828. You may have attached it to a usb1.1 port otherwise at least a unknown id should show.

Btw., HDTV isn't yet available for terrestrical transmission, only sat or cable (dvb-s or dvb-c) AFAIK.

seheap 10-11-2008 12:10 PM

Hybrid TV-ATSC
 
Bus 001 Device 002: ID 05e1:0400 Syntek Semiconductor Co., Ltd
Bus 001 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000

the USB ID of 05e1:0400 is nowhere to be found on the Internet.

I *think* the chips are auvitek. Under windows, in the device manager, it shows two "auvitek" devices for decoding tv audio and tv video.

Is there any way to get kernel modules to work with an unknown USB.ID?


All times are GMT -5. The time now is 09:46 PM.