LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-15-2004, 01:17 PM   #1
dholingw
Member
 
Registered: Dec 2003
Distribution: Cent OS 4.1
Posts: 38

Rep: Reputation: 15
WARNING: Page has Expired-- More MS Nonsence


Hi all.

Iím currently in the process of moving a massive website over to another server I put together. For some odd reason, whenever you use the sites cgi based search engine, then hit the back button to see the results again, Internet Explorer now craps out with a:

Warning: Page has Expired The page you requested was created using information you submitted in a form. This page is no longer available. As a security precaution, Internet Explorer does not automatically resubmit your information for you.

To resubmit your information and view this Web page, click the Refresh button.

In fact, this is now the case with anything at all that uses cgi scripts. AGAINÖ My current server is running this identical site, and has never experienced a problem such as this. This problem is limited to the ďnewĒ server. Perhaps something I need to set in Apache?

Some fast answers to possible questions:

- Yes, the Ďgetí method is being used on all scripts
- Yes, this problem is limited to Internet Explorer, (Netscape works properly --as typical)
- No, I do not, nor have ever used any type of cookie sessions
- No, it doesnít seem to be happening with my vBulletin forum, or php on general
- No, itís not my browser settings Ėthis problem is limited to the new server
- So far, pretty much limited to anything with .pl or .cgi extensions

As with most Microbloft problems, this is extremely annoying, as it simply blindsides you- no warning, or explanation as to why itís happening. Any light you kind people could shine on this would be muchly appreciated. I donít even know where to begin looking in this case.

Hope to hear back,

Dave H
 
Old 01-15-2004, 01:39 PM   #2
dholingw
Member
 
Registered: Dec 2003
Distribution: Cent OS 4.1
Posts: 38

Original Poster
Rep: Reputation: 15
The problem is Mod_Gzip! Anyone?

Thatís interesting. I just disabled mod_gzip, and Internet Explorer is no longer sending me that page expired message. It must be something mod_gzip is doing to the page headers. Has anyone else here experienced this?

Thanks,

Dave H
 
Old 01-15-2004, 01:52 PM   #3
duerra
Member
 
Registered: Oct 2003
Location: Where No One's Been... Spiral Out!
Distribution: FreeBSD
Posts: 201

Rep: Reputation: 30
In your scripts that your'e using, send a header direction. In php, you'd do it as follows:

header("Cache-Control: ");
header("pragma: ");

It's not a "problem" with Internet Explorer. It's meant that way. As the developer/programmer, you can fix it by explicitly telling IE what you want it to do for caching.

Edit: Also realize that a user's personal cache settings can override these controls, but it will work for 98% of people out there.
 
Old 01-15-2004, 02:12 PM   #4
dholingw
Member
 
Registered: Dec 2003
Distribution: Cent OS 4.1
Posts: 38

Original Poster
Rep: Reputation: 15
Thanks Duerra. I guess Iím a little confused now. Since the problem has been isolated to mod_rewrite, Iím not sure if this itís another directive I must add to the mod_rewrite rule set, or the cgi script itself I should play around with, and becasue the correct headers are sent when mod_rewrite is turned off. Here are the directives for mod_rewrite from httpd.conf:

<IfModule mod_gzip.c>
mod_gzip_on yes
mod_gzip_dechunk yes
mod_gzip_keep_workfiles No
mod_gzip_temp_dir /home/modgziptmp
mod_gzip_minimum_file_size 500
mod_gzip_maximum_file_size 1000000
mod_gzip_maximum_inmem_size 1000000
mod_gzip_item_include file \.htm$
mod_gzip_item_include file \.html$
mod_gzip_item_include file \.php$
mod_gzip_item_include mime ^text/.*
mod_gzip_item_include mime ^application/x-httpd-php
mod_gzip_item_include mime ^httpd/unix-directory$
mod_gzip_item_exclude file "\.css$"
mod_gzip_item_exclude file "\.js$"
mod_gzip_item_exclude file "\.wml$"
mod_gzip_item_exclude reqheader "User-Agent: .*Mozilla/4\..*\["
mod_gzip_item_exclude mime ^image/.gif
</IfModule>

Donít know if this helps, but hopefully someone can eyeball the problem.

Thanks again,

Dave H
 
Old 01-15-2004, 02:27 PM   #5
dholingw
Member
 
Registered: Dec 2003
Distribution: Cent OS 4.1
Posts: 38

Original Poster
Rep: Reputation: 15
Problem Solved

Thanks all. I was missing some directives. All is fixed.

Dave H
 
Old 01-15-2004, 02:32 PM   #6
duerra
Member
 
Registered: Oct 2003
Location: Where No One's Been... Spiral Out!
Distribution: FreeBSD
Posts: 201

Rep: Reputation: 30
Care to share? I wasn't previously aware that Apache could send default cache headers...
 
Old 01-15-2004, 03:14 PM   #7
dholingw
Member
 
Registered: Dec 2003
Distribution: Cent OS 4.1
Posts: 38

Original Poster
Rep: Reputation: 15
Ha Ha!... Some administrator I am. I fixed it, but I donít really know what I fixed. Hereís what I did. I grabbed the mod_gzip directives from a prior httpd.conf file, and replaced the ones you saw (in my earlier message). Here they are:

<IfModule mod_gzip.c>

mod_gzip_on Yes
mod_gzip_can_negotiate Yes
mod_gzip_static_suffix .gz
AddEncoding gzip .gz
mod_gzip_update_static No
mod_gzip_command_version '/mod_gzip_status'
mod_gzip_temp_dir /home/modgziptmp
mod_gzip_keep_workfiles No
mod_gzip_minimum_file_size 500
mod_gzip_maximum_file_size 500000
mod_gzip_maximum_inmem_size 60000
mod_gzip_min_http 1000
mod_gzip_handle_methods GET POST
mod_gzip_item_exclude reqheader "User-agent: Mozilla/4.0[678]"
mod_gzip_item_include file .html$
mod_gzip_item_include file .shtml$
mod_gzip_item_include file .htm$
mod_gzip_item_include file .shtm$
mod_gzip_item_include file .php$
mod_gzip_item_include file .phtml$
mod_gzip_item_exclude file .js$
mod_gzip_item_exclude file .css$
mod_gzip_item_include file .pl$
mod_gzip_item_include handler ^cgi-script$
mod_gzip_item_include mime ^text/html$
mod_gzip_item_include mime ^text/plain$
mod_gzip_item_include mime ^httpd/unix-directory$
mod_gzip_item_exclude mime ^image/
mod_gzip_dechunk Yes
mod_gzip_add_header_count Yes
mod_gzip_send_vary Yes
</IfModule>

I suspect one or several of these Ďadditional directivesí has solved the problem with Internet Explorer not caching some of the pages properly, but Iím still trying to figure out what one is doing the trick. By all means, if someone here wants to point this out, Iím listening

Also, mod_gzip was fast before, but with these new additions, now it's just screaming!

Dave H
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Login expired tulipysc Linux - Software 9 04-25-2007 08:29 PM
Dell Inspiron 8100: No scancodes from Page Up Page Down keys twosider Linux - Laptop and Netbook 1 10-18-2005 10:41 AM
password expired rbchhan Fedora 2 08-09-2004 11:39 AM
I cant change the default test page in apache server to add my page.y nhemapriya Linux - Newbie 3 05-13-2004 01:35 PM
RH & HP4050N PCL - page, pause, page, pause, page andguent Linux - Hardware 0 11-10-2003 09:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration