LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   want to see fat32 (https://www.linuxquestions.org/questions/linux-newbie-8/want-to-see-fat32-93164/)

amuarica 09-15-2003 05:24 PM

want to see fat32
 
hi i'm really new to redhat .

before this i use windows ..

how can i see my fat32 partition ...

i find the hda1 , i think it my drive c . isn't it ?

when i click at it , there is an error .

"nautilus has no install viewer capable of displaying /dev/hda1"

can you help me?

beolach 09-15-2003 06:45 PM

The problem you are having is that you're trying to access the
raw device file, /dev/hda1, rather than the files on that partition.

This is one of the first differences between windows & linux that
people run across. Linux has special "device files" that represent
hardware on the system; the closest Windows parallel is probably
the device manager.

In order to access the files on your fat32 (aka vfat) partition, you
will need to "mount" the fat32 filesystem, if it isn't already. You
most likely won't actually have to do this, since most installations
automatically detect fat32 partitions & do this for you. You can
check to see if it is already mounted by opening a console prompt
and typing "mount -t vfat". This will list all of the vfat (aka fat32)
filesystems that are already mounted. If your old windows
partitions are already mounted (most likely) it will print a line
something like:
/dev/hda1 on /mnt/win/c type vfat (rw)

This shows where the device (possible /dev/hda1) is mounted, in
this example /mnt/win/c. What this means is that you can access
all the files on the /dev/hda1 partition in the /mnt/win/c directory.

If it's not mounted, you will want to edit the file "/etc/fstab". This
file contains info on filesystems & where to mount them. You will
want to add a line somthing like:
Code:

# Device        Mount point        Type        Options                Special
/dev/hda1        /mnt/win/c        vfat        defaults        0        0

Changing the bold text to what would be best for you. Make sure
the mount point (i.e. /mnt/win/c) exists. It should be an empty
directory.

Additional information:
man mount
man fstab
Filesystems HOWTO - very technical & in depth.

aaa 09-15-2003 06:45 PM

You don't look at /dev/hda1, you mount it to a folder and look at that, using the mount command:
mount -t vfat /dev/hda1 /mnt/hd
This mounts your win partition to the /mnt/hd folder. The folder has to exist before you mount.

amuarica 09-15-2003 09:04 PM

thanks you very much
it really help

i really appreciate it

amuarica 09-15-2003 09:20 PM

sorry .. it is ok when i do at my drive c

but when i try to do with my drive e thats mean hda3 .
it doesnt work

it says that " wrong fs type ,bad option, bad superblock on /dev/hda3, or too many mounted file system

what should i do ?

quatsch 09-15-2003 09:29 PM

is it an fat32 partition?

Open a terminal window, become root with the su command and do
fdisk -l /dev/hda
Could you post the output of this?

skora 09-15-2003 10:35 PM

I have the same problem and I got this..

linux:~ # fdisk -l /dev/hda

Disk /dev/hda: 240 heads, 63 sectors, 7941 cylinders
Units = cylinders of 15120 * 512 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 646 4883728+ 12 Compaq diagnostics
/dev/hda2 647 2069 10757880 f Win95 Ext'd (LBA)
/dev/hda3 * 2070 7941 44392320 7 HPFS/NTFS
/dev/hda5 647 780 1013008+ 82 Linux swap
/dev/hda6 781 2069 9744808+ 83 Linux


so what should I do?
thank you very much

quatsch 09-15-2003 10:39 PM

for an ntfs partiton, you mount it by

mount -t ntfs /dev/hda3 /mnt/win

You'll have to make appropriate changes depending on the partiton and the desired mount point. Also, ntfs needs to be supported by your kernel. I hear some distributions disable it by default...

skora 09-15-2003 11:17 PM

thank you very much!!!
this worked!
:)

amuarica 09-16-2003 12:04 AM

i'm really sorry ...
i was wrong i think e: is hda3
but it is hda5 .

sorry , because i'm really new with redhat .

thanks for helping me

amuarica 09-16-2003 02:59 AM

more problem ...

before this i have mount all the drive and it success ..

but after i restart ...
i cant open all the drive again ..

can u xplain ???????

aaa 09-16-2003 07:20 AM

You can't mount or you have to mount all over again? If you don't want to mount every drive every single time you restart, you can put entries for them in your /etc/fstab file so it will be done automatically on startup. Put a line the way beolach explained it.

amuarica 09-16-2003 01:59 PM

i have done bleolach step ..
but still i have to mount all over again except drive c:

this is what i have done

/dev/hda1 /mnt/hd vfat defaults 0 0
/dev/hda5 /mnt/hd2 vfat defaults 0 0
/dev/hda6 /mnt/hd3 vfat defaults 0 0
/dev/hda7 /mnt/lagu vfat defaults 0 0
/dev/hda8 /mnt/hd4 vfat defaults 0 0

is there any wrong ?

quatsch 09-16-2003 03:27 PM

All the mount points exist, right? That is, you did
mkdir /mnt/hd2; mkdir /mnt/hd3; etc.

Do they get mounted when you do
mount -a
(as root). If not, do you get any error messages?

amuarica 09-20-2003 03:45 AM

it works .

thanks


All times are GMT -5. The time now is 01:35 PM.