-   Linux - Newbie (
-   -   vsftpd - only one user can login to ftp (

greengrocer 12-04-2005 04:54 AM

vsftpd - only one user can login to ftp
Hi everyone,

I have really strange login issue with vsftpd. Only one of my four users can get ftp access, the rest of the users are denied, including root user, root user is denied access to ftp.

I have edited the vsftpd.conf so that there is no anonymous login allowed.

I also set it so that it would allow local users to get access to ftp.

Thats all I have changed.

vsftpd has created /home/ftp automatically.

I havent changed any user accounts and group relationships around in any way, and thats why I find it strange.

Why would it be that one of the users can login to ftp and not the others?

I'm curious about this!


eddiebaby1023 12-04-2005 09:06 AM

Weird. Have you uncommented the "local_enable=YES" line?

badgerbox76 12-04-2005 09:02 PM

Vsftpd is just a plain pain to work with i would start looking for another ftp server, but thats just me

amitsharma_26 12-05-2005 07:43 AM

edit /etc/vsftpd.ftpusers & /etc/vsftpd.user_list & uncomment root to grant root to access ftp.


greengrocer 12-08-2005 05:41 AM

Thanks for all the suggestions, I worked out what was wrong, there were several problems, one of them quite embarrassing ** other newbies take note **

1) I was using the wrong password for one of the users.

2) I created a user specifically to give out to people I knew for th e purposes of granting access to my ftp server. This user belonged to the same group as the ftp daemon, and that group was blocked from access. I created a new group for this user and it worked.

I was also careful to set things up so that the special user name for ftp access did not belong to any other group (hopefully this will mean that no damage can be done by this user) if anyone has comments about the security aspect of this (ie I am I assuming correctly), your comments are welcomed.

I also discovered that pam is involved somehow in the access permissions invloved (does this sound right)? I have a file called ftpusers in /etc which has a list of disallowed users and groups. This file is referred to in /etc/pam.d/vsftpd


All times are GMT -5. The time now is 11:36 PM.