LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-25-2009, 11:16 AM   #1
MadAtUbuntu
LQ Newbie
 
Registered: Dec 2009
Location: Northern California USA
Distribution: Ubuntu Server 8.04.3 Hardy
Posts: 14

Rep: Reputation: 0
VSFTPD Error 550 I can upload, but Cannot download, any ideas?


Ok so this is my config, is something wrong with it?

I have created the anonymous folder and gave it the proper permissions, yet I can only upload and create files, if I try to download I get Error Code 550 cannot change directory. I would also like to point out the local accounts are fully functional, and my problem is with anonymous downloaders only.

ftp://spoofzor.serveirc.com/anonymous/

Last edited by MadAtUbuntu; 12-25-2009 at 06:27 PM.
 
Old 12-25-2009, 11:49 AM   #2
MadAtUbuntu
LQ Newbie
 
Registered: Dec 2009
Location: Northern California USA
Distribution: Ubuntu Server 8.04.3 Hardy
Posts: 14

Original Poster
Rep: Reputation: 0
Ok FAIL, I can now down files of zero file size. Which the files are NOT zero file size, thisi is driving me nuts!

Where is the fail in this conf???

I want local users confined to theri own private directories and have anonymous ftp enabled as well, but so far this is turning into a fiesta of failure.


# Standalone mode
listen=YES
max_clients=200
max_per_ip=4
# Access rights
chroot_local_user=YES
anonymous_enable=YES
local_enable=YES
write_enable=YES
anon_upload_enable=YES
anon_mkdir_write_enable=YES
anon_other_write_enable=NO
# Security
anon_world_readable_only=YES
connect_from_port_20=YES
hide_ids=YES
pasv_min_port=50000
pasv_max_port=60000
# Features
xferlog_enable=YES
ls_recurse_enable=NO
ascii_download_enable=YES
async_abor_enable=YES
# Performance
one_process_model=YES
idle_session_timeout=120
data_connection_timeout=300
accept_timeout=60
connect_timeout=60
anon_max_rate=500000


Oh it gets even better, after I rebooted with this conf, the FTP server is now completely dead.

Last edited by MadAtUbuntu; 12-25-2009 at 07:13 PM.
 
Old 12-25-2009, 12:19 PM   #3
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Are you running a firewall? Is the PASV mode port range (ports 50000-60000) allowed through it? I've found that a lot of problems like the ones you described are caused by problems with passive mode.
 
Old 12-25-2009, 05:37 PM   #4
MadAtUbuntu
LQ Newbie
 
Registered: Dec 2009
Location: Northern California USA
Distribution: Ubuntu Server 8.04.3 Hardy
Posts: 14

Original Poster
Rep: Reputation: 0
so this conf has ports set to 5000-6000???

Yeah Im natted behind a Mikrotik firewall but port 21 is allowed. And fully natted.
Plus the testing im doing is being done at a local level so the firewall is not an issue.

Should I disabled this passiv mode and how so?

FAILURE #1 PORTS 5000-6000

Waiting to retry...
Status: Connecting to 10.10.10.2:6000...
Status: Connection attempt failed with "ECONNREFUSED - Connection refused by server".
Error: Could not connect to server

-------------------------------------------------------------------------------------
FAILURE #2 PORT 21

Status: Connecting to 10.10.10.2:21...
Status: Connection established, waiting for welcome message...
Response: 500 OOPS: vsftpd: security: 'one_process_model' is anonymous only
Error: Critical error
Error: Could not connect to server


Ok the above errors I fixed by Setting

one_process_model=NO

And I complety removed these two lines as I have no intention on using those absurd ports

pasv_min_port=50000
pasv_max_port=60000

Now heres the problem, I can connect, and I can see the files, but I cannt download
Command: PASS **************
Response: 230 Login successful.
Command: OPTS UTF8 ON
Response: 200 Always in UTF8 mode.
Status: Connected
Status: Starting download of /anonymous/Perl/Exploit.Perl.BadBlue.zip
Command: CWD /anonymous/Perl
Response: 250 Directory successfully changed.
Command: TYPE I
Response: 200 Switching to Binary mode.
Command: PASV
Response: 227 Entering Passive Mode (10,10,10,2,91,34)
Command: RETR Exploit.Perl.BadBlue.zip
Response: 550 Failed to open file.
Error: Critical error

Someone plz help or ill be at this for days on end furthering my downward spiral into anti-socialism

Last edited by MadAtUbuntu; 12-25-2009 at 06:02 PM. Reason: some bugs fixed with edits
 
Old 12-25-2009, 10:38 PM   #5
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
It's 50000-60000, not 5000-6000. It's likely that you have to use passive FTP or else nothing will work, at least not unless the client has no firewall or NAT router in between it and the server. You need to understand how FTP actually works, there are two ports used, one for control/commands and the other for data. I wrote up an explanation awhile back in this thread (post #5 IIRC). Basically if your server is behind a NAT firewall, you need to make sure that the passive mode ports are also forwarded through the router to the server. You might want to use a smaller range than 10K ports. Unless you have many, many clients, a few hundred should be sufficient.
 
Old 12-16-2014, 05:09 PM   #6
achoo
LQ Newbie
 
Registered: Dec 2014
Posts: 2

Rep: Reputation: Disabled
Question what should I do differently?

I have a similar problem.
  1. I ran hostname -I and tried each of the IP addresses as pasv_address one at a time
  2. pasv_min_port=59000
  3. pasv_max_port=60000
  4. I ran firewall-config and under the public zone ...
    1. Ports: I added 59000-60000 tcp
    2. Services: I checked the box for ftp
  5. I'm on 3.17.6-200.fc20.x86_64 GNU/Linux

This is the result I get:

Code:
Name (my.i.p.addr:me): anonymous
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> dir
227 Entering Passive Mode (0,0,0,0,233,159).
150 Here comes the directory listing.
-rwxr-xr-x    1 1000     1000           29 Dec 16 21:26 tmp
226 Directory send OK.
ftp> get tmp
local: tmp remote: tmp
227 Entering Passive Mode (0,0,0,0,232,91).
550 Failed to open file.
Any help much appreciated!

Last edited by achoo; 12-16-2014 at 05:47 PM.
 
Old 12-16-2014, 06:54 PM   #7
achoo
LQ Newbie
 
Registered: Dec 2014
Posts: 2

Rep: Reputation: Disabled
Ah. This resolved my issue:
Quote:
setsebool -P allow_ftpd_full_access 1
from
http://www.linuxquestions.org/questi...or-4175469673/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd: can view files but can't download them (550) pochesal Linux - Networking 1 11-01-2005 12:30 PM
FTP upload problem: Error 550 Access Denied andrewstr Linux - Networking 0 12-17-2003 02:19 PM
Vsftpd help- 550 error hda Linux - Networking 1 10-15-2003 02:26 PM
VSFTPD - can download but cant upload. Dirt Linux - Software 1 09-06-2003 09:42 PM
vsftpd 550 upload error rusium Linux - Networking 1 05-20-2003 02:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration