LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-29-2006, 03:10 PM   #1
hunterhunter
Member
 
Registered: Nov 2005
Posts: 90

Rep: Reputation: 15
vsftpd, starting via xinetd, will not accept user names and passwords -see for detail


-------------Hers's my config.
listen_address=192.168.1.123
anonymous_enable=NO
local_enable=YES
write_enable=YES
pasv_enable=YES
local_umask=077
max_clients=20
check_shell=NO
anon_upload_enable=NO
use_localtime=YES
listen_port=21
anon_mkdir_write_enable=NO
pasv_min_port=65500
pasv_max_port=65525
dirmessage_enable=NO
xferlog_enable=YES
chroot_local_user=YES
passwd_chroot_enable=YES
#connect_from_port_20=YES
#chown_uploads=YES
#chown_username=whoever
xferlog_file=/var/log/vsftpd.log
xferlog_std_format=YES
idle_session_timeout=600
data_connection_timeout=120
nopriv_user=nobody
#async_abor_enable=YES
#ascii_upload_enable=YES
#ascii_download_enable=YES
ftpd_banner=Attention user. If you're not a valid user then please log off immediately.
#deny_email_enable=YES
#banned_email_file=/etc/vsftpd.banned_emails
#chroot_list_enable=NO
#chroot_list_file=/etc/vsftpd.chroot_list
ls_recurse_enable=YES
ssl_enable=YES
ssl_sslv2=YES
ssl_sslv3=YES
ssl_tlsv1=YES
force_local_data_ssl=YES
force_local_logins_ssl=YES
rsa_cert_file=/usr/share/ssl/certs/vsftpd.pem
listen=NO
-------------Here's are the xinetd.d contents.
/etc/xinetd.d/
-rw-r--r-- 1 root root 630 Mar 29 14:31 vsftpd_secure
-------------Here are the contents of that file.
# default: on
# description:
# The vsftpd FTP server serves FTP connections. It uses
# normal, unencrypted usernames and passwords for authentication.
# vsftpd is designed to be secure.
service ftp
{
socket_type = stream
wait = no
user = root
server = /usr/local/sbin/vsftpd
# server_args = /etc/vsftpd_secure.conf
# log_on_success += DURATION USERID
# log_on_failure += USERID
nice = 10
disable = no
bind = 192.168.1.123
}
-------------Here is what I get when trying to connect.

Status: Connecting to 192.168.1.123 ...
Status: Connected with 192.168.1.123, negotiating SSL connection...
Response: 220 (vsFTPd 2.0.4)
Command: AUTH SSL
Response: 530 Please login with USER and PASS.
Error: Unable to connect!
Status: Waiting to retry... (5 retries left)
Error: Unable to connect!
Error: Interrupted by user!

I'm using a user name and password of an account on the system.
Their shell is /bin/false and it's in /etc/shells also.
The RSA certificate is in place too.
I'm stumped, completely stumped...

Thanks for the help
 
Old 03-30-2006, 10:16 AM   #2
hunterhunter
Member
 
Registered: Nov 2005
Posts: 90

Original Poster
Rep: Reputation: 15
vsftpd&SSL working except it wont accept passwords.

It won't accept passwords regardless of what I do.

I try over, ssl, tsl, ssh.

I keep getting this error and am clueless as to why...


Status: Connecting to 192.168.1.123 ...
Status: Connected with 192.168.1.123, negotiating SSL connection...
Response: 220 Welcome to blah FTP service.
Command: AUTH SSL
Response: 234 Proceed with negotiation.
Status: SSL connection established. Waiting for welcome message...
Command: USER rob
Response: 331 Please specify the password.
Command: PASS ********
Response: 530 Login incorrect.
Error: Unable to connect!


I think it's something in the vsftpd config, but I can't figure out what it is.

Thanks
 
Old 03-30-2006, 12:24 PM   #3
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
I've merged your two threads ...
 
Old 03-30-2006, 12:35 PM   #4
hunterhunter
Member
 
Registered: Nov 2005
Posts: 90

Original Poster
Rep: Reputation: 15
What a tease
I thought someone actually replied!

Thanks though
 
Old 03-30-2006, 12:42 PM   #5
demented_are_go
Member
 
Registered: Mar 2006
Distribution: Fedora Solaris Slackware
Posts: 50

Rep: Reputation: 15
This : http://www.brennan.id.au/14-FTP_Server.html might help, it's an actual howto, there's quite a bit about vsftpd and ssl in there.
 
Old 03-30-2006, 12:53 PM   #6
hunterhunter
Member
 
Registered: Nov 2005
Posts: 90

Original Poster
Rep: Reputation: 15
Thank you ma'am.


I appreciate the assistance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsFTPd - SSL connection and dynamic SSL ports toxoplasme Linux - Server 11 08-22-2008 10:50 PM
vsftpd & ssl - how do I tell if it's actually vsftpd maintaining the connections?? hunterhunter Linux - General 0 03-27-2006 04:41 PM
vsftpd & ssl ports jonfa Linux - Networking 1 12-21-2005 06:33 PM
Setting up SSH to accept authenticate hosts without passwords jphaynes Slackware 4 05-05-2002 11:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration