-   Linux - Newbie (
-   -   vsftpd and log files - can i up the log level to see login attempts? (

robr 04-04-2008 10:46 AM

vsftpd and log files - can i up the log level to see login attempts?
I'm trying to troubleshoot a problem with provisioning of Polycom phones. They're set up to be provisioned by FTP, the username/pw I provided to the phone works when I log in from a client on my PC, but the phones aren't provisioning. I checked the /var/log/vsftpd.log file, but it doesn't show login attempts, it only shows file transfers. How can I up the loglevel so I can see login attempts and any other commands issued to the server?


helptonewbie 04-04-2008 12:16 PM

this is some stuff i mucked about with a little when i had a little testing environment.. if i remember you'll need to add/make these changes into you vsftpd.conf file...

syslog_enable=NO #makes use of syslog deamon for logging set to NO - writes directly to log file instead
log_ftp_protocol=NO #Logs everything passing between client and ftp service, basically like being verbose not really required to much information given
xferlog_enable=YES #Logs the uploads and downloads and the username of which has done this.
vsftpd_log_file=/var/log/vsftpd.log #Specifies where i want the log file to be written
xferlog_std_format=YES/NO #currently have this set yo yes need to play with it a bit more to find if its actually any use or not.
xferlog_file=/var/log/xfer.log #Don't know if this is really required, again need to play, doesn't seem to log anything overly helpful
dual_log_enable=YES #enables logging in both vsftpd or xfer logging styles, vsftpd looks better so far

So there's a couple of things worth looking at you may find useful, this is just from notes i had when i played arround with it a little so can't say much else..


robr 04-04-2008 12:23 PM

I added the log_ftp_protocol line, but it doesn't appear to be a valid value. Let me google that entry and see if I can get some further info. It looks like that may be the key to what I need. Thanks.

root@pbx:/polycom $ service vsftpd restart
Shutting down vsftpd: [ OK ]
Starting vsftpd for vsftpd: 500 OOPS: bad bool value in config file for: log_ftp_protocol

nevermind, i must have cut/paste something strange that didn't show up in VI from your post. I deleted the line and manually retyped it and it started up fine. Let me go see if I now have more verbose logs.

Nope. No go, I still only see file transfers appearing in the log :(. Tried the syslog_enable=NO as well. Still no love.

robr 04-04-2008 12:38 PM

Got it!!! These two are mutually exclusive:


You have to set
xferlog_std_format=NO for the log_ftp_protocol to work.

Thanks for the clue that led me to the solution!

All times are GMT -5. The time now is 02:57 PM.