LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Voodoo 2 Glide 3Dfx test trashed my disk?? (https://www.linuxquestions.org/questions/linux-newbie-8/voodoo-2-glide-3dfx-test-trashed-my-disk-163471/)

MKS45 03-28-2004 04:08 PM

Voodoo 2 Glide 3Dfx test trashed my disk??
 
This is an old PC (as the spec alongside indicates), with Voodoo 2 card in addition to the standard SiS 5597/5598 graphics card.
I've been looking at ways to try to get SuSe 9.0 Pro to not only see but use the Voodoo 2.
Found what appeared to be an appropriate package to download at the Italian 3dfxzone URL, including what the Mesa docs say is the appropriate Glide library.

Duly installed the stuff & went to try the 3Dfx test executable which it had installed. Got a brief view of the 3Dfx logo, then a blue screen prompting me to press any key. Did so, no response. repeat - same result. Ditto Ctrl-Alt-Backspace.

Eventually, multiple Ctrl-Alt-Deletes appeared to have forced a reboot. System however displayed some scary messages suggesting one or more filesystems were completely f***ed. Was led to a text login prompt, which, however, just repeated itself when I typed in "root".

So booted in failsafe mode. This time, things appeared to be going OK as all the filesystems were fsck'ed with no problems. Shortly afterwards (around the point where DMA is being turned on for all disks, I think) however, there came a message something like
hda: set_drive_speed_status: status=0x58 { DriveReady SeekComplete
DataRequest }
and subsequently, a steady slow stream of
hda: lost interrupt
messages, and the boot proceeds no further.

1) What did I do wrong?
2) (more importantly) Can I retrieve my disk and distro without reinstalling from scratch?

I do have the SuSe 9.0 Pro CDs btw, so can boot from #1 CD if necessary.

MKS45 03-29-2004 03:46 PM

mmmmm....deafening silence.....

Fortunately, I seem to have sorted it...or got lucky at any rate.

Booted from CD and mounted the /boot partition. Edited /grub/menu.lst so that the original boot parameters were restored (had removed "desktop" and "ide=nodma" previously to see if I could improve performance under Gnome & in particular, KDE).

Amazingly, this seems to have worked. Don't know why; would be pleasantly surprised if someone could tell me.


All times are GMT -5. The time now is 03:05 PM.