Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 08-25-2011, 09:10 AM   #1
LQ Newbie
Registered: Feb 2011
Posts: 23

Rep: Reputation: 2
Question vnc viewer showing only grey screen with 3 checkboxes

Hello everybody,

I am trying to access my 2 redhat5 linux machines "prod" & "ora10g" through vnc viewer installed on my windows xp sp3 machine,
I am able to connect & work on my "prod" machine with vnc viewer , when I connected to "ora10g" first time it was successful connection then I closed the session,
but when I reconnected from my Windows box to "ora10g" linux machine I just get a grey screen with three checkboxes in the top left corner:
__Accept clipboard from viewers
__Send clipboard to viewers
__Send primary selection to viewers

The log file of vnc server is showing:
vncext: VNC extension running!
vncext: Listening for VNC connections on port 5902
vncext: Listening for HTTP connections on port 5802
vncext: created VNC server for screen 0

vncviewer is running on port 1 on both the machine

Eagerly waiting for the reply form experts..!
Old 08-25-2011, 09:44 AM   #2
Registered: Oct 2009
Location: NJ
Distribution: fedora 20 and rawhide
Posts: 47

Rep: Reputation: 8
Not an expert but you should try looking at ~/.vnc/xstartup, you need to specify a window manager, also do chmod +x ~/.vnc/xstartup.
Googled this site, it helped me alot
1 members found this post helpful.
Old 08-25-2011, 10:52 AM   #3
LQ Newbie
Registered: Feb 2011
Posts: 23

Original Poster
Rep: Reputation: 2
Thank you jayfree for your instant reply

I checked all the setting as mentioned in the site suggested by you, & got error fixed additionally
I entered following settings in the /etc/sysconfig/vncservers file.
VNCSERVERARGS[1]="-geometry 800x600"

Thanks a bundle.....!
Old 08-25-2011, 10:54 AM   #4
LQ Newbie
Registered: Jul 2011
Posts: 6

Rep: Reputation: Disabled
TWM isn't the graphical environment that you were expecting?! There's actually an easy fix to this problem. For the user that is running the vncserver, go into that user's .vnc directory (~/.vnc). Open the file xstartup and uncomment the following two lines:
exec /etc/X11/xinit/xinitrc

After you restart your vncserver, you should get the graphical environment that you expect.


Last edited by colucix; 08-25-2011 at 10:58 AM. Reason: Advertising to commercial site removed.
1 members found this post helpful.
Old 08-25-2011, 11:02 AM   #5
LQ Newbie
Registered: Feb 2011
Posts: 23

Original Poster
Rep: Reputation: 2

Thanks mike for additional information on this topic, now I am able to connect to my ora10g machine without error..

Thank you very much..!
Old 11-22-2012, 03:31 AM   #6
ranjeet bitke
LQ Newbie
Registered: Nov 2012
Location: Online
Posts: 1

Rep: Reputation: Disabled
Smile look first for the log file

I faced a similar problem, but the issue was wit the Permission for the file /.vnc/xstartup

#chmod 755 .vnc/xstartup
#vncserver -kill :1
#vncserver &

this solved the problem!
Another way to check there is no permission problem is just to see the colour of
the xstartup file in the .vnc folder. It should be cyan. Else you need to change
the permission as above.
Old 04-20-2014, 03:05 AM   #7
LQ Newbie
Registered: Apr 2014
Posts: 2

Rep: Reputation: Disabled
Hi I too am stuck on this. I am following the guide at: - on the page about how to Configure-the-server/Install-VNC.html

I just get the Grey screen as the OP says he did (Back in 2011 I know) - I followed the instructions to the letter from what I can tell using 14.04LTS server and just get Grey with 3 check boxes. I did try to post on the havetheknow forum but I dont think there is much action on there any more.

my xstartup file within the vnc directory looks like this:


# Uncomment the following two lines for normal desktop:
#exec /etc/X11/xinit/xinitrc
gnome-session --session=gnome-classic &

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
#x-terminal-emulator -geometry 1280x1024+10+10 -ls -title "$VNCDESKTOP Desktop" &
#x-window-manager &
Any ideas or help is much appreciated.

PS I am a Linux noobie, this is my first ever proper attempt at getting a server working using it. I got putty working and am now running commands on the server. I have installed VNC but can't get it to look correct on my Windows 8 Machine.[COLOR="Silver"]

---------- Post added 04-20-14 at 03:06 AM ----------

Last edited by iain1234; 04-20-2014 at 03:08 AM.
Old 04-21-2014, 12:44 PM   #8
LQ Newbie
Registered: Apr 2014
Posts: 2

Rep: Reputation: Disabled
anyone know?
Old 02-28-2017, 05:09 AM   #9
LQ Newbie
Registered: Feb 2017
Posts: 1

Rep: Reputation: Disabled
Question VNC grey area

I copied below content of /home/oracle/.vnc/xstartup from another Linux machine where vnc was running properly .That fixed the issue.

[ -r /etc/sysconfig/i18n ] && . /etc/sysconfig/i18n
export LANG
export SYSFONT
vncconfig -iconic &
OS=`uname -s`
if [ $OS = 'Linux' ]; then
if [ -e /etc/SuSE-release ]; then
export PATH
if [ -x /etc/X11/xinit/xinitrc ]; then
exec /etc/X11/xinit/xinitrc
if [ -f /etc/X11/xinit/xinitrc ]; then
exec sh /etc/X11/xinit/xinitrc
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
twm &


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
VNC Grey screen lrolstad Linux - Software 8 01-14-2011 01:56 PM
VNC - blank grey screen jnojr Linux - Newbie 15 06-20-2010 09:04 PM
VNC grey screen isaidimsorry Linux - Software 2 03-18-2010 08:44 PM
VNC - the screen is a grey checked color rwtreke Linux - Newbie 1 02-01-2005 04:16 PM
Grey screen when trying to VNC to Gnome In2Deep General 7 02-05-2004 05:01 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:11 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration