LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   VNC Client/Server install question for Fedora Core 4 (https://www.linuxquestions.org/questions/linux-newbie-8/vnc-client-server-install-question-for-fedora-core-4-a-390018/)

rafiqul 12-06-2005 10:18 PM

VNC Client at XP / Server at Fedora Core 4 install question
 
Hi,

I have VNC Server installed at my FC4 machine. When I do "yum list installed vnc" it shows both vnc.i386, and vnc-server.i386 installed. Also when I type at the command prompt "vn+tab" it shows I have following file:
vncconfig
vncconfig.py
vncpasswd
vncserver
vncviewer

I also installed vnc client at my laptop (running on Windows XP professional), when I run the client it asks me to type VNC server information using "host:display" format - I dont know whats that mean. but I tried to use the IP address of my machine where FC 4 running (VNC server), but its says login failed.

I am able to ping to my FC4 machine from my laptop, also I am able to telnet, ftp etc...
Also, I ran vncserver - its created couple of files such as :
Created default startup script in /root/.vnc/xstartup
starting application specifid in /root/.vnc/xstartup
logfile /root/.vnc/local.localdomain:1.log

Can anyone help me how to get around this problem ? Do I have to setup anything on the server, or client side ? Please note VNC server is on my FC4 machine, and VNC client is on my laptop (XP).

Thanks for your help.

rafiqul 12-06-2005 11:06 PM

I just tried re-running my vncserver as follows:

vncserver:2 (i.e. Display 2)

And in the client I typed my server IP:2, it connected to my FC4 server just fine. I only see a blank desktop and the terminal that is opened at my desktop.

Can you guys help me how to get to view the full desktop ?

Thanks

tsphan 12-06-2005 11:56 PM

what you want is to load up the main desktop of your current X session, known as IP:0.

This can be done by running x0vncserver each time X loads.

Or add it into your x11 configuration file, my preference.

add a vnc module load in your X config:
Code:

Section "Module"
        Load  "vnc"
EndSection

then, in the screen section, add:

Code:

Section "Screen"
        Option "passwordFile" "/link/to/password/file/passwd"

You can make a passwd file by running vncpasswd, whoever you runned the file as, it'll be saved into their home directory under .vnc/passwd


This will allow the X session to load up each time with a vnc server built-in. Or, just stick with the x0vncserver

rafiqul 12-11-2005 09:42 PM

Created a passwd file by running vncpasswd, and add code about "module" and "Sreen" section above, (passwd file path I added "/root/.vnc/passwd") in the /etc/X11/xorg.conf

And finally ran the vncserver again...tried to connect from my laptop, and seeing the same thing..a blank desktop.

Did I have to run any services ? Or x0vncserver ? If so, can you please be a little detail about it ? Is anything that I doing anything wrong ?

Awaits your response...

tsphan 12-11-2005 11:09 PM

when you tried connecting, did you type in IPAddress:0 , with the :0?
you shouldn't have the run vncserver, it'll be automatically loaded with the X server

rafiqul 12-12-2005 02:50 PM

No. I tried running server first, by typing vncserver, and then I see a text message like vncserver:2, or sometimes vncserver:3. Depending on what I see, I type at the vncviewer "IP:2", or "IP:3", and then I connect.

poochdog 12-12-2005 04:30 PM

Hi I beleive this guide will help you, it contains information on editing the file which will show the full desktop. I beleive this information can be found on page two towards the bottom of the page. The link is http://www.notgotaclue.co.uk/art-winandlin.htm

tsphan 12-13-2005 01:19 AM

vncserver runs another X session on :1 :2 and :3, depending on how you run it.

While editing the X11 configuration will allow you to connect to the current X session, aka, :0
try to connect to :0

rafiqul 12-23-2005 01:01 PM

Excellent !!! Its just working great. The link above was realy helpful - thank you guys for your help.

001010 12-24-2005 10:58 PM

I am sort of in the same situation... However I am able to get connected through VNC, however on FC4 I get this message asking me to Accept or Decline the incoming connection. I have not been able to find a way to auto-accept the connection since it prompts me for my passwd anyways. Any hints?

rmfought 01-15-2006 12:33 PM

tsphan -

Will this support only one user at a time? Can you use the Option "passwordFile" more than once?

tsphan 01-15-2006 07:34 PM

i've never checked to see if someone could vnc twice to a computer before... i would think that if it works on other scenarios, it'll probably work on this one.

as for the passwordFile thing, i don't think it's possible and i also don't see what the point of it would be

poochdog 01-16-2006 01:44 PM

Hi there,

You can have multiple instances of VNC sessions, if you want to do this however, then I would recommend FREENX this link here has a couple of tutorials, one for freenx and one for VNC.

It will help you get started with this.

rmfought 01-17-2006 08:37 AM

That's all I'm looking for, multiple users accessing the box via VNC simultaneously.


All times are GMT -5. The time now is 08:42 PM.