LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-16-2016, 06:41 AM   #1
Chronic13
LQ Newbie
 
Registered: Nov 2016
Location: Tokyo
Distribution: Fedora
Posts: 18

Rep: Reputation: Disabled
Question Virtual Box Re-installation - latest build not booting


Hi Everyone,

Distro: Fedora 24

I installed VirtualBox via the rpm package, but for some reason I couldn't locate the launcher - I could only find the rpm packages on my drive.

I decided to install VirtualBox Guest Additions by using the following command
Code:
dnf install --allowerasing VirtualBox-Guest...
I think what I just learned is it's not always the safest route to use the "--allowerasing" option.

After installing the Guest Additions versions I rebooted the system and the latest build wouldn't boot.

My previous builds boot just fine.

Can anyone help me learn as to why this happened, and how I can go about repairing my corrupted build?

As always, a great many thanks to helpful community.
 
Old 12-16-2016, 06:50 AM   #2
grail
LQ Guru
 
Registered: Sep 2009
Location: Perth
Distribution: Manjaro
Posts: 10,011

Rep: Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194
Have you simply tried re-installing virtualbox? Or maybe uninstalling all of it and then re-installing?
 
1 members found this post helpful.
Old 12-16-2016, 07:18 AM   #3
Chronic13
LQ Newbie
 
Registered: Nov 2016
Location: Tokyo
Distribution: Fedora
Posts: 18

Original Poster
Rep: Reputation: Disabled
Question

I just tried uninstalling all of it. Even went as far as
Code:
rm -r path/VirtualBox
I rebooted into the latest build and I get the error message "FAILED to load Kernel Modules"

I'm currently running the previous build...
 
Old 12-16-2016, 07:35 AM   #4
grail
LQ Guru
 
Registered: Sep 2009
Location: Perth
Distribution: Manjaro
Posts: 10,011

Rep: Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194
Sorry, just want to make sure we are on the same page here. Your saying you totally removed and then re-installed and now you cannot boot the latest virtual machine?
 
Old 12-16-2016, 07:56 AM   #5
Chronic13
LQ Newbie
 
Registered: Nov 2016
Location: Tokyo
Distribution: Fedora
Posts: 18

Original Poster
Rep: Reputation: Disabled
Question

Thanks for your question - let me clarify.

I completely removed all trace of VirtualBox from my machine and I have yet to reinstall.

Before I removed VirtualBox, I was running the most recent Fedora 24 kernel version 4.8.13. After removing VirtualBox, I am getting an error when I try and load this Kernel.

I can now only load previous Kernel versions such as the one I'm using now, namely 4.8.10-200 and below.

Before I re-install VirtualBox, I was wondering if there was a way to debug what went wrong in the most recent Kernel version as a result of me removing VirtualBox.
 
Old 12-16-2016, 09:29 AM   #6
grail
LQ Guru
 
Registered: Sep 2009
Location: Perth
Distribution: Manjaro
Posts: 10,011

Rep: Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194Reputation: 3194
ahhhh ... now I am with you So my suggestion there would be to re-install your kernel version that is not working. It may then pay, once up and running, to watch and see when installing virtualbox if there
are any specific kernel related options you are asked for during the install and check which ones will work for you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Box slack build doesn't install web services completely wrinkledcheese Slackware 4 10-21-2016 05:16 PM
How can I use kickstart to build multiple virtual machines on Oracle virtual box? VitalTrainings Linux - Newbie 1 08-29-2014 09:04 AM
[SOLVED] OS installation through virtual box unclesamcrazy Linux - Newbie 8 05-27-2013 02:54 AM
[SOLVED] Ubuntu 12.04 not booting in oracle virtual box 4.0.4 KaRt Linux - Newbie 1 08-13-2012 04:39 AM
Latest kernel version fails to boot on virtual box abi200433 Linux - Virtualization and Cloud 4 09-24-2010 06:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration