LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   VIdeo card problem fedora 6 (https://www.linuxquestions.org/questions/linux-newbie-8/video-card-problem-fedora-6-a-601363/)

olracdor 11-21-2007 02:59 AM

VIdeo card problem fedora 6
 
im really having trouble installing the driver for my ATI HD 2600 series on fedora 6. i tried downloading the driver from www.amd.com but when i run the program the CCC appears in my applications menu but whan i click on it it does nothing. it seems that its not installed properly or notcompatible on my video card. how can i get a good driver for my video card to run BERYL

Fantasio 11-21-2007 03:32 AM

Hi,
It's quite easy as I remember.

Open a "Terminal Window", copy the script "ati-driver-installer-8.42.3-x86.x86_64.run" you downloaded to /tmp

You need to be root to install that driver, so type on your prompt "su - " followed by the root password.

backup your actual /etc/X11/xorg.conf or /etc/X11/XF86Config to a safe place

finally type "sh ati-driver-installer-8.42.3-x86.x86_64.run" and follow directives.

olracdor 11-21-2007 03:54 AM

ei
 
i did that but the result is
"sh: ati-driver-installer-8.42.3-x86.x86_64.run: No such file or directory"
and i looked at the fglrx.log and this is the content "[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Error] Kernel Module : No kernel module build environment - please consult readme." what should i do?

Fantasio 11-21-2007 04:30 AM

where do you download the driver script ?
Under your browser make a "Save As", in that case, you 'll know where it will be saved

After that, go to the location where you saved that file

and run the command "sh ati-driver-installer-8.42.3-x86.x86_64.run"

Once again: YOU NEED TO BE ROOT FOR INSTALLATION

olracdor 11-21-2007 05:17 AM

im login as the root, the "ati-driver-installer-8.42.3-x86.x86_64.run" ran, according to the instructions i should run " /usr/X11R6/bin/aticonfig --initial " in the terminal but the aticonfig is not present in that directory, i cant find it anywhere

Fantasio 11-21-2007 05:33 AM

many solutions are available:
find / -name aticonfig -print
updatedb ; locate aticonfig

for l in /usr/bin /bin /usr/X11R6/bin /sbin /usr/sbin ; do
ls $l/ati* ;
done

olracdor 11-21-2007 05:43 AM

no results found.. what the hel is wrong

olracdor 11-21-2007 05:51 AM

ei.. its runing now but the beryl is not working damn

Fantasio 11-21-2007 05:53 AM

Well, extract files from ati-driver script ...

Command below gives you several things you can do
sh ati-driver-installer-8.42.3-x86.x86_64.run --help


so,
mkidr /tmp/ati ; sh ati-driver-installer-8.42.3-x86.x86_64.run --extract /tmp/ati

find ati -iname \*config\* -print
ati/arch/x86/usr/X11R6/bin/aticonfig
ati/arch/x86_64/usr/X11R6/bin/aticonfig
ati/common/usr/share/doc/fglrx/configure.html
ati/common/usr/share/doc/fglrx/examples/etc/acpi/events/a-ac-aticonfig
ati/common/usr/share/doc/fglrx/examples/etc/acpi/events/a-lid-aticonfig
ati/component_config.sh
ati/config_install.sh
ati/packages/Debian/dists/etch/fglrx-ac-aticonfig
ati/packages/Debian/dists/etch/fglrx-lid-aticonfig
ati/packages/Debian/dists/experimental/fglrx-ac-aticonfig
ati/packages/Debian/dists/experimental/fglrx-lid-aticonfig
ati/packages/Debian/dists/lenny/fglrx-ac-aticonfig
ati/packages/Debian/dists/lenny/fglrx-lid-aticonfig
ati/packages/Debian/dists/sarge/fglrx-ac-aticonfig
ati/packages/Debian/dists/sarge/fglrx-lid-aticonfig
ati/packages/Debian/dists/sid/fglrx-ac-aticonfig
ati/packages/Debian/dists/sid/fglrx-lid-aticonfig
ati/packages/Fedora/a-ac-aticonfig
ati/packages/Fedora/a-lid-aticonfig
ati/packages/Ubuntu/dists/breezy/fglrx-ac-aticonfig
ati/packages/Ubuntu/dists/breezy/fglrx-lid-aticonfig
ati/packages/Ubuntu/dists/dapper/fglrx-ac-aticonfig
ati/packages/Ubuntu/dists/dapper/fglrx-lid-aticonfig
ati/packages/Ubuntu/dists/edgy/fglrx-ac-aticonfig
ati/packages/Ubuntu/dists/edgy/fglrx-lid-aticonfig
ati/packages/Ubuntu/dists/feisty/fglrx-ac-aticonfig
ati/packages/Ubuntu/dists/feisty/fglrx-lid-aticonfig
ati/packages/Ubuntu/dists/gutsy/fglrx-ac-aticonfig
ati/packages/Ubuntu/dists/gutsy/fglrx-lid-aticonfig
ati/packages/Ubuntu/dists/hoary/fglrx-ac-aticonfig
ati/packages/Ubuntu/dists/hoary/fglrx-lid-aticonfig
ati/packages/Ubuntu/dists/warty/fglrx-ac-aticonfig
ati/packages/Ubuntu/dists/warty/fglrx-lid-aticonfig

olracdor 11-21-2007 06:04 AM

oh man! now when i use the web browser and scroll down its in slow motion! but evrythng seems to be fine. so now i have 2 problems the beryl and the slow motion scroll on the web browser.

olracdor 11-21-2007 06:07 AM

oh man man!! eveything seems to be in slow motion, when i drag a window its moving in slow motion to! is it my video card? or just the settings? thanks for the help so far

olracdor 11-21-2007 06:23 AM

how can i fix this?

Fantasio 11-21-2007 07:45 AM

parse your xorg.conf
did you try a reboot ?

driver for ati should be fglrx inspect your config file

olracdor 11-21-2007 07:54 AM

yep also tried rebooting and i checked if fglrx is set as the driver,everything is set. but the result is a slow motion desktop..

olracdor 11-21-2007 07:57 AM

its not the hardware is it? maybe there's something wrong with the video card


All times are GMT -5. The time now is 03:53 PM.