LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   video card on mobo not working correctly (https://www.linuxquestions.org/questions/linux-newbie-8/video-card-on-mobo-not-working-correctly-647683/)

Schulzy190 06-07-2008 03:16 PM

video card on mobo not working correctly
 
i have recently bought a computer and i have installed fedora 9 on it...video worked fine for the install but now when i boot up i have video until fedora is running then i have resolution problems. i have managed to get video on my gaming monitor but they are horrible. i have a asus p5n-mx mobo. please give me some ideas i have no idea what to do to fix this thanks in advance

Junior Hacker 06-07-2008 03:59 PM

Looks like a nice board.
Fedora may have configured itself to use the generic vesa driver for graphics. It appears you have integrated Nvidia graphics.
Try booting into single user mode, (not sure how with your current distribution's version) and edit the /etc/X11/xorg.conf file to use the generic Nvidia driver (nv). An example of the section to edit follows:
Code:

Section "Device"
    Identifier  "Generic video"
    Driver      "nv"
EndSection

For full features including 3D capabilities you should look at installing the proprietary Nvidia drivers/modules. Although I have not tried Fedora 8 or 9, with Fedora 7 it is recommended to setup the livna repository and install it with yum.
This mjm individual usually gives the best advice for setting up Fedora.

Schulzy190 06-07-2008 04:19 PM

i checked the file and it says the following
Code:

Section "Device"
    Identifier "Videocard0"
    Driver    "vesa"
End Section

should i change it to what has previously been posted?

thanks

i92guboj 06-07-2008 04:40 PM

Quote:

Originally Posted by Schulzy190 (Post 3177832)
i checked the file and it says the following
Code:

Section "Device"
    Identifier "Videocard0"
    Driver    "vesa"
End Section

should i change it to what has previously been posted?

thanks

If you want to get the best performance you should use nvidia instead of vesa or nv, as said above. I don't know how to install the propietary nvidia driver in fedora, but the previous poster gave you some hinst above.

Once you install the nvidia (not "nv", but "nvidia") driver correctly, you should addapt your xorg.conf like this:

Code:

Section "Device"
    Identifier "Videocard0"
    Driver    "nvidia"
    Option "HWcursor" "true"
    Option "RenderAccel" "true"
    Option "AllowGLXWithComposite" "true"
End Section

There are more options but with those you should be able to use any modern desktop without problems. Again, those extra options are just for the nvidia driver. They don't work with vesa or nv.

Schulzy190 06-07-2008 04:50 PM

i am having touble installing the driver...i am new to linux so bare with me here

Junior Hacker 06-08-2008 02:50 PM

Try changing out "vesa" for "nv". This will get you some graphics and start enjoying your new Linux installation. You can then tinker with the proprietary driver later at your own pace to get better graphics, at least you'll be able to use firefox to refer to web pages like the one I provided a link for to help you.
You need to edit the file as root.
When you boot up in single user mode or in a command line only environment, make sure you are root and issue this command to open the file in a editor: vim /etc/X11/xorg.conf, using the arrow keys scroll down to that section, using backspace to erase vesa, then insert nv in it's place. Then hit all together these three keys: Ctrl, Alt, semicolon, you should now have a semicolon appear at the bottom left of the screen, type: wq! to write the file, quit now.
Now try a reboot.


All times are GMT -5. The time now is 06:29 PM.