LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-14-2005, 12:36 PM   #1
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Rep: Reputation: 30
vesafb "passed an undefined mode number"


When my Arch system first boots up it tells me that I've passed an undefined mode number and tells me to press <return> to see the available modes or <space> to continue.

If I chosose option 4 (Mode: 0F05 COLSxROWS: 00x30), my resolution looks much better.

I've looked everywhere to figure out what I need to put in my grub.conf or menu.lst in order to have my system use the 4th mode automatically, but I cannot figure out how to do this.

Thanks.
 
Old 09-15-2005, 08:29 AM   #2
rjkfsm
Member
 
Registered: Apr 2004
Location: Charleston, SC
Distribution: Debian, Gentoo, Knoppix & DSL
Posts: 122

Rep: Reputation: 15
You can pass options to vesafb using "video=vesafb:option" on the kernel command line. Multiple options should be separated by comma, like this: "video=vesafb:ypan,1024x768-32@85"

Before you do this, you need to make sure vesa support is compiled into the kernel, not as a module. You can find more options in:
"/usr/src/linux/Documentation/fb/vesafb.txt"

This is my /boot/grub/grub.conf on my laptop (running Gentoo) as an example:

Code:
default 0
timeout 15
splashimage=(hd0,0)/grub/splash.xpm.gz

title=Gentoo Linux 2.6.12-r10
root (hd0,0)
kernel /bzImage.r10 quiet root=/dev/hda3 video=vesafb:ywrap,mtrr,1280x1024-32@85 splash=verbose,theme:livecd-2005.1 CONSOLE=/dev/tty1
boot

Last edited by rjkfsm; 09-15-2005 at 08:31 AM.
 
Old 09-16-2005, 04:06 AM   #3
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Original Poster
Rep: Reputation: 30
thanks.

I just don't can't figure out what option 4 translates to in all of that,

I've used that line in another computer woth succes, but that computer had a more common resolution.
 
Old 09-16-2005, 04:19 AM   #4
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
It is not easy to read, but it may contain the information you are looking for:
http://www.vesa.org/public/VBE/vbe3.pdf
 
Old 09-16-2005, 10:22 PM   #5
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Original Poster
Rep: Reputation: 30
wow, I found the solution. Srtting vga=788 solves the problem and now my screen resolution looks crisp and clean!

I'm so excited!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
You passed an undefined mode number & wheel mouse dave`2005 Linux - Newbie 8 08-28-2005 11:38 AM
You passed an undefined mode number priest_judas Linux - Newbie 12 02-08-2005 05:16 PM
You passed an undefined mode number priest_judas Linux - Hardware 3 12-11-2003 04:19 PM
Slack 9.1 - You passed an undefined mode number priest_judas Slackware 1 12-11-2003 07:56 AM
You have passed an undefined mode number. acidslut Slackware 5 08-17-2003 11:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration