-   Linux - Newbie (
-   -   Very basic question: how do I run a newly downloaded app? (

lhoff 06-25-2001 09:36 AM

Very basic question: how do I run a newly downloaded app?
I'm about a week old (new?) in my Linux Mandrake usership. I downloaded the Linux version of my favorite MP3 search agent the other day. I got this thing called a .tar.gz file. I concluded that that is an archive, like ZIP files on Windows.

Konqueror let me enter this file as though it were a directory. I moved the folder inside it to my usr/lib directory. Then, when I went to the usr/lib directory and entered this new subdirectory, double-clicking on the app did nothing.

I tried moving everything to usr/bin instead. Everything moved fine, but I still can't get the app to run.

Is there something different from what I would normally do in Windows that I must do to run an app I've downloaded from the internet? The file properties of this new file say that it's an executable...


jharris 06-25-2001 09:46 AM

Yeah, a tar.gz file is a lot like a .zip file - its actually a .tar file (TApe Archive) that been compressed with GZip...

You probably want to extract the .tar.gz file somewhere using

tar xvfz myFile.tar.gz
This will normally create a folder called myFile. Look in that directory for a README or INSTALL file. Read this and it will tell you how to install the application.

good luck


bobthebat 06-26-2001 06:05 PM

also just to clarify, when you download a program in .tar.gz format, you actually need to compile it and then install it, but this is not hard at all. Most of the time, the commands to to this are (you must be in the uncompressed directory and be root):

make install

sometimes there are extra options and such that will be described in the README or INSTALL files, as jharris said. After you install, an executable will be placed in your /usr/bin or /usr/bin/x11 or /usr/local/bin or some folder like that, and can be launched by just typing its name.

mcmunt 07-05-2001 07:43 PM

I understand the process for compiling or making apps, but when I try to ./configure or make an app I get a file not found error relating to the commands.
I've used "tar xvzf" to extract the source and moved the directory and su'd into root. I type in "make" and the shell returns "make: file not found". Now I've searched my Madrake 8.0 install for configure or make but can't find a thing. What do I have to install/download to get these commands running??


trickykid 07-06-2001 08:59 AM

Is it the proper way of installing if you read the INSTALL or README files on the file you downloaded.

Have you tried the full path when using the make or whatever command? Or are you in the present directory of that newly downloaded program?

mcmunt 07-06-2001 07:06 PM

Thanks for the reply TrickyKid. The app I'm trying to build is gkrellmoon from freshmeat. INSTALL file says to just do a "make" then a "make install".
Found out I hadn't installed the files for "make" which is why I had the files not found message - duh! But now when make tries to build the files I get a couple more commands not found: gtk-config and imlib-config. So I'm about to go hunting for those.
At least I'm heading in the right direction.;)

All times are GMT -5. The time now is 05:47 PM.