LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   /usr/bin/ld: cannot find -lc (https://www.linuxquestions.org/questions/linux-newbie-8/usr-bin-ld-cannot-find-lc-191157/)

aa2bi 06-08-2004 01:10 PM

/usr/bin/ld: cannot find -lc
 
Hi there.

I'm trying to install RQLv2.1 in Mandrake 9.0.

./configure runs OK, and 'make' stops in this:

gcc -g -O2 -Bstatic -r -L/usr//bin/../lib -L///usr//bin/../lib/gcc-lib/i586-mandrake-linux-gnu/3.2 -L./lib -L../lib -L/usr/local/pgsql/lib -L/usr/local/pgsql/lib/postgresql graph_constructor.c /bin/graph_constructor.o -o graph_constructor

/usr/bin/ld: cannot find -lc

As you can see, the problem is the last line. Is there anything I can do?

Thanks for your time,
Tony

m_yates 06-08-2004 04:50 PM

You are missing some needed development package that provides libc.a From the Mandrake control center, look for a package to install that begins with "glibc-devel...." Try installing it and then try re-compiling RQLv2.1. Hope that works.

aa2bi 06-09-2004 06:32 AM

Hi there m_yates.

OK, I fixed it. I don't know why, but as you said, glibc packages were not installed. So, I did, and it worked fine.

Thanks for your help!!


All times are GMT -5. The time now is 04:55 PM.