LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-02-2017, 08:28 PM   #1
keithht
LQ Newbie
 
Registered: Feb 2011
Posts: 2

Rep: Reputation: 0
Cool Using usb speakers in Linux


Hi Community, I am old (71) but spent over 40 years in IT, some of it in UNIX admin I retired over 10 years ago having started in IT in 1968 on a mainframe that cost the government between 5 and 10 million pounds which would be outperformed many times by my Windows phone.
I need a simple step by step method to use my Logitech usb speakers in Linux I would be very grateful.....
Cheers Keith Tomlinson
 
Old 03-02-2017, 08:32 PM   #2
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,375

Rep: Reputation: 217Reputation: 217Reputation: 217
You are going to have to supply more information than that, like what distribution of linux you are using and if you are using a desktop manager such as gnome, kde, etc.

Personally I'd first check dmesg to see what got inserted for the speakers themselves.
 
Old 03-02-2017, 08:40 PM   #3
notKlaatu
Senior Member
 
Registered: Sep 2010
Location: Lawrence, New Zealand
Distribution: Slackware
Posts: 1,075

Rep: Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725
Generally:

1. Plug in your speakers.
2. Open System Settings > Sound (or 'pavucontrol' from a terminal or application menu)
3. In pavucontrol, select Playback tab
4. Set playback to the USB device

Done.

As r3sistance says, though, knowing what distribution and your desktop is probably more useful than, say, your history with mainframes :-)
 
Old 03-02-2017, 10:11 PM   #4
rokytnji
LQ Veteran
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 19
Posts: 5,930
Blog Entries: 21

Rep: Reputation: 2966Reputation: 2966Reputation: 2966Reputation: 2966Reputation: 2966Reputation: 2966Reputation: 2966Reputation: 2966Reputation: 2966Reputation: 2966Reputation: 2966
Type alsamixer in terminal in case it is installed. hit enter key after typing that in

Use the arrow keys to adjust slider controls.

Use the m key to unmute or mute.

Above instructions only cover alsa. I don't use pulseaudio like mentioned above

Code:
.$ apt-cache policy pulseaudio
pulseaudio:
  Installed: (none)
  Candidate: 5.0-13.0nosystemd1
  Version table:
     5.0-13.0nosystemd1 0
        500 http://antix.daveserver.info/jessie/ jessie/nosystemd i386 Packages
     5.0-13 0
        500 http://ftp.gr.debian.org/debian/ jessie/main i386 Packages
Depending on what desktop environment you are running. There should be a speaker icon on the taskbar. Just like on Windows. No? You should be able to turn up the volume that way also. Logitech usb speakers are plug and play in linux. just like windows.
 
Old 03-03-2017, 02:02 AM   #5
JJJCR
Senior Member
 
Registered: Apr 2010
Posts: 1,645

Rep: Reputation: 278Reputation: 278Reputation: 278
Hi Keith, this link may help: http://askubuntu.com/questions/79124...s-consistently
 
Old 03-03-2017, 11:43 AM   #6
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Xubuntu
Posts: 5,438

Rep: Reputation: 1894Reputation: 1894Reputation: 1894Reputation: 1894Reputation: 1894Reputation: 1894Reputation: 1894Reputation: 1894Reputation: 1894Reputation: 1894Reputation: 1894
Welcome to the forum!

Firstly, make sure your usb device is plugged in before you boot up the computer. Then try the sound, using youtube or whatever.

If you can't hear anything, don't worry: a few distros come with the sound turned off (yes, really!) Look in your menu for a sound control, hardware control, or a configuration centre (I can't say where, because it depends on what you installed). If the sound is set to mute, un-mute and try again.

If that has no effect, the sound tool should have options like "hardware", or "input" and "output" where you can select the device. Select "usb" and "analog output".

If that doesn't work, then there's a little more to do. If your desktop is KDE, you may find that the sound configuration works for KDE's own programs but not for Firefox or Chrome, for example.

First, find the tool in the menu for managing users and groups. Run that and join the "audio" group. That's only needed on a few distros, but it won't do any harm to join if it isn't.

Now look in the folder /etc/modprobe.d/ for something like alsa-base.conf. Search that file for a line like "options snd-usb-audio index=-2". If it's there (and I've seen it occur twice, so check carefully) delete it. Then reboot the computer and see it the problem has gone.

If not, try the command "aplay -l". If it includes something like
card 1: Device [USB Audio Device], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
then sound is going to whatever is listed as Card 0. Create a file in your home directory called ".asoundrc" containing
defaults.pcm.card 1
defaults.pcm.device 0
defaults.ctl.card 1
and log out and in again.

If you still have no sound, find the names of the sound modules in the kernel with
$ cat /proc/asound/modules

If the module for the device you want (like snd_usb_audio) is not there, look in /lib/modules/[Linux version number]/kernel/sound/ to see if you’ve got it. If you haven’t, you need to get it from your distro: it must be compiled for the version of the kernel that you’re using. If you have it, then it wasn’t loaded, probably because it’s faulty.

If you’ve got the module loaded, you can try blocking the modules for unwanted devices from loading. Look in /etc/modprobe.d/ for something like blacklist.conf
Edit it, adding lines like
blacklist snd_cmipci
for each unwanted module. Then remove .asoundrc and reboot. In one case I heard of, the devices were sometimes being recognised in a different order when the computer was booted, so .asoundrc would give the wrong number: this fixed the problem.

Last edited by DavidMcCann; 03-03-2017 at 11:44 AM.
 
1 members found this post helpful.
Old 03-06-2017, 05:34 AM   #7
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,003
Blog Entries: 1

Rep: Reputation: 847Reputation: 847Reputation: 847Reputation: 847Reputation: 847Reputation: 847Reputation: 847
From CLI based tools

$ pavucontrol

The above for pulseaudio's configuration tool. And turn OFF everything you don't want to use.

$ cat /proc/asound/cards

FILE:.asoundrc
Code:
defaults.ctl.card 1
defaults.pcm.card 1
defaults.pcm.device 3
The above for alsa natively. The rough equivalent to -D hw:1,3 for speaker-test, aplay, and other players / test tools. Where ,3 is often the HDMI out. Adjust to needs based on the contents of /proc/asound/cards, or the more verbose output of other things. With -D hw:0,0 being the default out in the absence of a .asoundrc file.

If you're running one of those fancy desktops, you probably have something akin to a menu item ... Menu -> System -> Settings -> Audio -> ..and 15 layers later.. something that "might" work, and break again on tomorrows update. Or a 16px x 16px speaker icon on the bar which looks like little more than a spec of dust on a 4K display.
 
Old 03-07-2017, 11:08 AM   #8
keithht
LQ Newbie
 
Registered: Feb 2011
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by keithht View Post
Hi Community, I am old (71) but spent over 40 years in IT, some of it in UNIX admin I retired over 10 years ago having started in IT in 1968 on a mainframe that cost the government between 5 and 10 million pounds which would be outperformed many times by my Windows phone.
I need a simple step by step method to use my Logitech usb speakers in Linux I would be very grateful.....
Cheers Keith Tomlinson
Hi again, I accept the comment re: my short history, it was really an attempt to introduce myself to the community and say hello.

The distro I am using is : Mint 18 Cinnamon and the desktop seems to be KDE.......cheers Keith
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB speakers with Linux Mint 11 Naimbora Linux Mint 3 11-22-2015 10:46 AM
Does any Linux distro support USB speakers.... sbarr Linux - Hardware 4 10-15-2006 03:31 AM
I need help with my USB Speakers Delicate_Shadow Linux - Hardware 2 08-23-2006 04:39 PM
USB Speakers Help Delicate_Shadow Linux - Hardware 0 05-10-2006 03:50 PM
Will USB Speakers work? weijie90 Linux - Hardware 1 04-21-2006 07:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration